File: kopano-webapp-lighttpd.postinst.in

package info (click to toggle)
kopano-webapp 3.5.14+dfsg1.orig-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 45,160 kB
  • sloc: php: 35,994; xml: 2,116; sh: 436; makefile: 370; java: 300; python: 152; ruby: 14
file content (56 lines) | stat: -rwxr-xr-x 2,118 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
#!/bin/sh

# postinst script for kopano-webapp-lighttpd
# see: dh_installdeb(1)

# summary of how this script can be called:
#                           --- $1 ---          --- $2 ---     --- $3 ---               --- $4 ---
#            <new-postinst> 'configure'         <most-recently-configured-version>
#            <old-postinst> 'abort-upgrade'     <new version>
#   <conflictor's-postinst> 'abort-remove'      'in-favour'     <package>                <new-version>
#                <postinst> 'abort-remove'
# <deconfigured's-postinst> 'abort-deconfigure' 'in-favour'     <failed-install-package> <version>     'removing' <conflicting-package> <version>
#
# for details, see http://www.debian.org/doc/debian-policy/ or the
# debian-policy package

set -e
#set -x # uncomment for verbose output

PHPVERSION="@version@"
PACKAGE_ETC_FOLDER="/etc/kopano/webapp"

case "$1" in
    configure)
        if [ -e /usr/lib/php/php-maintscript-helper ]; then
            . /usr/lib/php/php-maintscript-helper

            # Calling php_invoke to enable 'mapi' for the PHP module cgi
            php_invoke enmod ${PHPVERSION} cgi mapi
        fi
        # Handle the lighttpd modules
        if [ -x "`which lighty-enable-mod`" ]; then
            echo "[kopano-webapp-lighttpd] Add symlink for Lighttpd config file..."
            if [ ! -L /etc/lighttpd/conf-available/50-kopano-webapp.conf ]; then
                ln -s ${PACKAGE_ETC_FOLDER}/lighttpd.conf /etc/lighttpd/conf-available/50-kopano-webapp.conf
            fi
            # We need some modules enabled, but let this all to the user.
            # Note /usr/share/doc/kopano-webapp-lighttpd/README.Debian
            #lighty-enable-mod accesslog kopano-webapp fastcgi-php mod_alias || true
            echo "[kopano-webapp-lighttpd] Not enable Lighttpd configuration by default!"
            echo "Please note /usr/share/doc/kopano-webapp-lighttpd/README.Debian"
        fi
    ;;

    abort-upgrade|abort-remove|abort-deconfigure)
    ;;

    *)
        echo "postinst called with unknown argument \`$1'" >&2
        exit 1
    ;;
esac

#DEBHELPER#

exit 0