File: changelog

package info (click to toggle)
ktp-text-ui 17.08.3-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 5,792 kB
  • sloc: cpp: 12,672; sh: 21; makefile: 8
file content (190 lines) | stat: -rw-r--r-- 6,935 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
ktp-text-ui (17.08.3-2) unstable; urgency=medium

  * Team upload.
  * Switch Vcs-* fields to salsa.debian.org.
  * Bump the debhelper compatibility to 11:
    - bump the debhelper build dependency to 11~
    - bump compat to 11
  * Use https for Format in copyright.
  * Bump Standards-Version to 4.1.4, no changes required.
  * Add the libqt5texttospeech5-dev build dependency, to enable the
    text-to-speech functionality.

 -- Pino Toscano <pino@debian.org>  Tue, 08 May 2018 20:10:27 +0200

ktp-text-ui (17.08.3-1) unstable; urgency=medium

  * Team upload.
  * Upload to unstable.
  * New upstream release.
  * Bump Standards-Version to 4.1.2, no changes required.
  * Simplify watch file, and switch it to https.
  * Bump telepathy-related build dependencies:
    - libktp-dev to >= 17.08.3
    - libtelepathy-logger-qt-dev to >= 17.08
    - libtelepathy-qt5-dev to >= 0.9.7
  * Remove unused build dependencies: libkf5wallet-dev, libkf5webkit-dev,
    libqjson-dev, libqt5webkit5-dev, and libqtwebkit-dev.
  * Simplify the way any bindled jquery.js is replaced with a symlink to the
    system version: dynamically search and replace any file, instead of
    maintaining a static list
    - drop the usage of dh_linktree, and the dh-linktree build dependency
    - remove the libjs-jquery build dependency, as it is not needed during
      build
  * Update lintian overrides.
  * Adjust l10npkgs_firstversion_ok to the version where kde-l10n will
    drop translations.

 -- Pino Toscano <pino@debian.org>  Sat, 09 Dec 2017 09:04:15 +0100

ktp-text-ui (17.08.1-1) experimental; urgency=medium

  * New upstream release (17.08.1).
  * Drop soon to be deprecated fail-missing
  * Add breaks/replaces against the kde-l10n packages
  * Release to experimental

 -- Maximiliano Curia <maxy@debian.org>  Mon, 11 Sep 2017 19:59:20 +0200

ktp-text-ui (16.04.2-1) experimental; urgency=medium

  * New upstream release.

 -- Maximiliano Curia <maxy@debian.org>  Fri, 24 Jun 2016 09:43:33 +0200

ktp-text-ui (16.04.1-1) experimental; urgency=medium

  [ Automatic packaging ]
  * Bump Standards-Version to 3.9.8
  * Update build-deps and deps with the info from cmake
  * Add a .gitattributes file to use dpkg-mergechangelogs

  [ Maximiliano Curia ]
  * Add new lintian-override for the private library

 -- Maximiliano Curia <maxy@debian.org>  Sat, 28 May 2016 02:14:35 +0200

ktp-text-ui (15.12.1-2) experimental; urgency=medium

  * Bump build dependencies.

 -- Maximiliano Curia <maxy@debian.org>  Sat, 13 Feb 2016 09:04:32 +0100

ktp-text-ui (15.12.1-1) experimental; urgency=medium

  [ Maximiliano Curia ]
  * Update watch file.
  * Bump Standards-Version to 3.9.6.
  * New upstream release (15.12.0).
  * New upstream release (15.12.1).

 -- Maximiliano Curia <maxy@debian.org>  Mon, 01 Feb 2016 10:22:47 +0100

ktp-text-ui (15.08.3-1) unstable; urgency=medium

  * New upstream release.
  * Use version of libkf5emoticons that forces emoticons-bin dependency
    (Closes: #805453)

 -- Diane Trout <diane@ghic.org>  Sat, 05 Dec 2015 11:08:11 -0800

ktp-text-ui (15.08.2-1) unstable; urgency=medium

  * Update watch file for KTp's move to Applications
  * New upstream release. (Closes: #784489)
  * Update build-depends for KF5 and rename of
    libktpcommoninternalsprivate-dev to libktp-dev
  * Update copyright file
    - Remove Files-Excluded, upstream fixed
    - Remove cmake/* as it was removed
    - Remove all of the po/* blocks
  * Use dhmk from pkg-kde-tools to build ktp.
    - Change maintainer to debian-qt-kde
    - Update debian/rules
  * Remove kde-telepathy-text-ui.links scriptaculous was removed and
    jquery is being handled by kde-telepathy-text-ui.linktree
  * Update install paths for KF5 locations.
  * Don't apply 02_ktpchat_soversion.diff
    Remove diffs no longer being applied.
  * Add KDE's unstable download url to watch file
  * Use dh-linktree to use to replace jquery.js files.
  * Add dependency on libjs-jquery to provide replacement jquery.js
  * Update lintian-overrides for move to multiarch.
  * Update Build-Depends to use telepathy-qt5-dev

 -- Diane Trout <diane@ghic.org>  Sat, 07 Nov 2015 11:02:45 -0800

ktp-text-ui (0.9.0+dfsg-1) unstable; urgency=medium

  [ Diane Trout ]
  * New upstream release.
  * Update libtelepathy-qt build-dep to 0.9.5
  * Update libktpcommoninternalsprivate-dev build-dep to 0.9.0
  * Update libtelepathy-logger-qt build-dep to 0.8.0
  * Add libkpeople-dev 0.3 build-dep
  * Change to using .install file and default dh_auto_install behavior
    - this makes dh_install --list-missing more reliable.
  * Update version number in lintian-override
  * Update copyright file
  * Prevent another license file from being installed into usr/lib
  * Use libjs-jquery (>= 1.7) and libjs-scriptaculous (>= 1.8.2)
    instead of minimized copies provided by upstream.
  * Update copyright file
  * Update Standards-Version to 3.9.6. No changes needed.
  * Build dfsg version to remove minimized js source files:
    jquery.min.js and scriptaculous183.js

 -- Diane Trout <diane@ghic.org>  Wed, 20 May 2015 22:26:23 -0700

ktp-text-ui (0.8.1-1) unstable; urgency=low

  * New upstream release
  * Update Standards-Version to 3.9.5. No changes needed.
  * Bump ktp-common-internals and kde-telepath-data dependencies to 0.8.1
  * Remove 04_no_require_x11.patch
  * Update debian/copyright

 -- Diane Trout <diane@ghic.org>  Fri, 16 May 2014 21:06:46 -0700

ktp-text-ui (0.7.0-1) unstable; urgency=low

  * New upstream release.
  * Add libqjson-dev Build-Depends.
  * Add 04_no_require_x11.patch from upstream
  * Bump ktp-common-internals and kde-telepath-data dependencies to 0.7.0

 -- Diane Trout <diane@ghic.org>  Wed, 27 Nov 2013 18:16:56 -0800

ktp-text-ui (0.6.3-1) unstable; urgency=low

  [ Ritesh Raj Sarraf ]
  * [e26f6a8] drop patch 03_no_redundant_glib_calls.diff
  * [459ee64] Drop tests, for now, as they are failing

  [ Diane Trout ]
  * Update watch file as KDE-Telepathy is now in stable release.
  * Bump ktp-common-internals version
  * Plasma-widget-telpathy-chat was moved to ktp-desktop-applet
  * Add telepathy-logger dependency
  * Imported Upstream version 0.6.2.1
  * Refresh patches
  * Bump ktp-common-internal dependency
  * Set Uploaders to Diane Trout and Michał Zając
  * Update to Standards-Version 3.9.4. No changes needed.
  * Add several plugins to kde-telepathy-text-ui.install
  * Add description to 02_ktpchat_soversion.diff
  * Merge libktpchat0 into ktp-telepathy-text-ui.
  * Override lintian warnings about the libktpchat0 library.

  [ Mark Purcell ]
  * Imported Upstream version 0.6.3
  * Add myself to Uploaders
  * Update Build-Depends: libktpcommoninternalsprivate-dev (>= 0.6.3)

 -- Mark Purcell <msp@debian.org>  Sun, 11 Aug 2013 11:01:09 +1000

ktp-text-ui (0.4.0-1) unstable; urgency=low

  * Initial release.

 -- George Kiagiadakis <kiagiadakis.george@gmail.com>  Mon, 18 Jun 2012 22:27:06 +0300