File: dist.ini

package info (click to toggle)
libany-moose-perl 0.27-2
  • links: PTS, VCS
  • area: main
  • in suites: bookworm, bullseye, buster, sid, stretch
  • size: 356 kB
  • ctags: 13
  • sloc: perl: 401; makefile: 2
file content (60 lines) | stat: -rw-r--r-- 1,882 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
name    = Any-Moose
author  = Shawn M Moore <code@sartak.org>
author  = Florian Ragwitz <rafl@debian.org>
author  = Stevan Little <stevan@iinteractive.com>
author  = 藤 吾郎 (Fuji Goro) <gfuji@cpan.org>
license = Perl_5
copyright_holder = Best Practical Solutions
copyright_year   = 2009

[@Author::ETHER]
:version = 0.097
installer = MakeMaker   ; MBT does not like dynamic_config = 1
Authority.authority = cpan:SARTAK
Test::MinimumVersion.max_target_perl = 5.006002
-remove = PodCoverageTests
-remove = Test::CleanNamespaces
Test::ReportPrereqs.include[0] = Class::MOP
Test::ReportPrereqs.include[1] = Moose
Test::ReportPrereqs.include[2] = MooseX::Types
Test::ReportPrereqs.include[3] = Mouse
Test::ReportPrereqs.include[4] = MouseX::Types
Test::ReportPrereqs.include[5] = Moo
Test::ReportPrereqs.include[6] = Role::Tiny
Test::Compile.:version = 2.055
Test::Compile.switch = -M-warnings=deprecated
StaticInstall.dry_run = 0   ; we have dynamic prereqs, so x_static_install => 0

[MetaResources]
x_IRC = irc://irc.perl.org/#moose
x_MailingList = http://lists.perl.org/list/moose.html

[RemovePrereqs]
remove = Moose
remove = Mouse
remove = Mouse::Util

[OnlyCorePrereqs]
starting_version = 5.006
check_dual_life_versions = 0

[DynamicPrereqs]
:version = 0.018
-delimiter = |
-body = |if (eval { require Moose }) {
-body = |  # we have any version of Moose; good enough! -- rjbs, 2011-09-15
-body = |  # This should fix a crufty edge-case with cpantesting -- bingos, 2011-11-07
-body = |  requires('Moose', '0');
-body = |} else {
-body = |  # No Moose?  Well, we need *something* to test with, so we'll ask for the
-body = |  # lighter-weight one, Mouse. -- rjbs, 2011-09-15
-body = |  requires('Mouse', '0.40');
-body = |}

[Test::CheckBreaks]
:version = 0.017
no_forced_deps = 1
conflicts_module = Moose::Conflicts
conflicts_module = Module::Runtime::Conflicts

[Deprecated]