File: changelog

package info (click to toggle)
libarchive-zip-perl 1.59-1+deb9u1
  • links: PTS, VCS
  • area: main
  • in suites: stretch
  • size: 976 kB
  • sloc: perl: 5,036; makefile: 9
file content (388 lines) | stat: -rw-r--r-- 13,849 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
370
371
372
373
374
375
376
377
378
379
380
381
382
383
384
385
386
387
388
libarchive-zip-perl (1.59-1+deb9u1) stretch-security; urgency=high

  * Non-maintainer upload by the Security Team.
  * Prevent from traversing symlinks and parent directories when extracting
    (CVE-2018-10860) (Closes: #902882)
  * Extract test files needed for t/25_traversal.t test.
    Add zip files to debian/t/data directory and add them to
    debian/sorce/include-binaries to include those in the debian tarball.
    Add an override for dh_auto_test to copy debian/t/data/*.zip testfiles
    to test directory prior to running the testsuite.
    Clean test files needed for t/25_traversal.t in dh_clean

 -- Salvatore Bonaccorso <carnil@debian.org>  Fri, 21 Sep 2018 17:17:23 +0200

libarchive-zip-perl (1.59-1) unstable; urgency=medium

  * Import upstream version 1.59

 -- Salvatore Bonaccorso <carnil@debian.org>  Fri, 12 Aug 2016 22:13:05 +0200

libarchive-zip-perl (1.58-1) unstable; urgency=medium

  [ gregor herrmann ]
  * Change bugtracker URL(s) to HTTPS.
  * debian/copyright: change Copyright-Format 1.0 URL to HTTPS.

  [ Salvatore Bonaccorso ]
  * Import upstream version 1.58
  * Declare compliance with Debian policy 3.9.8

 -- Salvatore Bonaccorso <carnil@debian.org>  Tue, 02 Aug 2016 21:59:05 +0200

libarchive-zip-perl (1.57-1) unstable; urgency=medium

  * debian/control: Use HTTPS transport protocol for Vcs-Git URI
  * Import upstream version 1.57
  * Update copyright years for debian/* packaging files
  * Declare compliance with Debian policy 3.9.7

 -- Salvatore Bonaccorso <carnil@debian.org>  Sat, 02 Apr 2016 14:34:48 +0200

libarchive-zip-perl (1.56-2) unstable; urgency=medium

  * Upload to unstable

 -- Salvatore Bonaccorso <carnil@debian.org>  Sat, 02 Jan 2016 13:34:47 +0100

libarchive-zip-perl (1.56-1) experimental; urgency=medium

  * Import upstream version 1.56

 -- Salvatore Bonaccorso <carnil@debian.org>  Sun, 20 Dec 2015 08:00:15 +0100

libarchive-zip-perl (1.55-1) unstable; urgency=medium

  * Team upload.
  * Rename autopkgtest configuration file(s) as per new pkg-perl-
    autopkgtest schema.
  * Import upstream version 1.55.
  * Add new build dependency: libtest-mockmodule-perl.

 -- gregor herrmann <gregoa@debian.org>  Sat, 05 Dec 2015 19:46:00 +0100

libarchive-zip-perl (1.53-1) unstable; urgency=medium

  * Import upstream version 1.53

 -- Salvatore Bonaccorso <carnil@debian.org>  Wed, 23 Sep 2015 22:41:29 +0200

libarchive-zip-perl (1.51-1) unstable; urgency=medium

  * Import upstream version 1.51

 -- Salvatore Bonaccorso <carnil@debian.org>  Tue, 22 Sep 2015 10:16:40 +0200

libarchive-zip-perl (1.50-1) unstable; urgency=medium

  * Team upload.

  [ Salvatore Bonaccorso ]
  * Import upstream version 1.50

  [ gregor herrmann ]
  * Remove Matthias Klose from Uploaders on his request.
  * Bump debhelper compatibility level to 9.

 -- gregor herrmann <gregoa@debian.org>  Fri, 04 Sep 2015 22:53:21 +0200

libarchive-zip-perl (1.49-1) unstable; urgency=low

  * Import upstream version 1.49
    + Fixes "Failure on unseekable file handle after desiredCompressionLevel()
      is called" (Closes: #600848, #618780)

 -- Salvatore Bonaccorso <carnil@debian.org>  Sat, 01 Aug 2015 07:15:44 +0200

libarchive-zip-perl (1.48-1) unstable; urgency=medium

  * Import upstream version 1.48
  * Update copyright years for debian/* packaging files

 -- Salvatore Bonaccorso <carnil@debian.org>  Fri, 19 Jun 2015 07:09:43 +0200

libarchive-zip-perl (1.47-1) unstable; urgency=medium

  * Team upload.

  [ gregor herrmann ]
  * Update Repository URL in debian/upstream/metadata.
  * Import upstream version 1.46.
  * Update years of packaging copyright.
  * Drop debian/tests/pkg-perl/skip-smoke.
    Contains only commented out lines.

  [ Niko Tyni ]
  * Drop fix for deflated empty files, fixed in a different way upstream

  [ gregor herrmann ]
  * Import upstream version 1.47
  * Drop 0002-TODO-test-for-rt.cpan.org-73797-deflated-empty-file-.patch.
    Not necessary any more.
  * Drop debian/t/data/jar.zip after the test using it was removed.
    Also remove all occurences of it in debian/*.

 -- gregor herrmann <gregoa@debian.org>  Thu, 18 Jun 2015 18:44:35 +0200

libarchive-zip-perl (1.39-1) unstable; urgency=medium

  * Team upload.
  * Import upstream version 1.39
  * Refresh patches (offset, renamed file, whitespace defuzzying).
  * Update years of packaging copyright.
  * Mark package as autopkgtest-able.
  * Declare compliance with Debian Policy 3.9.6.

 -- gregor herrmann <gregoa@debian.org>  Wed, 22 Oct 2014 21:12:14 +0200

libarchive-zip-perl (1.38-1) unstable; urgency=medium

  * Update Vcs-Browser URL to cgit web frontend
  * Add debian/upstream/metadata
  * Imported upstream version 1.38

 -- Salvatore Bonaccorso <carnil@debian.org>  Wed, 03 Sep 2014 07:43:22 +0200

libarchive-zip-perl (1.37-2) unstable; urgency=medium

  * Team upload.
  * d/copyright: Add documentation around the Info-ZIP license

 -- Harlan Lieberman-Berg <H.LiebermanBerg@gmail.com>  Tue, 25 Mar 2014 16:34:46 -0400

libarchive-zip-perl (1.37-1) unstable; urgency=low

  * Team upload.

  [ gregor herrmann ]
  * Strip trailing slash from metacpan URLs.

  [ Harlan Lieberman-Berg ]
  * New upstream version.
  * Imported Upstream version 1.37
  * Bump S-V to 3.9.5.
  * Delete patches applied upstream and refresh remaining patches.

  [ gregor herrmann ]
  * Drop libtest-*-perl build dependencies which aren't needed anymore,
    since the tests are removed.

 -- Harlan Lieberman-Berg <H.LiebermanBerg@gmail.com>  Tue, 25 Mar 2014 12:59:08 -0400

libarchive-zip-perl (1.30-7) unstable; urgency=low

  * Team upload.

  [ Salvatore Bonaccorso ]
  * Change Vcs-Git to canonical URI (git://anonscm.debian.org)
  * Change search.cpan.org based URIs to metacpan.org based URIs

  [ gregor herrmann ]
  * Put test file jar.zip into debian/ instead of creating it with quilt.
    Newer versions of patch don't apply git binary patches. Thanks to
    Jakub Wilk for the bug report. (Closes: #711951)
  * debian/copyright: switch formatting to Copyright-Format 1.0.
  * Update {versioned,alternative} (build) dependencies.
  * Set Standards-Version to 3.9.4 (no further changes).

 -- gregor herrmann <gregoa@debian.org>  Wed, 12 Jun 2013 17:34:30 +0200

libarchive-zip-perl (1.30-6) unstable; urgency=low

  * Team upload.
  * Add debian/patches/000* to debian/patches/series. Additionally extract
    t/data/jar.zip manually from debian/patches/0002-* and add it to
    debian/source/include-binaries (quilt silently ignores the binary part
    in the patch). Thanks to Niko Tyni (Closes: #654899)
  * Add build dependency on unzip and zip, used in the test suite.
  * Add patch fix_clean_target.patch to make upstream's clean target work.
    Remove override from debian/rules. (Cf. #654901)

 -- gregor herrmann <gregoa@debian.org>  Wed, 22 Feb 2012 18:14:36 +0100

libarchive-zip-perl (1.30-5) unstable; urgency=low

  * Team upload.

  [ Ansgar Burchardt ]
  * debian/control: Convert Vcs-* fields to Git.

  [ Damyan Ivanov ]
  * rules: remove test-created files on clean
    Thanks to Wookey for the patch. (Closes: #654901)

  [ gregor herrmann ]
  * Add new patches 0001-Make-the-embedded-File-Which-which-work-in-BEGIN-
    blo.patch, 0002-TODO-test-for-rt.cpan.org-73797-deflated-empty-
    file-.patch, 0003-Fix-for-rt.cpan.org-73797-deflated-empty-file-
    direct.patch: keep empty file deflated. Thanks to Niko Tyni for
    analyzing the tricky issue and providing patches. (Closes: #654899)
  * Update years of packaging copyright.
  * Bump Standards-Version to 3.9.2 (no further changes).
  * debian/copyright: update header section.

 -- gregor herrmann <gregoa@debian.org>  Thu, 12 Jan 2012 23:15:49 +0100

libarchive-zip-perl (1.30-4) unstable; urgency=low

  [ gregor herrmann ]
  * Update patch fix_example_shebangs.patch to include yet another hashbang
    (closes: #601402).

  [ Ernesto Hernández-Novich (USB) ]
  * debian/control: updated Standards-Version; upgrade to DH8.
  * debian/compat: upgrade to DH8.
  * debian/copyright: update to DEP5; add and update copyright dates;
    set Upstream-Contact to current CPAN maintainer.

  [ Salvatore Bonaccorso ]
  * Email change: Salvatore Bonaccorso -> carnil@debian.org
  * debian/control: Make Build-Depends-Indep on libtest-cpan-meta-perl
    unversioned.

 -- Ernesto Hernández-Novich (USB) <emhn@usb.ve>  Tue, 01 Mar 2011 07:54:20 -0430

libarchive-zip-perl (1.30-3) unstable; urgency=low

  [ gregor herrmann ]
  * Remove Ben Burton from Uploaders on request of the MIA team
    (closes: #577665).

  [ Salvatore Bonaccorso ]
  * Convert to '3.0 (quilt)' package source format. Drop quilt framework for
    packaging. 
  * Refresh debian/copyright file.
  * debian/control: Re-oder the Build-Depends-Indep control file field.
  * Bump Standards-Version to 3.9.0 (no changes needed).
  * Add fix-spelling-error.patch patch to fix a small spelling error
    reported by lintian.

 -- Salvatore Bonaccorso <salvatore.bonaccorso@gmail.com>  Mon, 05 Jul 2010 10:25:32 +0200

libarchive-zip-perl (1.30-2) unstable; urgency=low

  * Add patch bumping required Perl minimum version in META.yml. Some tests
    for libarchive-zip-perl require 5.006, and the tests fail with newer
    libperl-minimumversion-perl (>= 1.22). Thanks to Lucas Nussbaum reporting
    the FTBFS (Closes: #560632).
  * Add myself to Uploaders. 
  * debian/copyright: Update to the current revision of the DEP5 machine
    readable format-specification proposal. 

 -- Salvatore Bonaccorso <salvatore.bonaccorso@gmail.com>  Sun, 13 Dec 2009 10:08:11 +0100

libarchive-zip-perl (1.30-1) unstable; urgency=low

  * New upstream release (Closes: 548963).
  * debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser
    field (source stanza); Homepage field (source stanza);
    ${misc:Depends} to Depends: field. Changed: Maintainer set to Debian
    Perl Group <pkg-perl-maintainers@lists.alioth.debian.org> (was: Ben
    Burton <bab@debian.org>); Ben Burton <bab@debian.org> moved to
    Uploaders. Updated Standards-Version. Added myself in Uploaders.
    Added quilt to Build-Depends: field.
  * debian/watch: use dist-based URL.
  * debian/rules: delete /usr/lib/perl5 only if it exists.
  * Added versioned dependencies on libcompress-raw-zlib-perl.
  * Remove unneeded dependencies on libfile-which-perl.
  * Added quilt patch to fix shebangs on example scripts (Closes: 543659).

 -- Ernesto Hernández-Novich (USB) <emhn@usb.ve>  Thu, 01 Oct 2009 10:46:15 -0430

libarchive-zip-perl (1.18-2) unstable; urgency=low

  * Take over for the Debian Perl Group on maintainer's request
    (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=548963#10)

 -- Ernesto Hernández-Novich (USB) <emhn@usb.ve>  Tue, 29 Sep 2009 19:22:49 -0430

libarchive-zip-perl (1.18-1) unstable; urgency=low

  * New upstream release.
  * Added build-depends on libfile-which-perl, which is now used in the test
    suite.
  * Removed Appnote.txt and appnote.iz from the source tarball, since these
    appear to be non-free.
  * Switched from debhelper compatibility level 3 to 5.  Moved debhelper
    dependency to Build-Depends (not Build-Depends-Indep) to support the
    clean target (thanks lintian).
  * Bumped standards-version to 3.7.2.2 (no changes required).

 -- Ben Burton <bab@debian.org>  Sun, 20 May 2007 09:04:44 +1000

libarchive-zip-perl (1.16-1) unstable; urgency=low

  * New upstream release (closes: #329494).
  * Run the test suite during the package build.  This requires an extra
    build-depends on libcompress-zlib-perl.
  * Bumped standards-version to 3.6.2.1 (no changes required).

 -- Ben Burton <bab@debian.org>  Wed,  5 Oct 2005 19:08:56 +1000

libarchive-zip-perl (1.14-2) unstable; urgency=low

  * Adopted by Ben Burton (closes: #314850).  Thanks to Ivo Timmermans
    and Matthias Klose for all their work on this package.
  * Clarified the copyright file by explicitly including the Perl license
    terms.
  * Changed double hyphen to a single hyphen in Tree.pm to avoid bad
    formatting in POD manpage (closes: #303022).
  * Added a manpage for /usr/bin/crc32.

 -- Ben Burton <bab@debian.org>  Mon, 20 Jun 2005 09:21:56 +1000

libarchive-zip-perl (1.14-1) unstable; urgency=high

  * New upstream version.
    - Fixes: Archive::Zip is fooled by manipulated ZIP directory
      Closes: #277773.

 -- Matthias Klose <doko@debian.org>  Sat, 30 Oct 2004 22:19:15 +0200

libarchive-zip-perl (1.13-2) unstable; urgency=low

  * Add watch file.

 -- Matthias Klose <doko@debian.org>  Sun, 19 Sep 2004 19:44:59 +0200

libarchive-zip-perl (1.13-1) unstable; urgency=high

  * NMU (needed as a dependency for mailscanner).

 -- Matthias Klose <doko@debian.org>  Sat, 28 Aug 2004 19:37:13 +0200

libarchive-zip-perl (1.12-0.1) unstable; urgency=low

  * NMU (needed as a dependency for mailscanner). Closes: #258198.

 -- Matthias Klose <doko@debian.org>  Fri,  9 Jul 2004 07:48:06 +0200

libarchive-zip-perl (1.10-0.1) unstable; urgency=low

  * NMU (needed as a dependency for mailscanner).
  * New upstream version (closes: #235788).
    - Better handling of broken archives (closes: #218932).

 -- Matthias Klose <doko@debian.org>  Mon, 28 Jun 2004 18:31:23 +0200

libarchive-zip-perl (1.05-1) unstable; urgency=low

  * New upstream release.  (Closes: #192051)
  * debian/control:
      - Update Standards-Version;
      - Set Section to perl.

 -- Ivo Timmermans <ivo@debian.org>  Mon,  5 May 2003 23:54:26 +0200

libarchive-zip-perl (1.01-1) unstable; urgency=low

  * New upstream release. (Closes: #145273)
  * Renamed Build-Depends to Build-Depends-Indep.

 -- Ivo Timmermans <ivo@debian.org>  Sun, 19 May 2002 00:39:23 +0200

libarchive-zip-perl (0.11-1) unstable; urgency=low

  * Initial Release. (Closes: #99768)

 -- Ivo Timmermans <ivo@debian.org>  Mon, 18 Jun 2001 14:36:39 +0200