File: dist.ini

package info (click to toggle)
libb-hooks-endofscope-perl 0.13-1
  • links: PTS, VCS
  • area: main
  • in suites: jessie, jessie-kfreebsd
  • size: 268 kB
  • ctags: 16
  • sloc: perl: 320; makefile: 7
file content (47 lines) | stat: -rw-r--r-- 1,183 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
name    = B-Hooks-EndOfScope
author  = Florian Ragwitz <rafl@debian.org>
author  = Peter Rabbitson <ribasushi@cpan.org>
license = Perl_5
copyright_year = 2008
copyright_holder = Florian Ragwitz

[@Author::ETHER]
installer = none    ; we supply our own, below
-remove = AutoPrereqs
-remove = PodCoverageTests  ; TODO
-remove = PodWeaver ; we are surgical instead
Authority.authority = cpan:FLORA
Git::Tag.tag_format = %v
Git::NextVersion.version_regexp = ^(.+)$
Test::Version.has_version = 0   ; for internal modules (FIXME: new option forthcoming)
Test::MinimumVersion.max_target_perl = 5.008001

[SurgicalPodWeaver]

[Prereqs]
Module::Runtime = 0.012
Sub::Exporter::Progressive = 0.001006
Module::Implementation = 0.05

[Prereqs / TestRequires ]
; provide done_testing()
Test::More    = 0.88

[Prereqs / ConfigureRequires ]
; for proper can_xs
; <xdg> ribasushi, I think you want EU::CB 0.26 minimum
ExtUtils::CBuilder = 0.26

[Prereqs / RuntimeRecommends]
Variable::Magic = 0.48

[Prereqs / DevelopRequires]
Devel::Hide = 0.0007

[Meta::Dynamic::Config]

; see Makefile.PL for lots of magic
[MakeMaker::Custom]

; authordep Pod::Weaver::Section::Contributors
[ContributorsFromGit]