File: README.source

package info (click to toggle)
libchado-perl 1.31-5
  • links: PTS, VCS
  • area: main
  • in suites: buster
  • size: 44,716 kB
  • sloc: sql: 282,721; xml: 192,553; perl: 25,524; sh: 101; python: 73; makefile: 56
file content (13 lines) | stat: -rw-r--r-- 858 bytes parent folder | download | duplicates (5)
1
2
3
4
5
6
7
8
9
10
11
12
13
Chado is patched to adapt to Debian file system hierarchy, using quilt.
For more info on quilt, see /usr/share/doc/quilt/README.source.

Regarding lintian warnings:
W: libchado-perl: maintainer-script-ignores-errors postinst
  Errors are not ignored, errors are catched in the script as some error codes are a correct behaviour in scripts.
  Other error codes are thrown as usual

W: libchado-perl: package-contains-upstream-install-documentation usr/share/doc/libchado-perl/INSTALL.Chado.gz
 Lintian override:
 INSTALL doc is required for database optimization setup and manual schema installation if automatic setup was not used.

Binaries tools are not set in /usr/bin but under /usr/share/gmod/chado/bin because part of those scripts are used by other gmod tools, not necessarly with same version and not necessarly all same tools, leading to conflicts.