File: changelog

package info (click to toggle)
libclass-meta-perl 0.66-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid, stretch
  • size: 660 kB
  • ctags: 152
  • sloc: perl: 5,886; makefile: 2
file content (164 lines) | stat: -rw-r--r-- 5,638 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
libclass-meta-perl (0.66-2) unstable; urgency=medium

  * Team upload.

  [ Nathan Handler ]
  * Email change: Nathan Handler -> nhandler@debian.org

  [ Salvatore Bonaccorso ]
  * Change Vcs-Git to canonical URI (git://anonscm.debian.org)
  * Change search.cpan.org based URIs to metacpan.org based URIs

  [ gregor herrmann ]
  * Strip trailing slash from metacpan URLs.

  [ Salvatore Bonaccorso ]
  * Update Vcs-Browser URL to cgit web frontend

  [ Niko Tyni ]
  * Make the package autopkgtestable
  * Update to Standards-Version 3.9.6
  * Add explicit build dependency on libmodule-build-perl

 -- Niko Tyni <ntyni@debian.org>  Sat, 06 Jun 2015 11:38:05 +0300

libclass-meta-perl (0.66-1) unstable; urgency=low

  [ gregor herrmann ]
  * debian/control: update {versioned,alternative} (build) dependencies.

  [ Nathan Handler ]
  * New upstream release
  * debian/control:
    - Add myself to list of Uploaders
    - Bump Standards-Version to 3.9.3
  * debian/copyright:
    - Add myself to debian/* copyright
    - Update to copyright-format 1.0
  * debian/patches/spelling.patch:
    - Most of the spelling issues were resolved in 0.66, but one still remains
    - Add myself as an Author and update last updated date

  [ Salvatore Bonaccorso ]
  * Add back (build-)dependency for Class::ISA.
    Add back alternative (Build-)Depends(-Indep) on
    libclass-isa-perl | perl (<< 5.10.1-13).

 -- Nathan Handler <nhandler@ubuntu.com>  Sun, 15 Jul 2012 11:54:09 -0500

libclass-meta-perl (0.65-1) unstable; urgency=low

  [ Maximilian Gass ]
  * New upstream release 0.64

  [ Ansgar Burchardt ]
  * debian/control: Convert Vcs-* fields to Git.

  [ gregor herrmann ]
  * New upstream release 0.65.
  * Refresh spelling patch.
  * debian/copyright: update years of upstream copyright and DEP5 formatting.
  * Set Standards-Version to 3.9.2 (no changes).
  * Make build dependency on libtest-pod-perl versioned.
  * debian/libclass-meta-perl.docs: update doc filename.

 -- gregor herrmann <gregoa@debian.org>  Sat, 06 Aug 2011 20:28:38 +0200

libclass-meta-perl (0.63-2) unstable; urgency=low

  [ Nathan Handler ]
  * debian/watch: Update to ignore development releases.

  [ gregor herrmann ]
  * debian/control: Changed: (build-)depend on perl instead of perl-
    modules.
  * Drop build dependency on "perl (>= 5.10) | libmodule-build-perl", already
    satisfied in lenny.

  [ Peter Pentchev ]
  * Convert to the 3.0 (quilt) source format with no changes.
  * Depend on libclass-isa-perl | perl (<< 5.10.1-13).  Closes: #614410
  * Refresh the copyright file:
    - refer to the GPL-1 file instead of the GPL symlink
    - update it to the latest DEP 5 candidate format
    - refer to Debian (not just GNU/Linux) systems
    - add my debian/* copyright notice
  * Bump Standards-Version to 3.9.1 with no changes.
  * Add spelling.patch to fix two spelling mistakes and a grammatical one.
  * Bump the debhelper compatibility level to 8 with no changes and
    minimize the rules file.
  * Drop the 5.8.0-7 version from the perl build dependency.
  * Add myself to the list of uploaders.

 -- Peter Pentchev <roam@ringlet.net>  Fri, 25 Feb 2011 01:56:19 +0200

libclass-meta-perl (0.63-1) unstable; urgency=low

  * debian/control: Changed: Switched Vcs-Browser field to ViewSVN
    (source stanza).

  * New upstream release.
  * Remove patch pod-link.patch (incorporated upstream); remove quilt
    framework.
  * Set Standards-Version to 3.8.1 (no changes).
  * Set debhelper compatibility level to 7; adapt
    debian/{control,compat,rules}.
  * Add perl-modules (>= 5.10) as an alternative build dependency to
    libmodule-build-perl.
  * debian/copyright: switch to new format.

 -- gregor herrmann <gregoa@debian.org>  Wed, 08 Apr 2009 20:06:04 +0200

libclass-meta-perl (0.62-1) unstable; urgency=low

  * New upstream release.
  * debian/watch: set version to 3.
  * debian/copyright: update years of copyright, use version-independent
    upstream source URL.
  * Refresh debian/rules, no functional changes.
  * debian/control:
    - add libtest-pod-perl, libtest-pod-coverage-perl to Build-Depends-Indep
    - add /me to Uploaders
  * Add patch pod-link.patch: fixes an internal L<> link in the pod; add
    quilt framework.

 -- gregor herrmann <gregoa@debian.org>  Fri, 23 May 2008 21:10:46 +0200

libclass-meta-perl (0.61-1) unstable; urgency=low

  * New upstream release

 -- Krzysztof Krzy┼╝aniak (eloy) <eloy@debian.org>  Thu, 15 May 2008 12:13:58 +0200

libclass-meta-perl (0.55-1) unstable; urgency=low

  * New upstream release
  * debian/control:
   + Standards-Version upgraded to 3.7.3 (no changes)
  * debian/watch: updated to recent schema
  * debian/compat: updated to 5, debhelper dependency changed as well

 -- Krzysztof Krzy┼╝aniak (eloy) <eloy@debian.org>  Thu, 08 May 2008 11:18:33 +0200

libclass-meta-perl (0.53-2) UNRELEASED; urgency=low

  * debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser
    field (source stanza); Homepage field (source stanza). Removed: XS-
    Vcs-Svn fields.

 -- gregor herrmann <gregor+debian@comodo.priv.at>  Tue, 09 Oct 2007 22:28:06 +0200

libclass-meta-perl (0.53-1) unstable; urgency=low

  * New upstream release
  * debian/control:
   - Build-Depends: created and moved debhelper & libmodule-build-perl here
   - Standards-Version: increased to 3.7.2 without additional changes

 -- Krzysztof Krzyzaniak (eloy) <eloy@debian.org>  Tue, 30 May 2006 16:51:16 +0200

libclass-meta-perl (0.52-1) unstable; urgency=low

  * Initial Release (closes: #345828)

 -- Krzysztof Krzyzaniak (eloy) <eloy@debian.org>  Tue,  3 Jan 2006 17:29:20 +0100