File: changelog

package info (click to toggle)
libcloud 2.4.0-1
  • links: PTS, VCS
  • area: main
  • in suites: buster, sid
  • size: 21,484 kB
  • sloc: python: 112,371; xml: 43,239; sh: 18; makefile: 8
file content (205 lines) | stat: -rw-r--r-- 6,909 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
libcloud (2.4.0-1) unstable; urgency=medium

  * New upstream version 2.4.0
  * add new upstream signing key: Quentin Pradet <quentinp@apache.org>

 -- Hans-Christoph Steiner <hans@eds.org>  Sun, 27 Jan 2019 20:30:19 +0000

libcloud (2.3.0-3) unstable; urgency=medium

  * d/control: Remove unneeded dependency on
    backports.ssl-match-hostname (Closes: #909971).
  * d/control: Bump Standards-Version to 4.2.1.
  * d/docs: Install NOTICE file.

 -- Andrew Starr-Bochicchio <asb@debian.org>  Wed, 03 Oct 2018 21:14:23 -0400

libcloud (2.3.0-2) unstable; urgency=medium

  [ Ondřej Nový ]
  * d/changelog: Remove trailing whitespaces
  * d/control: Remove ancient X-Python-Version field
  * d/control: Remove ancient X-Python3-Version field
  * Convert git repository from git-dpm to gbp layout

  [ Andrew Starr-Bochicchio ]
  * d/tests: Run autopkg tests on all supported Python
    versions (Closes: #900999).
  * d/patches/0001-Backport-Python-3.7-support-from-upstream-master.patch:
    Backport Python 3.7 support from upstream master (Closes: #903388).
  * d/patches/0002-Unset-the-http_proxy-environment-variable-before-run.patch:
    Backport upstream patch fixing issues w/ disabled tests.
  * d/rules: Re-enable tests that conflict with pybuild's proxy settings.

 -- Andrew Starr-Bochicchio <asb@debian.org>  Sun, 16 Sep 2018 19:46:23 -0400

libcloud (2.3.0-1) unstable; urgency=medium

  [ Ondřej Nový ]
  * d/control: Set Vcs-* to salsa.debian.org
  * d/changelog: Remove trailing whitespaces

  [ Andrew Starr-Bochicchio ]
  * d/watch: Look for tar.gz files, not tar.bz2.
  * New upstream release.
  * d/control: Bump Standards-Version to 4.1.4, no changes.

 -- Andrew Starr-Bochicchio <asb@debian.org>  Sat, 07 Apr 2018 17:22:41 -0400

libcloud (2.2.1-1) unstable; urgency=medium

  [ Andrew Starr-Bochicchio ]
  * New upstream release.
   - Resolves FTBFS with Python 3.6 (Closes: #878542).
  * debian/control: Remove deprecated XS-Testsuite field.
  * Build depend on python{3}-pytest and python{3}-pytest-runner.
  * Bump Standards-Version to 4.1.0.
  * Use PYBUILD_{BEFORE,AFTER}_TEST to avoid overriding
    dh_auto_test and dh_auto_clean.
  * Disable tests that conflict with pybuild's proxy settings.

  [ Hans-Christoph Steiner ]
  * New upstream release from git tag
  * tests now use python-requests-mock

 -- Andrew Starr-Bochicchio <asb@debian.org>  Wed, 18 Oct 2017 23:24:15 -0400

libcloud (1.5.0-1) unstable; urgency=medium

  * Imported Upstream version 1.5.0
  * uses latest python-lockfile (Closes: #789561)

 -- Hans-Christoph Steiner <hans@eds.org>  Fri, 06 Jan 2017 23:11:40 +0100

libcloud (1.4.0-1) unstable; urgency=medium

  * New upstream release

 -- Hans-Christoph Steiner <hans@eds.org>  Mon, 19 Dec 2016 20:54:25 +0100

libcloud (1.3.0-1) unstable; urgency=medium

  * New upstream release.
  * Fixed VCS URL (https)

 -- Hans-Christoph Steiner <hans@eds.org>  Mon, 17 Oct 2016 17:06:40 -0400

libcloud (0.20.0-1) unstable; urgency=medium

  * New upstream release.
   - Resolves test failures (Closes: #811160).
  * Drop debian/patches/dont_req_backports_with_py3.patch,
    applied upstream.
  * Build depend on python{3}-lockfile to ensure all
    tests are run.

 -- Andrew Starr-Bochicchio <asb@debian.org>  Mon, 18 Jan 2016 16:05:14 -0500

libcloud (0.17.0-1) unstable; urgency=medium

  * New upstream release.
  * debian/patches/dont_req_backports_with_py3.patch:
   - Don't require the backports.ssl_match_hostname module when
     running the tests under Python 3 as it is not needed.
  * debian/control:
   - Build-depend on python-backports.ssl-match-hostname
   - Bump Standards-Version to 3.9.6, no changes.
  * debian/watch: Use pypi.debian.net redirector.
  * debian/copyright: Update and add myself.

 -- Andrew Starr-Bochicchio <asb@debian.org>  Sat, 09 May 2015 15:45:37 -0400

libcloud (0.15.1-1) unstable; urgency=medium

  * New upstream release.
  * Build Python3 package (Closes: #745962). Thanks to
    Daniel Lintott for the initial patch!
  * Correctly install upstream changelog.
  * Add lintian overrides for privacy-breach-generic as they are
    being triggered by dummy data used in the testsuite.
  * Install example files.
  * Add autopackage tests.

 -- Andrew Starr-Bochicchio <asb@debian.org>  Sun, 06 Jul 2014 21:59:57 -0400

libcloud (0.14.1-1) unstable; urgency=low

  * new upstream release

 -- Hans-Christoph Steiner <hans@eds.org>  Thu, 17 Apr 2014 11:41:46 -0400

libcloud (0.13.3-1) unstable; urgency=low

  [ Jakub Wilk ]
  * Add Vcs-* fields.

  [ Julien Cristau ]
  * New upstream release
  * Bump X-Python-Version to 2.6+, 2.5 didn't have an ssl module.

  [ Jakub Wilk ]
  * Use canonical URIs for Vcs-* fields.

  [ Hans-Christoph Steiner ]
  * Non-maintainer upload (closes: #679881)
  * Newest upstream release where the tests pass (tests are broken in
    0.14.0 and 0.14.1).
  * Bumped Standards-Version to 3.9.5. No changes needed.

 -- Hans-Christoph Steiner <hans@eds.org>  Wed, 16 Apr 2014 22:09:23 -0400

libcloud (0.5.0-1) unstable; urgency=low

  * New upstream release (Closes: #598463)
  * Make myself Uploader instead of Maintainer and set DPMT as the
    maintainer.
  * Adjust debian/watch now that libcloud is a toplevel Apache project.
  * Remove dependency on zope.interface (dropped upstream).
  * Convert to debhelper 7 and dh_python2.
  * Bumped Standards-Version to 3.9.2. No changes needed.
  * Bump debian/compat to 7.
  * Drop debian/pycompat.
  * Use debian/clean instead of overriding dh_auth_clean.

 -- Soren Hansen <soren@ubuntu.com>  Tue, 14 Jun 2011 13:27:50 +0200

libcloud (0.3.1-1) unstable; urgency=low

  * New upstream release.
  * Update debian/copyright to reflect libcloud's inclusion into the
    Apache incubator programme (copyright reassigned to ASF) and to
    account for the new OpenNEbula driver being copyrighted differently
    than the bulk of the project.

 -- Soren Hansen <soren@ubuntu.com>  Tue, 18 May 2010 07:40:17 +0200

libcloud (0.2.0-1) unstable; urgency=low

  * New upstream release.
  * Update Standards-Version to 3.8.4. No changes needed.
  * Switch to "3.0 (quilt)" source package format.
  * Dropped get-orig-source target from debian/rules. Upstream has released
    tarballs.
  * Added watch file.

 -- Soren Hansen <soren@ubuntu.com>  Fri, 07 May 2010 10:00:57 +0200

libcloud (0.1.1~git20091201-1) unstable; urgency=low

  * New upstream snapshot.
  * Add dependencies for test suite to Build-Depends.

 -- Soren Hansen <soren@ubuntu.com>  Wed, 02 Dec 2009 11:32:37 +0100

libcloud (0.1.1~git20091125-1) UNRELEASED; urgency=low

  * New upstream release
  * Run test suite at build time.

 -- Soren Hansen <soren@ubuntu.com>  Wed, 25 Nov 2009 10:43:15 +0100

libcloud (0.1.1~git20091107-1) unstable; urgency=low

  * Initial upload to Debian. (Closes: #555006)

 -- Soren Hansen <soren@ubuntu.com>  Sat, 07 Nov 2009 22:45:52 +0100