File: changelog

package info (click to toggle)
libcommons-compress-java 1.18-2
  • links: PTS, VCS
  • area: main
  • in suites: buster, sid
  • size: 33,004 kB
  • sloc: java: 44,235; xml: 4,705; sh: 6; makefile: 4
file content (237 lines) | stat: -rw-r--r-- 7,848 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
libcommons-compress-java (1.18-2) unstable; urgency=medium

  * Team upload.
  * Remove powermock from B-D. See #875358.
  * Declare compliance with Debian Policy 4.3.0.
  * Skip all the tests.

 -- Markus Koschany <apo@debian.org>  Fri, 01 Mar 2019 23:27:13 +0100

libcommons-compress-java (1.18-1) unstable; urgency=medium

  * Team upload.
  * New upstream version 1.18.
    - Fix CVE-2018-11771.
      When reading a specially crafted ZIP archive, the read method of Apache
      Commons Compress ZipArchiveInputStream can fail to return the correct EOF
      indication after the end of the stream has been reached. When combined
      with a java.io.InputStreamReader this can lead to an infinite stream,
      which can be used to mount a denial of service attack against services
      that use Compress' zip package. Thanks to Salvatore Bonaccorso for the
      report. (Closes: #906301)
  * Declare compliance with Debian Policy 4.2.0.

 -- Markus Koschany <apo@debian.org>  Wed, 22 Aug 2018 21:43:55 +0200

libcommons-compress-java (1.17-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
    - Removed the CVE-2018-1324 patch (fixed upstream)
    - New build dependency on libmaven-antrun-plugin-java
    - Disabled Brotli support (dependency not in Debian)
    - Disabled Zstandard support (dependency not in Debian)
  * Rebuilt with Java 8 compatibility (Closes: #903774)
  * Standards-Version updated to 4.1.5
  * Use salsa.debian.org Vcs-* URLs

 -- Emmanuel Bourg <ebourg@apache.org>  Mon, 16 Jul 2018 13:11:58 +0200

libcommons-compress-java (1.13-2) unstable; urgency=medium

  * Team upload.
  * Apply patch for CVE-2018-1324 (Closes: #893174)
  * Use debhelper 11
  * Update Homepage
  * Update debian/watch to repack with xz compression
  * Drop get-orig-source target from debian/rules
  * Bump Standards-Version to 4.1.4

 -- tony mancill <tmancill@debian.org>  Sun, 08 Apr 2018 20:58:50 -0700

libcommons-compress-java (1.13-1) unstable; urgency=medium

  * New upstream release

 -- Emmanuel Bourg <ebourg@apache.org>  Fri, 06 Jan 2017 00:59:52 +0100

libcommons-compress-java (1.12-1) unstable; urgency=medium

  * New upstream release
    - New build dependency on libpowermock-java
    - Ignore the test failures related to the powermock/cglib interaction
  * Switch to debhelper level 10

 -- Emmanuel Bourg <ebourg@apache.org>  Wed, 21 Dec 2016 15:38:24 +0100

libcommons-compress-java (1.11-1) unstable; urgency=medium

  * New upstream release
    - Removed the Java 8 compatibility patch (fixed upstream)
  * Build with maven-debian-helper instead of ant.
  * Standards-Version updated to 3.9.8 (no changes)
  * Use secure Vcs-* URLs

 -- Emmanuel Bourg <ebourg@apache.org>  Wed, 20 Apr 2016 16:24:25 +0200

libcommons-compress-java (1.10-2) unstable; urgency=medium

  * Team upload.
  * Add patch from upstream to address test failure with Java 8.
    (Closes: #814583)
  * Standards-Version updated to 3.9.7 (no changes)

 -- tony mancill <tmancill@debian.org>  Mon, 15 Feb 2016 20:29:42 -0800

libcommons-compress-java (1.10-1) unstable; urgency=medium

  * New upstream release
  * Updated the OSGi metadata

 -- Emmanuel Bourg <ebourg@apache.org>  Mon, 31 Aug 2015 23:22:38 +0200

libcommons-compress-java (1.9-1) unstable; urgency=medium

  * New upstream release
  * Updated the OSGi metadata
  * Standards-Version updated to 3.9.6 (no changes)
  * Updated the Vcs-* fields

 -- Emmanuel Bourg <ebourg@apache.org>  Fri, 10 Oct 2014 16:58:50 +0200

libcommons-compress-java (1.8.1-1) unstable; urgency=medium

  * New upstream release
  * Removed 01-optional-xz-dependency.patch
  * Updated the OSGi metadata
  * Moved the package to Git

 -- Emmanuel Bourg <ebourg@apache.org>  Mon, 19 May 2014 18:13:11 +0200

libcommons-compress-java (1.8-2) unstable; urgency=medium

  * Patched the pom to Mark the dependency on org.tukaani:xz as optional
    (Closes: #741754)

 -- Emmanuel Bourg <ebourg@apache.org>  Tue, 25 Mar 2014 17:12:29 +0100

libcommons-compress-java (1.8-1) unstable; urgency=medium

  * New upstream release (Closes: #739655)
  * Updated the OSGi metadata
  * The dependency on libxz-java is now suggested and no longer required

 -- Emmanuel Bourg <ebourg@apache.org>  Thu, 13 Mar 2014 08:37:01 +0100

libcommons-compress-java (1.6-1) unstable; urgency=low

  * New upstream release
  * Updated Standards-Version to 3.9.5 (no changes)
  * Build depend on debhelper >= 9
  * Removed the unused debian/orig-tar.sh script

 -- Emmanuel Bourg <ebourg@apache.org>  Sat, 02 Nov 2013 13:55:47 +0100

libcommons-compress-java (1.5-2) unstable; urgency=low

  * Team upload.

  [ Emmanuel Bourg ]
  * Use canonical URLs for the Vcs-* fields
  * Added the upstream changelog

  [ tony mancill ]
  * Apply patch to d/rules to include ant-junit4.jar on build classpath.
    - Thank you to James Page. (Closes: #712589)

 -- tony mancill <tmancill@debian.org>  Mon, 17 Jun 2013 15:32:55 -0700

libcommons-compress-java (1.5-1) unstable; urgency=low

  * Team upload.
  * Upload to unstable.

 -- tony mancill <tmancill@debian.org>  Fri, 17 May 2013 07:53:06 -0700

libcommons-compress-java (1.5-1~exp1) experimental; urgency=low

  * New upstream release.
  * Add Emmanuel Bourg to Uploaders.
  * d/control: Bump Standards-Version to 3.9.4 (no changes needed).
  * Update to the package description (Closes: #682169).

  [ Jakub Adam ]
  * Add xz.jar to manifest Class-Path.
    - fixes lintian-reported warning missing-classpath.
  * Ensure backwards compatible bytecode is built (Closes: #688118).
  * Add OSGi metadata into jar manifest.
  * Add Jakub Adam to Uploaders.

 -- Emmanuel Bourg <ebourg@apache.org>  Tue, 26 Mar 2013 19:42:09 +0100

libcommons-compress-java (1.4.1-2) unstable; urgency=low

  * Team upload.
  
  [ Miguel Landaeta ]
  * Promote dependency on libxz-java from Suggests to Depends.
    (Closes: #680874)

  [ Tony Mancill ]
  * Correct broken Vcs-Svn URL.

 -- Miguel Landaeta <miguel@miguel.cc>  Sun, 08 Jul 2012 15:59:26 -0430

libcommons-compress-java (1.4.1-1) unstable; urgency=medium

  * Team upload.
  * New upstream release. CVE-2012-2098 is fixed. (Closes: #674448).
  * Replace B-D on junit with junit4.
  * Add B-D on libxz-java.
  * Fix clean target to allow twice in a row builds.

 -- Miguel Landaeta <miguel@miguel.cc>  Sun, 17 Jun 2012 18:08:36 -0430

libcommons-compress-java (1.2-2) unstable; urgency=low

  * Team upload.

  [ James Page ]
  * Enablement of JUnit test suite (LP: #876413) (Closes: 646090):
    - d/build.xml: Provide targets to compile and execute test suite.
    - d/control: Add B-D's on junit and ant-optional to support testing.
    - d/rules: Add ant-junit and junit to DEB_JARS for testing.
  * d/copyright: Updated for revised field names.

  [ Damien Raude-Morvan ]
  * d/control: Bumped Standards-Version: 3.9.3, no changes.

 -- Damien Raude-Morvan <drazzib@debian.org>  Wed, 30 May 2012 01:26:41 +0200

libcommons-compress-java (1.2-1) unstable; urgency=low

  * New upstream release
  * Clean up Depends and Suggests fields.
  * Switch to source format 3.0.

 -- Torsten Werner <twerner@debian.org>  Sun, 07 Aug 2011 01:56:15 +0200

libcommons-compress-java (1.0-1) unstable; urgency=low

  * First upstream release (Closes: #542603)
  * Update old sandbox URLs.
  * Convert debian/copyright to dep5 format and change license of debian/* to
    Apache-2.0.
  * Update get-orig-source target in debian/rules.
  * Switch to default-jdk.
  * Change Section: java.
  * Update Standards-Version: 3.8.3.
  * Use maven-repo-helper to start transition to Maven.

 -- Torsten Werner <twerner@debian.org>  Sun, 20 Sep 2009 11:16:42 +0200

libcommons-compress-java (0~svn604876-1) unstable; urgency=low

  * Initial release (Closes: #456662)

 -- Torsten Werner <twerner@debian.org>  Mon, 17 Dec 2007 15:17:09 +0100