1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
|
DEB_SOURCE_PACKAGE := $(shell dpkg-parsechangelog | grep '^Source:' | cut -f 2 -d ' ')
DEB_UPSTREAM_VERSION := $(shell dpkg-parsechangelog | egrep '^Version:' | cut -f 2 -d ' ' | cut -d: -f2- | sed 's/-[^-]*$$//')
export JAVA_HOME=/usr/lib/jvm/default-java
export CLASSPATH=$(shell for jar in `cat debian/build-classpath`; do if [ -f "$$jar" ]; then echo -n "$${jar}:"; fi; done)
%:
dh $@ --buildsystem=ant --with maven_repo_helper
override_dh_auto_build:
ANT_ARGS="-Dbasedir=$(realpath .) -Djdk.javadoc=file:///usr/share/doc/default-jdk-doc/api/ jar javadoc javadoc-jar" dh_auto_build
cat debian/commons-lang.bnd | sed s/VERSION/$(DEB_UPSTREAM_VERSION)/ > debian/.commons-lang-versioned.bnd
echo debian/.commons-lang-versioned.bnd >> debian/.mh_clean
bnd wrap --properties debian/.commons-lang-versioned.bnd --output target/commons-lang.bnd.jar target/commons-lang-$(DEB_UPSTREAM_VERSION).jar
get-orig-source:
-uscan --download-version $(DEB_UPSTREAM_VERSION) --force-download --rename
|