File: Makefile.PL

package info (click to toggle)
libdata-alias-perl 1.16-1
  • links: PTS, VCS
  • area: main
  • in suites: wheezy
  • size: 396 kB
  • sloc: perl: 2,797; makefile: 2
file content (19 lines) | stat: -rw-r--r-- 400 bytes parent folder | download | duplicates (4)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
use inc::Module::Install;
use Config;

my %fussy_OS = (
	MSWin32	=> "Win32",
	aix	=> "AIX",
);

$fussy_OS{$^O}  and $] < 5.008009  and die "ERROR:  [OS unsupported]  " .
	"Data::Alias on $fussy_OS{$^O} requires perl 5.8.9 or later.\n";


name     'Data-Alias';
all_from 'lib/Data/Alias.pm';

die "ERROR: Data::Alias does not support old 5.005-style threads\n"
	if $Config{use5005threads};

WriteAll;