File: Build.PL

package info (click to toggle)
libdata-record-perl 0.02-4
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, jessie, jessie-kfreebsd, sid, stretch
  • size: 124 kB
  • ctags: 21
  • sloc: perl: 315; makefile: 12
file content (25 lines) | stat: -rw-r--r-- 683 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
#!/usr/bin/perl -w

use strict;
use Module::Build;

my $builder = Module::Build->new(
    module_name       => 'Data::Record',
    license           => 'perl',
    dist_author       => 'Curtis "Ovid" Poe <moc.oohay@eop_divo_sitruc>',
    dist_version_from => 'lib/Data/Record.pm',
    requires          => {

        # No, I don't really require Sub::Uplevel, but I'm tired of my
        # tests failing because of this.
        'Sub::Uplevel' => 0.09,
    },
    build_requires => {
        'Test::Exception' => 0.21,
        'Test::More'      => 0.6,
    },
    add_to_cleanup     => ['Data-Record-*'],
    create_makefile_pl => 'traditional',
);

$builder->create_build_script();