File: Rakefile

package info (click to toggle)
libdataobjects-postgres-ruby 0.2.4-2
  • links: PTS
  • area: main
  • in suites: lenny
  • size: 316 kB
  • ctags: 566
  • sloc: ansic: 6,894; ruby: 225; makefile: 2
file content (36 lines) | stat: -rw-r--r-- 972 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
require 'rubygems'
require 'rake/gempackagetask'

PLUGIN = "do_postgres"
NAME = "do_postgres"
VERSION = "0.2.4"
AUTHOR = "Yehuda Katz"
EMAIL = "wycats@gmail.com"
HOMEPAGE = "http://dataobjects.devjavu.com"
SUMMARY = "A DataObject.rb driver for postgres"

spec = Gem::Specification.new do |s|
  s.name = NAME
  s.version = VERSION
  s.platform = Gem::Platform::RUBY
  s.has_rdoc = true
  s.extra_rdoc_files = ["README", "LICENSE", 'TODO']
  s.summary = SUMMARY
  s.description = s.summary
  s.author = AUTHOR
  s.email = EMAIL
  s.homepage = HOMEPAGE
  s.add_dependency('data_objects', ["<=0.2.0"])
  s.require_path = 'lib'
  s.autorequire = PLUGIN
  s.extensions = ["ext/extconf.rb"]
  s.files = %w(LICENSE README Rakefile TODO) + Dir.glob("{lib,specs,ext}/**/*").reject {|x| x =~ /\.(o|bundle)$/ }
end

Rake::GemPackageTask.new(spec) do |pkg|
  pkg.gem_spec = spec
end

task :install => [:package] do
  sh %{sudo gem install pkg/#{NAME}-#{VERSION}}, :verbose => false
end