File: Announce

package info (click to toggle)
libdbd-informix-perl 2003.04-3
  • links: PTS
  • area: contrib
  • in suites: etch, etch-m68k, sarge
  • size: 1,232 kB
  • ctags: 467
  • sloc: perl: 7,349; ansic: 5,340; sh: 184; makefile: 58
file content (80 lines) | stat: -rw-r--r-- 4,081 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
To: dbi-announce@perl.org, dbi-dev@perl.org, dbi-users@perl.org,
        informix-list@iiug.org
Subject: ANNOUNCE: IBM Informix Database Driver for Perl Version 2003.04 (2003-03-05) released

IBM Informix Database Driver for Perl Version 2003.04 (2003-03-05) has been uploaded to CPAN.

IBM Informix Database Driver for Perl (also known as DBD::Informix) is
the driver code that enables Perl 5.005 or later to access Informix
databases via the DBI module (but if you are not already using Perl
5.8.0, you should be planning to upgrade to it).  You will need the code
for DBI version 1.33 or later as well.  The code for DBD::Informix is
available for download via:

http://www.perl.org/CPAN/modules/by-category/07_Database_Interfaces
http://dbi.perl.org/

** When you successfully build this module, use the ItWorks (Perl)
** script to report your configuration to the maintenance team (meaning
** Jonathan Leffler) at jleffler@us.ibm.com.  Note that ItWorks does not
** send email to anybody; you have to do that yourself.

New in release 2003.04:
* This release is purely a re-packaging of previous functionality.
* Unfortunately, neither CPAN nor CPANPLUS really handles 3-part version
  numbers, so revert to 2-part numbers (year, release number within year).
  It is difficult to find these things out without trying.

New in release 2003.03.0401:
* Minor bug fix release.
* Installs Bundle::DBD::Informix to keep CPAN and CPANPLUS modules happy
  that DBD::Informix is properly installed and up-to-date.
* Remove data_sources from Informix.xs since it is defined by DBI.
* Sort out version information in DBD::Informix::* sub-modules.
* Minor amendments and additions to history in ChangeLog.

New in release 2003.03.0303:
* Pre-requisite version of DBI is now 1.33.  There were a number of
  changes made in the support code for DBI that this version of
  DBD::Informix relies upon.
* Fix various minor problems as noted in the ChangeLog.
* Overhaul the infrastructure to align better with DBI specifications.
* Revise infrastructure to exploit ExtUtils::AutoInstall.  If it causes you
  problems (because you don't have Internet access, for example), read the
  notes at the top of Makefile.PL on how to avoid the problems.
* Provide support for $dbh->get_info() and $dbh->type_info_all().
* No longer supporting obsolete versions of ESQL/C: 5.0x, 6.0x, 7.0x, 7.1x,
  7.2x other than 7.24, 9.0x, and 9.1x prior to 9.16.  All of these are at
  least 5 years out of date.  See also FUTURE DIRECTION in ChangeLog.
* This release is supported by Jonathan Leffler <jleffler@us.ibm.com>.
* Moving to version numbering scheme with 3-part major, minor, release
  numbering as recommended in:
    http://en.tldp.org/HOWTO/Software-Release-Practice-HOWTO/index.html
  Just to be contrarian, the version number will be date-based.

New in release 1.04.PC1:
* This release is supported by Jonathan Leffler.  It isn't clear what
  IBM's official stance on the product is.  However, they do support
  DBD::DB2 so there is likely to be minimal objection to this work.
* This release provides support for INSERT cursors.
* This release provides support for UPDATE of blobs (BYTE and TEXT).
* This release provides semi-tested support for BEGIN WORK WITHOUT
  REPLICATION.
* This release works with ClientSDK 2.80; the prior versions of
  DBD::Informix do not because the version string changed radically.
* Has better support for non-standard Perl installations.
* You can tell DBD::Informix to avoid testing smart blobs if you have
  IDS 9.x but no smart blob spaces.  You can also say which smart blob
  space to use if you don't want to use 'sbspace'.
* Fix up file locations so it works better with CPAN.

Scheduled next version: 2003.xx.yy00.
* Feature content still dependent on time available.
* Expected to contain sqlda version of the code (WIP - Work In Progress
  WIP - at last).

As always, see the ChangeLog file for details about what has changed.

Jonathan Leffler (jleffler@us.ibm.com, jleffler@earthlink.net)

@(#)$Id: Announce,v 2003.6 2003/03/05 19:15:28 jleffler Exp $