File: changelog

package info (click to toggle)
libdigest-sha-perl 6.02-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 328 kB
  • sloc: ansic: 730; perl: 451; sh: 25; makefile: 9
file content (397 lines) | stat: -rw-r--r-- 13,443 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
370
371
372
373
374
375
376
377
378
379
380
381
382
383
384
385
386
387
388
389
390
391
392
393
394
395
396
397
libdigest-sha-perl (6.02-1) unstable; urgency=medium

  [ Damyan Ivanov ]
  * declare conformance with Policy 4.1.3 (no changes needed)

  [ Salvatore Bonaccorso ]
  * Update Vcs-* headers for switch to salsa.debian.org
  * Import upstream version 6.02
  * Update copyright years for debian/* packaging files
  * Update copyright years for upstream files
  * Bump Debhelper compat level to 10
  * Declare compliance with Debian policy 4.1.4

 -- Salvatore Bonaccorso <carnil@debian.org>  Sat, 21 Apr 2018 19:00:45 +0200

libdigest-sha-perl (6.01-1) unstable; urgency=medium

  * Import upstream version 6.01

 -- Salvatore Bonaccorso <carnil@debian.org>  Mon, 25 Dec 2017 20:57:53 +0100

libdigest-sha-perl (6.00-1) unstable; urgency=medium

  [ Damyan Ivanov ]
  * declare conformance with Policy 4.1.2 (no changes needed)

  [ Salvatore Bonaccorso ]
  * Import upstream version 6.00
  * Set Rules-Requires-Root to no

 -- Salvatore Bonaccorso <carnil@debian.org>  Sat, 09 Dec 2017 16:10:54 +0100

libdigest-sha-perl (5.98-1) unstable; urgency=medium

  * New upstream version 5.98
  * Declare compliance with Debian policy 4.1.1

 -- Salvatore Bonaccorso <carnil@debian.org>  Wed, 04 Oct 2017 20:52:31 +0200

libdigest-sha-perl (5.97-1) unstable; urgency=medium

  * Import upstream version 5.97
  * Update copyright years for upstream files
  * Update copyright years for debian/* packaging files
  * Declare compliance with Debian policy 4.1.0

 -- Salvatore Bonaccorso <carnil@debian.org>  Wed, 06 Sep 2017 21:25:12 +0200

libdigest-sha-perl (5.96-1) unstable; urgency=medium

  [ gregor herrmann ]
  * Rename autopkgtest configuration file(s) as per new pkg-perl-
    autopkgtest schema.

  [ Salvatore Bonaccorso ]
  * debian/control: Use HTTPS transport protocol for Vcs-Git URI

  [ gregor herrmann ]
  * debian/copyright: change Copyright-Format 1.0 URL to HTTPS.

  [ Salvatore Bonaccorso ]
  * Imported Upstream version 5.96
    - Contains mitigation fix related to CVE-2016-1238 in Perl.
  * Update copyright years for upstream files
  * Update copyright years for debian/* packaging files
  * Declare compliance with Debian policy 3.9.8
  * debian/rules: Build enabling all hardening flags

 -- Salvatore Bonaccorso <carnil@debian.org>  Thu, 28 Jul 2016 21:21:32 +0200

libdigest-sha-perl (5.95-2) unstable; urgency=medium

  * Upload to unstable

 -- Salvatore Bonaccorso <carnil@debian.org>  Mon, 27 Apr 2015 06:58:08 +0200

libdigest-sha-perl (5.95-1) experimental; urgency=medium

  * Add single file from src directory to temporary directory for autopkgtests.
    Fixes: "autopkgtest failure: Can't locate Digest/SHA/PurePerl.pm in
    @INC". The testsuite checks in the current directory for a 'src'
    directory and if not found uses Digest::SHA::PurePerl which causes the
    autopkgtest failure. (Closes: #768144)
  * Imported Upstream version 5.95
  * Update copyright years for upstream files
  * Update copyright years for debian/* packaging files
  * Add lintian overrides for warnings regarding /usr/bin/shasum.
    Override lintian warnings for the library-package-name-for-application
    and application-in-library-section lintian tags since the package is
    mainly a library package.

 -- Salvatore Bonaccorso <carnil@debian.org>  Sat, 04 Apr 2015 16:24:38 +0200

libdigest-sha-perl (5.93-1) unstable; urgency=medium

  * Update Vcs-Browser URL to cgit web frontend
  * Imported Upstream version 5.93
  * Declare compliance with Debian Policy 3.9.6
  * Add Testsuite: autopkgtest-pkg-perl field in debian/control

 -- Salvatore Bonaccorso <carnil@debian.org>  Sun, 26 Oct 2014 16:30:20 +0100

libdigest-sha-perl (5.92-1) unstable; urgency=medium

  * Imported Upstream version 5.92

 -- Salvatore Bonaccorso <carnil@debian.org>  Sun, 01 Jun 2014 20:06:58 +0200

libdigest-sha-perl (5.91-1) unstable; urgency=medium

  * Imported Upstream version 5.91

 -- Salvatore Bonaccorso <carnil@debian.org>  Sat, 17 May 2014 07:40:32 +0200

libdigest-sha-perl (5.90-1) unstable; urgency=medium

  * Imported Upstream version 5.90

 -- Salvatore Bonaccorso <carnil@debian.org>  Wed, 07 May 2014 20:35:43 +0200

libdigest-sha-perl (5.89-1) unstable; urgency=medium

  * Imported Upstream version 5.89

 -- Salvatore Bonaccorso <carnil@debian.org>  Sun, 20 Apr 2014 07:54:31 +0200

libdigest-sha-perl (5.88-1) unstable; urgency=medium

  [ gregor herrmann ]
  * Strip trailing slash from metacpan URLs.

  [ Salvatore Bonaccorso ]
  * Imported Upstream version 5.88

 -- Salvatore Bonaccorso <carnil@debian.org>  Tue, 18 Mar 2014 06:26:27 +0100

libdigest-sha-perl (5.87-1) unstable; urgency=medium

  * Imported Upstream version 5.87

 -- Salvatore Bonaccorso <carnil@debian.org>  Tue, 18 Feb 2014 06:32:47 +0100

libdigest-sha-perl (5.86-1) unstable; urgency=medium

  * Imported Upstream version 5.86
  * Update copyright years for upstream files
  * Update copyright years for debian/* packaging files
  * Declare compliance with Debian Policy 3.9.5
  * Adjust versioned Build-Depends on debhelper to (>= 9.20120312~)

 -- Salvatore Bonaccorso <carnil@debian.org>  Thu, 30 Jan 2014 18:40:12 +0100

libdigest-sha-perl (5.85-1) unstable; urgency=low

  * Imported Upstream version 5.85

 -- Salvatore Bonaccorso <carnil@debian.org>  Thu, 27 Jun 2013 08:30:49 +0200

libdigest-sha-perl (5.84-1) unstable; urgency=low

  * Imported Upstream version 5.72, 5.73, 5.74, 5.80, 5.81, 5.82, 5.83 and
    5.84
  * Bump Standards-Version to 3.9.4
  * Change Vcs-Git to canonical URI (git://anonscm.debian.org)
  * Drop 698172-fix-double-free-in-load-subroutine.patch.
    Patch is part of Digest::SHA 5.81.
  * Update debian/copyright file information.
    Update copyright years for upstream files and debian/* packaging.
  * Change search.cpan.org based URIs to metacpan.org based URIs

 -- Salvatore Bonaccorso <carnil@debian.org>  Sun, 05 May 2013 05:28:38 +0200

libdigest-sha-perl (5.71-2) unstable; urgency=low

  * Add 698172-fix-double-free-in-load-subroutine.patch patch.
    Fix double-free when loading Digest::SHA object representing the
    intermediate SHA state from a file. (Closes: #698172)

 -- Salvatore Bonaccorso <carnil@debian.org>  Wed, 16 Jan 2013 20:51:48 +0100

libdigest-sha-perl (5.71-1) unstable; urgency=low

  * Imported Upstream version 5.71
  * Update debian/copyright information.
    Update format to copyright-format 1.0 as released with Debian policy
    3.9.3.
    Update copyright years for upstream files and debian/* packaging.
  * Bump Standards-Version to 3.9.3
  * Bump Debhelper compat level to 9.
    Adjust Build-Depends on debhelper to debhelper (>= 9).

 -- Salvatore Bonaccorso <carnil@debian.org>  Wed, 29 Feb 2012 20:53:56 +0100

libdigest-sha-perl (5.70-1) unstable; urgency=low

  * Imported Upstream version 5.70

 -- Salvatore Bonaccorso <carnil@debian.org>  Wed, 14 Dec 2011 13:14:29 +0100

libdigest-sha-perl (5.63-1) unstable; urgency=low

  * Imported Upstream version 5.63

 -- Salvatore Bonaccorso <carnil@debian.org>  Tue, 08 Nov 2011 18:11:21 +0100

libdigest-sha-perl (5.62-2) unstable; urgency=low

  [ Ansgar Burchardt ]
  * debian/control: Convert Vcs-* fields to Git.

  [ Salvatore Bonaccorso ]
  * debian/copyright: Replace DEP5 Format-Specification URL from
    svn.debian.org to anonscm.debian.org URL.
  * Divert /usr/bin/shasum and its manpage to avoid inconsistent
    situation where newer Digest::SHA is used with /usr/bin/shasum from
    perl package. (Closes: #638063)

 -- Salvatore Bonaccorso <carnil@debian.org>  Thu, 18 Aug 2011 18:23:55 +0200

libdigest-sha-perl (5.62-1) unstable; urgency=low

  * New upstream release
  * Bump Standards-Version to 3.9.2.

 -- Salvatore Bonaccorso <carnil@debian.org>  Sat, 14 May 2011 22:55:25 +0200

libdigest-sha-perl (5.61-1) unstable; urgency=low

  * New upstream release

 -- Salvatore Bonaccorso <carnil@debian.org>  Thu, 10 Mar 2011 10:32:07 +0100

libdigest-sha-perl (5.60-1) unstable; urgency=low

  * New upstream release
  * debian/control:
    - Expand short and long description matching the implemented hash
      standards.
    - Bump versioned Build-Depends on debhelper to (>= 8).
  * debian/copyright: Refresh copyright years
  * Bump Debhelper compat level to 8.
  * Email change: Salvatore Bonaccorso -> carnil@debian.org
  * Email change: gregor herrmann -> gregoa@debian.org

 -- Salvatore Bonaccorso <carnil@debian.org>  Fri, 04 Mar 2011 08:48:13 +0100

libdigest-sha-perl (5.50-1) unstable; urgency=low

  * New upstream release

 -- Salvatore Bonaccorso <carnil@debian.org>  Wed, 15 Dec 2010 08:33:19 +0100

libdigest-sha-perl (5.49-1) unstable; urgency=low

  * New upstream release
  * Update my email address.
  * Refresh debian/copyright:
    - Refer to GPL-1 license text in common-licenses.
    - Explicitly refer to Debian systems in general instead of only Debian
      GNU/Linux systems.
  * Convert to '3.0 (quilt)' source package format.
  * Bump Standards-Version to 3.9.1.

 -- Salvatore Bonaccorso <carnil@debian.org>  Mon, 13 Dec 2010 20:46:57 +0100

libdigest-sha-perl (5.48-1) unstable; urgency=low

  [ gregor herrmann ]
  * debian/control: Changed: Switched Vcs-Browser field to ViewSVN
    (source stanza).
  * debian/control: Added: ${misc:Depends} to Depends: field.

  [ Nathan Handler ]
  * debian/watch: Update to ignore development releases.

  [ Salvatore Bonaccorso ]
  * New upstream release
  * Add myself to Uploaders
  * Referesh debian/copyright following revision 135 of DEP5's
    Format-Specification for machine-readable copyright information.
  * Bump compatibility level debhelper to 7
  * debian/rules: simplify rules Makefile to a tiny file using override
    targets feature and dh command.
  * debian/control:
    - Bump versioned dependency on debhelper to (>= 7.0.50).
    - Replace versioned Build-Depends-Indep on perl (>= 5.8) with unversioned
      one, as this is satisfied already in oldstable.
  * Remove unused lintian-overrides.
  * Bump Standards-Version to 3.8.3

 -- Salvatore Bonaccorso <salvatore.bonaccorso@gmail.com>  Thu, 07 Jan 2010 07:31:02 +0100

libdigest-sha-perl (5.47-1) unstable; urgency=low

  * New upstream release.
  * debian/control: change my email address.
  * Add lintian override for long lines in manpage that are caused by URLs.

 -- gregor herrmann <gregoa@debian.org>  Mon, 05 May 2008 21:44:18 +0200

libdigest-sha-perl (5.46-1) unstable; urgency=low

  [ Joachim Breitner ]
  * Removed myself from uploaders.

  [ gregor herrmann ]
  * New upstream release.
  * debian/copyright: update years of copyright.
  * Refresh debian/rules, no functional changes.

 -- gregor herrmann <gregor+debian@comodo.priv.at>  Thu, 10 Apr 2008 16:12:33 +0200

libdigest-sha-perl (5.45-2) unstable; urgency=low

  [ gregor herrmann ]
  * debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser
    field (source stanza); Homepage field (source stanza). Removed: XS-
    Vcs-Svn fields.
  * debian/rules: delete /usr/share/perl5 only if it exists.

  [ Damyan Ivanov ]
  * debian/watch: use dist-based URL, better pattern
  * debian/rules:
    + move test suite to build-stamp target
    + make install not depend on build target, but let install-stamp depend on
      build-stamp target
    + remove commented-out dh_* calls; remove unused dh_link and dh_makeshlibs
      calls
  * debian/copyright: use dist-based upstream URL; refresh years of copyright
  * Standards-Version: 3.7.3 (no changes)
  * debhelper compatibility level 6
  * add myself to Uploaders

 -- Damyan Ivanov <dmn@debian.org>  Mon, 21 Jan 2008 13:29:59 +0200

libdigest-sha-perl (5.45-1) unstable; urgency=low

  * New upstream release.
  * DOn't try to install t/nist/Readme.txt -- doesn't exist anymore.

 -- gregor herrmann <gregor+debian@comodo.priv.at>  Sat, 14 Jul 2007 22:46:50 +0200

libdigest-sha-perl (5.44-1) unstable; urgency=low

  * New upstream release.
  * Add examples to /usr/share/doc/libdigest-sha-perl/examples.

 -- gregor herrmann <gregor+debian@comodo.priv.at>  Sun, 19 Nov 2006 20:10:33 +0100

libdigest-sha-perl (5.43-1) unstable; urgency=low

  * New upstream release.

 -- gregor herrmann <gregor+debian@comodo.priv.at>  Sun,  6 Aug 2006 20:40:38 +0200

libdigest-sha-perl (5.42-1) unstable; urgency=low

  * New upstream release

 -- Gunnar Wolf <gwolf@debian.org>  Mon, 31 Jul 2006 12:50:41 -0500

libdigest-sha-perl (5.41-1) unstable; urgency=low

  * New upstream release.
  * Set Debhelper Compatibility Level to 5.

 -- gregor herrmann <gregor+debian@comodo.priv.at>  Sat, 17 Jun 2006 16:46:59 +0200

libdigest-sha-perl (5.39-1) unstable; urgency=low

  * New upstream release
  * Upgrade to Standards-Version 3.7.2. No changes needed.
  * Add libtest-pod-perl and libtest-pod-coverage-perl to Build-Depends
    for better test coverage.

 -- Niko Tyni <ntyni@iki.fi>  Thu,  1 Jun 2006 21:37:53 +0300

libdigest-sha-perl (5.34-1) unstable; urgency=low

  * Gunnar Wolf: New upstream release
  * Allard Hoeve: fix erronous watch file.

 -- Gunnar Wolf <gwolf@debian.org>  Tue, 21 Feb 2006 16:23:06 -0600

libdigest-sha-perl (5.32-1) unstable; urgency=low

  * New upstream release
  * Fixed watch file so it does not get confused by other modules in the
    same namespace

 -- Gunnar Wolf <gwolf@debian.org>  Mon,  5 Dec 2005 12:59:55 -0600

libdigest-sha-perl (5.31-1) unstable; urgency=low

  * Initial Release (closes: #339580)

 -- Allard Hoeve <allard@byte.nl>  Wed, 16 Nov 2005 11:33:35 +0100