File: cpanfile

package info (click to toggle)
libdist-zilla-perl 6.017-1
  • links: PTS, VCS
  • area: main
  • in suites: bookworm, bullseye, sid
  • size: 1,680 kB
  • sloc: perl: 7,041; makefile: 4; sh: 1
file content (117 lines) | stat: -rw-r--r-- 4,093 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
# This file is generated by Dist::Zilla::Plugin::CPANFile v6.015
# Do not edit this file directly. To change prereqs, edit the `dist.ini` file.

requires "App::Cmd::Command::version" => "0";
requires "App::Cmd::Setup" => "0.330";
requires "App::Cmd::Tester" => "0.306";
requires "App::Cmd::Tester::CaptureExternal" => "0";
requires "Archive::Tar" => "0";
requires "CPAN::Meta::Converter" => "2.101550";
requires "CPAN::Meta::Merge" => "0";
requires "CPAN::Meta::Prereqs" => "2.120630";
requires "CPAN::Meta::Requirements" => "2.121";
requires "CPAN::Meta::Validator" => "2.101550";
requires "CPAN::Uploader" => "0.103004";
requires "Carp" => "0";
requires "Class::Load" => "0.17";
requires "Config::INI::Reader" => "0";
requires "Config::MVP" => "2.200011";
requires "Config::MVP::Assembler" => "0";
requires "Config::MVP::Assembler::WithBundles" => "2.200010";
requires "Config::MVP::Reader" => "2.101540";
requires "Config::MVP::Reader::Findable::ByExtension" => "0";
requires "Config::MVP::Reader::Finder" => "0";
requires "Config::MVP::Reader::INI" => "2.101461";
requires "Config::MVP::Section" => "2.200009";
requires "Data::Dumper" => "0";
requires "Data::Section" => "0.200002";
requires "DateTime" => "0.44";
requires "Digest::MD5" => "0";
requires "Encode" => "0";
requires "ExtUtils::Manifest" => "1.66";
requires "File::Copy::Recursive" => "0.41";
requires "File::Find::Rule" => "0";
requires "File::Path" => "0";
requires "File::ShareDir" => "0";
requires "File::ShareDir::Install" => "0.03";
requires "File::Spec" => "0";
requires "File::Temp" => "0";
requires "File::pushd" => "0";
requires "JSON::MaybeXS" => "0";
requires "List::Util" => "1.45";
requires "Log::Dispatchouli" => "1.102220";
requires "Mixin::Linewise::Readers" => "0.100";
requires "Module::CoreList" => "0";
requires "Module::Runtime" => "0";
requires "Moose" => "0.92";
requires "Moose::Role" => "0";
requires "Moose::Util::TypeConstraints" => "0";
requires "MooseX::LazyRequire" => "0";
requires "MooseX::Role::Parameterized" => "1.01";
requires "MooseX::SetOnce" => "0";
requires "MooseX::Types" => "0";
requires "MooseX::Types::Moose" => "0";
requires "MooseX::Types::Perl" => "0";
requires "PPI::Document" => "0";
requires "Params::Util" => "0";
requires "Path::Tiny" => "0.052";
requires "Perl::PrereqScanner" => "1.016";
requires "Pod::Simple" => "0";
requires "Scalar::Util" => "0";
requires "Software::License" => "0.103014";
requires "Software::LicenseUtils" => "0";
requires "String::Formatter" => "0.100680";
requires "String::RewritePrefix" => "0.006";
requires "Sub::Exporter" => "0";
requires "Sub::Exporter::ForMethods" => "0";
requires "Sub::Exporter::Util" => "0";
requires "Term::Encoding" => "0";
requires "Term::ReadKey" => "0";
requires "Term::ReadLine" => "0";
requires "Term::UI" => "0";
requires "Test::Deep" => "0";
requires "Text::Glob" => "0.08";
requires "Text::Template" => "0";
requires "Try::Tiny" => "0";
requires "YAML::Tiny" => "0";
requires "autodie" => "0";
requires "namespace::autoclean" => "0";
requires "parent" => "0";
requires "perl" => "v5.14.0";
requires "strict" => "0";
requires "utf8" => "0";
requires "version" => "0";
requires "warnings" => "0";
recommends "App::cpanminus" => "0";
recommends "Archive::Tar::Wrapper" => "0.15";
recommends "Data::OptList" => "0.110";
recommends "Term::ReadLine::Gnu" => "0";
suggests "PPI::XS" => "0";

on 'test' => sub {
  requires "CPAN::Meta::Check" => "0.011";
  requires "CPAN::Meta::Requirements" => "2.121";
  requires "ExtUtils::MakeMaker" => "0";
  requires "ExtUtils::Manifest" => "1.66";
  requires "File::Spec" => "0";
  requires "Software::License::None" => "0";
  requires "Test::FailWarnings" => "0";
  requires "Test::Fatal" => "0";
  requires "Test::File::ShareDir" => "0";
  requires "Test::More" => "0.96";
  requires "lib" => "0";
};

on 'test' => sub {
  recommends "CPAN::Meta" => "2.120900";
};

on 'configure' => sub {
  requires "ExtUtils::MakeMaker" => "0";
  requires "File::ShareDir::Install" => "0.06";
};

on 'develop' => sub {
  requires "Test::More" => "0";
  requires "Test::Pod" => "1.41";
};