1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42
|
export PYBUILD_NAME = edlib
export DEB_BUILD_MAINT_OPTIONS=hardening=+all
DEB_CMAKE_EXTRA_FLAGS = -DCMAKE_BUILD_TYPE=Release
%:
dh $@ --with python3
override_dh_auto_configure:
dh_auto_configure --buildsystem=cmake -- $(DEB_CMAKE_EXTRA_FLAGS)
override_dh_auto_build:
dh_auto_build --buildsystem=cmake
$(MAKE) --directory=bindings/python edlib pyedlib.bycython.cpp
dh_auto_build --buildsystem=pybuild -- --dir bindings/python
override_dh_auto_install:
dh_auto_install --buildsystem=cmake
dh_auto_install --buildsystem=pybuild -- --dir bindings/python
override_dh_install:
dh_install
file-rename 's/_static\.a/.a/' `find debian -name libedlib_static.a`
d-shlibmove --commit \
--multiarch \
--devunversioned \
--exclude-la \
--movedev debian/tmp/usr/include/* usr/include \
debian/tmp/usr/lib/*.so
override_dh_auto_test:
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
`find . -name edlib-aligner -type f -executable` -p apps/aligner/test_data/query.fasta apps/aligner/test_data/target.fasta
`find . -name runTests`
endif
|