File: changelog

package info (click to toggle)
libev 1:4.25-1
  • links: PTS, VCS
  • area: main
  • in suites: buster
  • size: 2,184 kB
  • sloc: ansic: 6,355; sh: 4,267; makefile: 25
file content (175 lines) | stat: -rw-r--r-- 5,639 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
libev (1:4.25-1) unstable; urgency=medium

  * New upstream release. (Closes: #883649)
  * debian: Apply "wrap-and-sort -abst".
  * debian/control:
    + Make myself the maintainer with acknowledgement from original
      maintainer, move Jérémy Lal into uploaders list.
    + R³: Use "Rules-Requires-Root: no".
    + Bump debhelper compat to v12.
    + Mark libev4 as Multi-Arch: same.
  * debian/changelog: Remove trailing spaces.
  * debian/patches: Drop all patches, merged upstream.
  * debian/compat: Dropped in favour of using debhelper-compat.
  * debian/rules:
    + Enable full hardening.
    + Use "dh_missing --fail-missing".
  * debian/*.dirs: Removed, no longer necessary.
  * debian/libev4.symbols: Add a Build-Depends-Package field.
  * debian/not-installed: Explicitly not installing .la file.

 -- Boyuan Yang <byang@debian.org>  Fri, 08 Feb 2019 14:27:15 -0500

libev (1:4.22-1.1) unstable; urgency=medium

  * Non-maintainer upload.
  * Rebuild for Debian Buster.
    + Automatically generate debug packages. (Closes: #642110)
  * debian/control:
    + Drop obsoleted package priority extra.
    + Update Vcs-* fields and use git repo under Salsa Debian group.
    + Declare compliance with Debian Policy 4.3.0.
    + Update Homepage information. (Closes: #883650)
  * debian/copyright: Use secure uri for Format field.

 -- Boyuan Yang <byang@debian.org>  Sat, 02 Feb 2019 14:29:37 -0500

libev (1:4.22-1) unstable; urgency=medium

  * Imported Upstream version 4.22
  * Restore original ev.3 after build
  * Patch ev.pod for spelling error
  * Copyright format 1.0
  * Standards-Version 3.9.6

 -- Jérémy Lal <kapouer@melix.org>  Mon, 11 Jan 2016 22:03:12 +0100

libev (1:4.15-3) unstable; urgency=low

  * Priority: optional except on development packages
  * dh9 hardening and multiarch
  * Patch configure.ac for automake >= 1.14 support
  * dh-autoreconf is back, now working nicely

 -- Jérémy Lal <kapouer@melix.org>  Tue, 10 Sep 2013 00:32:58 +0200

libev (1:4.15-2) unstable; urgency=low

  * Upload to unstable

 -- Jérémy Lal <kapouer@melix.org>  Sat, 31 Aug 2013 00:25:23 +0200

libev (1:4.15-1) experimental; urgency=low

  * New upstream release. (Closes: #613116)
  * Remove obsolete DMUA field.
  * Standards-Version 3.9.4 compliant.
  * debian/libev4.symbols: add three new symbols.
  * debian/rules:
    + fix hardening
    + no longer needed to autoreconf.
  * No longer build-depend on dh-autoreconf.

 -- Jérémy Lal <kapouer@melix.org>  Wed, 01 May 2013 01:01:54 +0200

libev (1:4.11-1) unstable; urgency=low

  * New upstream release. (Closes: #657080)
  * Taking over package maintenance. Adding DM-Upload-Allowed: yes.
  * Bump Standards-Version to 3.9.2
  * Removed patch applied to master branch, applied upstream. (Closes: #643186)
  * debian/rules: remove unneeded overrides :
    + Makefile has a rule for ev.3: ev.pod and calls pod2man when needed.
    + Use dh-autoreconf
  * debian/control: add Vcs-* fields, move git repository to collab-maint.
  * debian/copyright: convert to DEP-5 format.

 -- Jérémy Lal <kapouer@melix.org>  Sat, 11 Feb 2012 02:00:25 +0100

libev (1:4.04-1) unstable; urgency=low

  * New upstream release.
    - API/ABI bump from libev3 to libev4.
  * Convert packaging to git.

 -- Robert S. Edmonds <edmonds@debian.org>  Mon, 21 Feb 2011 18:40:13 -0500

libev (1:3.9-1) unstable; urgency=low

  * New upstream release.

 -- Robert S. Edmonds <edmonds@debian.org>  Tue, 09 Mar 2010 14:32:48 -0500

libev (1:3.8-1) unstable; urgency=low

  * New upstream release.
  * Build depend on quilt >= 0.46-4.1; closes: #484232.

 -- Robert S. Edmonds <edmonds@debian.org>  Sun, 23 Aug 2009 14:34:56 -0400

libev (1:3.6-1) unstable; urgency=low

  * New upstream release.
  * Invoke autoreconf -fvi in debian/rules; closes: #511235.
  * Add new symbols ev_now_update, ev_resume, ev_suspend.

 -- Robert S. Edmonds <edmonds@debian.org>  Sat, 09 May 2009 14:50:06 -0400

libev (3.43-1.1) unstable; urgency=low

  * Non-maintainer upload.
  * Reupload with architecture-independent binaries (Closes: #507381).

 -- Cyril Brulebois <kibi@debian.org>  Sun, 07 Dec 2008 15:26:48 +0100

libev (3.43-1) unstable; urgency=low

  * New upstream release

 -- Robert S. Edmonds <edmonds@debian.org>  Sat, 19 Jul 2008 17:41:35 -0400

libev (3.41-1) unstable; urgency=low

  * New upstream release
  * Add new symbols ev_loop_verify, verify_watcher.
  * Use debhelper 7.
  * Convert from dpatch to quilt.

 -- Robert S. Edmonds <edmonds@debian.org>  Sun, 25 May 2008 16:44:17 -0400

libev (3.2-1) unstable; urgency=low

  * New upstream release

 -- Robert S. Edmonds <edmonds@debian.org>  Fri, 11 Apr 2008 02:11:28 -0400

libev (3.1-1) unstable; urgency=low

  * New upstream release:
    - ev_async watchers
  * Add new symbols ev_async_send, ev_async_start, ev_async_stop.

 -- Robert S. Edmonds <edmonds@debian.org>  Sat, 15 Mar 2008 18:19:28 -0400

libev (3.0-2) unstable; urgency=low

  * Make libev-libevent-dev Architecture: all.

 -- Robert S. Edmonds <edmonds@debian.org>  Wed, 12 Mar 2008 16:41:14 -0400

libev (3.0-1) unstable; urgency=low

  * New upstream release:
    - API/ABI bump.
  * Build new binary package libev-libevent-dev which contains the libevent
    event loop compatibility header; closes: #460735.

 -- Robert S. Edmonds <edmonds@debian.org>  Mon, 04 Feb 2008 19:23:33 -0500

libev (2.01-1) unstable; urgency=low

  * Initial release; closes: #459268.
  * Rename /usr/include/event.h to /usr/include/ev-event.h to avoid libev-dev
    conflicting with libevent-dev.

 -- Robert S. Edmonds <edmonds@debian.org>  Fri, 11 Jan 2008 12:46:35 -0500