1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54
|
configure: Makefile
Makefile: Makefile.PL
dh_testdir
perl Makefile.PL INSTALLDIRS=vendor
build-arch: build
build-indep: build
build: build-stamp
build-stamp: configure
dh_testdir
$(MAKE) OPTIMIZE="-O2 -g -Wall"
touch build-stamp
clean:
dh_testdir
dh_testroot
rm -f build-stamp
[ ! -f Makefile ] || $(MAKE) distclean
rm -f Makefile Makefile.old
dh_clean
binary-indep: build
dh_testdir
dh_testroot
dh_clean
dh_installdirs
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
$(MAKE) test
endif
$(MAKE) install DESTDIR=$(CURDIR)/debian/libexcel-writer-xlsx-perl/
dh_lintian
dh_install
dh_installdocs -n
dh_installchangelogs
dh_compress
dh_fixperms
dh_installdeb
dh_perl
dh_gencontrol
dh_md5sums
dh_builddeb
binary-arch: build
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary configure
|