1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26
|
Description: do not compare filenames not present under autopkgtest
Forwarded: not-needed
Author: Florian Schlichting <fsfs@debian.org>
Reviewed-by: gregor herrmann <gregoa@debian.org>
Last-Update: 2022-04-02
@@ -52,6 +52,9 @@
! $ignore{$_}
} $rule->in( curdir() );
+ SKIP: {
+ skip 'running under autopkgtest', 1 if -e 'lib/Debian/pkgperl/Foobar.pm';
+
is_deeply( \@files, [ qw{
Changes
META.json
@@ -59,6 +62,7 @@
Makefile.PL
lib/File/Find/Rule/Perl.pm
} ], 'Found the expected files' );
+ }
}
}
|