1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36
|
Source: libformat-human-bytes-perl
Maintainer: Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Uploaders: Deepak Tripathi <apenguinlinux@gmail.com>,
Damyan Ivanov <dmn@debian.org>
Section: perl
Priority: optional
Build-Depends: debhelper (>= 7.2.13)
Build-Depends-Indep: perl
Standards-Version: 3.9.5
Vcs-Browser: http://anonscm.debian.org/gitweb/?p=pkg-perl/packages/libformat-human-bytes-perl.git
Vcs-Git: git://anonscm.debian.org/pkg-perl/packages/libformat-human-bytes-perl.git
Homepage: https://metacpan.org/release/Format-Human-Bytes
Package: libformat-human-bytes-perl
Architecture: all
Depends: ${misc:Depends},
${perl:Depends}
Description: Format a bytecount and make it human readable
Format::Human::Bytes is used to convert bytecount values to human-readable
strings. It will return you a printable string which is more readable by
humans than a simple bytecount.
.
For example:
use Format::Human::Bytes;
$readable = Format::Human::Bytes::base2($bytecount[,$decimals]);
It will convert in base 2 format.
.
$readable = Format::Human::Bytes::base10($bytecount[,$decimals]);
It will convert in base 10 format.
.
Another way is to create constructor for example:
.
$fhb = Format::Human::Bytes->new();
$readable = $fhb->base2($bytecount[,$decimals]);
$readable = $fhb->base10($bytecount[,$decimals]);
|