File: changelog

package info (click to toggle)
libforms 1.2.3-1.3
  • links: PTS
  • area: main
  • in suites: buster, sid, stretch
  • size: 10,736 kB
  • ctags: 9,015
  • sloc: ansic: 97,669; sh: 11,156; makefile: 951
file content (333 lines) | stat: -rw-r--r-- 12,336 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
libforms (1.2.3-1.3) unstable; urgency=medium

  * Non-maintainer upload.
  * Switch to the dh sequencer (Closes: #822042, #805947)

 -- Paul Wise <pabs@debian.org>  Wed, 24 Aug 2016 13:31:03 +0800

libforms (1.2.3-1.2) unstable; urgency=medium

  * Non-maintainer upload.
  * Update the build system using dh-autoreconf, in order to fix build
    failure on ppc64el (thanks, Daniel Schepler; closes: #702269).

 -- Colin Watson <cjwatson@debian.org>  Sat, 04 Oct 2014 06:18:51 +0100

libforms (1.2.3-1.1) unstable; urgency=medium

  * Non-maintainer upload.
  * Switch from libtiff4-dev to libtiff-dev (Closes: #736022)

 -- Paul Wise <pabs@debian.org>  Mon, 30 Jun 2014 10:42:13 +0800

libforms (1.2.3-1) unstable; urgency=medium

  * New upstream release

 -- Peter S Galbraith <psg@debian.org>  Sat, 22 Feb 2014 12:59:58 -0500

libforms (1.0.93sp1-2) unstable; urgency=low

  * Bug fix: "Please Build-Depends on libjpeg-dev, not libjpeg62-dev",
    thanks to Bill Allombert (Closes: #634137).

 -- Peter S Galbraith <psg@debian.org>  Tue, 19 Jul 2011 12:48:13 -0400

libforms (1.0.93sp1-1) unstable; urgency=low

  * New upstream release with soname bump to 2.
    Should fix bug: "[kali] segfault at startup" with kali rebuild
    (See: #558025).
  * Changed source package name to unversioned "libforms"
  * Remove mention of very old libforms0.88-bin, libforms0.89-bin and
    xforms-dev.
  * Standards-Version: 3.8.4
  * Switch to dpkg-source 3.0 (quilt) format (I simply added the
    debian/source/format file).

 -- Peter S Galbraith <psg@debian.org>  Wed, 26 May 2010 19:23:06 -0400

libforms1 (1.0.92sp1-5) unstable; urgency=low

  * Uptream patches to add dir entry in texinfo file.

 -- Peter S Galbraith <psg@debian.org>  Tue, 13 Oct 2009 21:49:50 -0400

libforms1 (1.0.92sp1-4) unstable; urgency=low

  * Fix buildd error. Missing texlive-latex-base for xforms.pdf fonts.
  * Bug fix: "libforms-dev-1.0.92sp1-2 depends on libforms-1.0.92sp1-1",
    thanks to Arthur Marsh (Closes: #550450).  Replaced specific version
    with ${binary:Version} so it shouldn't happen again.

 -- Peter S Galbraith <psg@debian.org>  Sat, 10 Oct 2009 09:28:11 -0400

libforms1 (1.0.92sp1-3) unstable; urgency=low

  * Fix buildd error. Merge arch-independent and arch-dependent builf even
    if redundant (for now).

 -- Peter S Galbraith <psg@debian.org>  Fri, 09 Oct 2009 23:38:07 -0400

libforms1 (1.0.92sp1-2) unstable; urgency=low

  * Bug fix: "libforms1 - FTBFS: texi2html: Command not found", thanks to
    Bastian Blank (Closes: #550350).  Fix Build-Dependency.
  * missing-dependency-on-install-info, added depends on
    "dpkg (>= 1.15.4) | install-info"

 -- Peter S Galbraith <psg@debian.org>  Fri, 09 Oct 2009 17:40:28 -0400

libforms1 (1.0.92sp1-1) unstable; urgency=low

  * New upstream release (minor bug fixes)
  * libforms-doc: new binary package, replaces old non-free package.
  * debian/libforms-doc.doc-base registers HTML docs.

 -- Peter S Galbraith <psg@debian.org>  Thu, 08 Oct 2009 20:46:02 -0400

libforms1 (1.0.92-1) unstable; urgency=low

  * New upstream release. Thanks to Steffen Moeller (Closes: #549614).
  * Drop `Pre-Depends: x11-common (>= 1:7.0)'
  * Delete lintian overrides
  * Change Build-depends xlibmesa-gl-dev to libgl1-mesa-dev

 -- Peter S Galbraith <psg@debian.org>  Tue, 06 Oct 2009 17:50:16 -0400

libforms1 (1.0-8) unstable; urgency=low

  * Added libxext-dev to build-depends. Thanks to Lucas Nussbaum
    (Closes: #486960, #486983).
  * Standards-Version 3.8.0. Added Homepage to control file.

 -- Peter S Galbraith <psg@debian.org>  Thu, 19 Jun 2008 21:30:49 -0400

libforms1 (1.0-7) unstable; urgency=low

  * Bug fix: "libforms-dev: ships files under /usr/X11R6 deprecated
    hierarchy", thanks to Henrique de Moraes Holschuh for reporting, to
    Andreas Jochens for a patch and to Steve Langasek for the
    Pre-Depends info (Closes: #363574).
  * dev packages pre-depend on x11-common (>= 1:7.0) to make sure that
    /usr/include/X11 is a directory, not a symlink, at the time of unpack
    (thanks to Steve Langasek)
  * Changes submitted by Elimar Riesebieter <riesebie@lxtec.de>
    (Closes: #363574)
    - Completly reorganized rules.
    - We now install the devs to /usr/include/X11 (Xorg7 transition ;)
    - Introduced compat level 5

 -- Peter S Galbraith <psg@debian.org>  Sat, 22 Apr 2006 19:19:44 -0400

libforms1 (1.0-6) unstable; urgency=medium

  * debian/control: forgot a few instances of oldlib xlibs-dev to change
    for libxpm-dev.
  * debian/control: "libforms-dev: Override disparity", libforms-dev goes
    in section libdevel (Closes: #263134).

 -- Peter S Galbraith <psg@debian.org>  Tue,  3 Aug 2004 19:56:38 -0400

libforms1 (1.0-5) unstable; urgency=medium

  * Bug fix: "rebuild with libtiff4, upload with urgency=medium", thanks
    to Jay Berkenbilt (Closes: #262829).
  * Standards-Version 3.6.1 without changes
  * Remove oldlib build-depends; add libxpm-dev.

 -- Peter S Galbraith <psg@debian.org>  Mon,  2 Aug 2004 21:34:29 -0400

libforms1 (1.0-4) unstable; urgency=low

  * Create `libformsgl1' and `libformsgl-dev' packages with OpebGL
    bindings, adding xlibmesa-gl-dev ad build-depends (closes: #18462).

 -- Peter S Galbraith <psg@debian.org>  Mon,  4 Aug 2003 23:16:33 -0400

libforms1 (1.0-3) unstable; urgency=low

  * Remove hardwired dependency on xlib6g and xlibs.  That must be a
    leftover from the binary-only days.  (closes: #182643)

 -- Peter S Galbraith <psg@debian.org>  Wed, 26 Feb 2003 20:35:37 -0500

libforms1 (1.0-2) unstable; urgency=low

  * Move libforms-bin's man page from /usr/man to /usr/share/man
  (closes: #173203)
  * Make sure installed header files have 604 permissions.

 -- Peter S Galbraith <psg@debian.org>  Sun, 15 Dec 2002 15:35:29 -0500

libforms1 (1.0-1) unstable; urgency=low

  * New upstream release...  LGPL'ed !!! (closes: #144223)
  * "Party, party, party! Free at last!" (closes: #140915)
  * Rewrote the debian directory files since this is now a real source
    package (it used to copy binary files into place).

 -- Peter S Galbraith <psg@debian.org>  Sun,  8 Dec 2002 20:01:05 -0500

libforms0.89 (0.89-12) unstable; urgency=low

  * debian/control: added s390 architecture. (closes: #120722)
  * Package now has: 
     glibc2.1 version for i386, powerpc, alpha, m68k, sparc, ia64 and s390.
  * Fix spelling mistake for word 'publicly' (closes: #124946, #124947)

 -- Peter S Galbraith <psg@debian.org>  Mon,  7 Jan 2002 13:38:03 -0500

libforms0.89 (0.89-11) unstable; urgency=low

  * debian/control: added ia64 architecture.
  * debian/rules: use forms.h from each arch instead of always the i386
    version, since the fixlevel version is different (e.g. 0.89.X).
  * Updated binaries for alpha.
  * debian/control: Updated to Standards-Version 3.5.6 without
    changes. The package breaks new X policy because it installs libraries
    under /usr/X11R6/lib and a header file under /usr/X11R6/include/X11.
    I'm hoping that a new 0.90 upstream package will allow me to make the
    transition out of /usr/X11R6 without problems for packages that depend
    on XForms.

 -- Peter S Galbraith <psg@debian.org>  Thu,  8 Nov 2001 15:21:27 -0500

libforms0.89 (0.89-10) unstable; urgency=low

  * debian/control: /usr/X11R6/include/X11/forms.h includes files like
    X11/Xlib.h from xlibs-dev so package libforms-dev needs to depend on
    it.

 -- Peter S Galbraith <psg@debian.org>  Tue,  4 Sep 2001 13:47:29 -0400

libforms0.89 (0.89-9) unstable; urgency=low

  * New maintainer
  * Changed depends from xpm4g to libxpm4 (closes: #70561)
  * Updated to Standards-Version 3.1.1 (Build-Depends)

 -- Peter S Galbraith <psg@debian.org>  Thu, 14 Sep 2000 12:37:47 -0400

libforms0.89 (0.89-8) unstable; urgency=low

  * NMU approved by Michael Meskes <meskes@debian.org> 
  * Added glibc2.1 binaries for sparc.
  * Package now has: 
     glibc2.1 version of 0.89 for i386, powerpc, alpha, m68k and sparc.

 -- Peter S Galbraith <psg@debian.org>  Tue, 15 Aug 2000 09:09:55 -0400

libforms0.89 (0.89-7) unstable; urgency=low

  * NMU approved by Michael Meskes <meskes@debian.org> 
  * Package libforms-dev now depends on libc6-dev instead of libc6 (>= 2.1)
  * Updated i386 binaries and demo sources to current upstream version.
  * Package now has: 
     glibc2.1 version of 0.89 for i386, powerpc and alpha and m68k.

 -- Peter S Galbraith <psg@debian.org>  Mon,  7 Aug 2000 14:11:51 -0400

libforms0.89 (0.89-6) frozen unstable; urgency=low

  * NMU approved by Michael Meskes <meskes@debian.org> 
  * add glibc2.1 binaries for m68k architecture (since this is a binary-only
    package without source code, m68k did not have a libforms0.89 package).
  * Package now has: 
    glibc2.1 version of 0.89 for i386, powerpc and alpha;
    glibc2.1 version of 0.89.1 for m68k.

 -- Peter S Galbraith <psg@debian.org>  Thu, 18 May 2000 11:51:31 -0400

libforms0.89 (0.89-5) frozen unstable; urgency=low

  * NMU approved by Michael Meskes <meskes@debian.org> 
  * add glibc2.1 binaries for alpha architecture (since this is a binary-only
    package without source code, alpha did not have a libforms0.89 package).
  * update copyright file to point to new web site.
  * minor license change.
  * Package now has: glibc2.1 version for i386, powerpc and alpha;
  
 -- Peter S Galbraith <psg@debian.org>  Thu, 13 Apr 2000 13:40:32 -0400

libforms0.89 (0.89-4) unstable; urgency=low

  * NMU approved by Michael Meskes <meskes@debian.org> 
  * Had omitted symlink libforms.so -> libforms.so.0.89 in -dev package

 -- Peter S Galbraith <psg@debian.org>  Sun,  7 Nov 1999 18:57:04 -0500

libforms0.89 (0.89-3) unstable; urgency=low

  * NMU approved by Michael Meskes <meskes@debian.org> 
  * Removed compatibility symlink libforms.so.0.88->libforms.so.0.89
    because we also need a glibc2.1 version of libforms.so.0.88 since they
    are not fully compatible.  For example, Lyx is broken under V0.89.
  * Removed the `replaces, conflicts, provides: libforms0.88'
    since a glibc2.1 version of libforms0.88 is brought back to life.
  
 -- Peter S Galbraith <psg@debian.org>  Sat, 30 Oct 1999 13:02:41 -0400

libforms0.89 (0.89-2) unstable; urgency=low

  * NMU approved by Michael Meskes <meskes@debian.org> 
  * Added powerpc binaries
  * Hacked rules file to handle all architectures; scheme uses a native
    tar file format, which we will update whenever we add an architecture.
    close #27327: libforms0.88: there are more architectures available  
  * Removed the versioned depends libforms-dev had on libforms0.89 (= 0.89-1)

 -- Peter S Galbraith <psg@debian.org>  Wed, 13 Oct 1999 22:20:49 -0400

libforms0.89 (0.89-1) unstable; urgency=low

  * New upstream version (closes:Bug#43435)
  * Added original source location to copyright file (closes:Bug#44431)
  * Added compatibility symlink libforms.so.0.88->libforms.so.0.89.
  * Switced to latest debhelper tools.

 -- Michael Meskes <meskes@debian.org>  Mon, 27 Sep 1999 15:24:09 +0200

libforms0.88 (0.88.1-2) frozen unstable; urgency=low

  * Resolved file overlap between bo's xforms-dev and hamm's libforms-bin
    with a Replaces:.

 -- Ben Gertzfield <che@debian.org>  Wed, 13 May 1998 13:27:39 -0700

libforms0.88 (0.88.1-1) unstable; urgency=low

  * New upstream version.

 -- Ben Gertzfield <che@debian.org>  Fri,  6 Mar 1998 18:32:11 -0800

libforms0.88 (0.88-4) unstable; urgency=low

  * Whoops, header should be in /usr/X11R6/include/X11, not
    /usr/X11R6/include/. Fixes bug #16691.
  * Commented out dh_du call in debian/rules, le sigh.

 -- Ben Gertzfield <che@debian.org>  Tue, 17 Feb 1998 14:59:07 -0800

libforms0.88 (0.88-3) unstable; urgency=low

  * Added in 'fdesign' program to -dev. Fixes bug #17811.
  * Moved binaries and libraries and headers into /usr/X11R6/. 
    Fixes bug #16691.
  * -dev package now Conflicts: with and Replaces: xforms-dev.
    Fixes bug #16691.

 -- Ben Gertzfield <che@debian.org>  Wed,  4 Feb 1998 17:36:02 -0800

libforms0.88 (0.88-2) unstable; urgency=low

  * Fixed shlibs file to make soname 0.88, not 0.

 -- Ben Gertzfield <che@debian.org>  Fri,  2 Jan 1998 22:12:50 -0800

libforms0.88 (0.88-1) unstable; urgency=low

  * Initial release.
  * No source available; binary only.

 -- Ben Gertzfield <che@debian.org>  Fri,  2 Jan 1998 16:11:09 -0800