File: CHANGES

package info (click to toggle)
libgetargs-long-perl 1.1002-1
  • links: PTS
  • area: main
  • in suites: lenny
  • size: 252 kB
  • ctags: 233
  • sloc: perl: 3,190; makefile: 43
file content (68 lines) | stat: -rw-r--r-- 2,116 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
Version 1.1002 : Tues Nov 6 2007
- Dual-licensed the code under the GPL and Artistic licenses. (By the request
	of Brandon Forehand <b4hand@users.sourceforge.net>.) Raphael Manfredi agreed
	over email to changing the license on his code.

Version 1.1001 : Mon Jun 6 2005
- Fixed incorrect comments in Long.pm and test cases

Version 1.1000: Tue Dec 21 2004
- Fixed version numbers, which were incompatible with some modules. (Thanks to
  Tassilo von Parseval <tassilo.von.parseval@rwth-aachen.de> for the bug
  report)
- Removed custom installation prompt.
- Cleaned up documentation a bit.

Version 1.0.1: Thu Sep 16 2004
- Added missing inc/ dependency
- Switched to Test::More for better test reporting

Version 1.0.0: Wed Sep 15 2004
- David Coppit <david@coppit.org> is the new maintainer.
- License changed to GPL
- Changed Makefile.PL to use Module::Install
- Version numbering changed
- Added a check for the perl version number

Tue Mar 20 11:37:54 MET 2001   Raphael Manfredi <Raphael_Manfredi@pobox.com>

. Description:

	Version 0.1.3.

	Changed interface of all getargs() routines.  This change is
	NOT backward compatible, but this is the privilege of still
	being at the alpha stage...  Previous calls were made as:

	    getargs(\@_, ...)

	and must now be written as:

	    getargs (@_, ...)

	with an implicit reference being taken, via Perl prototyping.

	Added mention of similar module Params::Validate.  His author
	contacted me to mention it, and apparently we independently
	invented the same thing, albeit with slight different goals
	and interfaces.

	Added warning about interface change during the run of
	Makefile.PL if a previous incompatible version is detected.

	Updated all getargs() calls to new interface in the regression
	test suite.

Thu Mar 15 01:14:21 MET 2001   Raphael Manfredi <Raphael_Manfredi@pobox.com>

. Description:

	Added warning when using perl 5.6.0.  Don't use that version
	of Perl.  Either use 5.005_03, or try 5.6.1.

Fri Mar  2 19:00:00 MET 2001   Raphael Manfredi <Raphael_Manfredi@pobox.com>

. Description:

	Forgot to include t/code.pl in distribution