File: changelog

package info (click to toggle)
libgetdata 0.10.0-6
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 16,172 kB
  • sloc: ansic: 99,852; cpp: 4,820; fortran: 4,524; sh: 4,178; f90: 2,543; python: 2,378; perl: 1,893; php: 1,447; makefile: 1,421
file content (257 lines) | stat: -rw-r--r-- 8,387 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
libgetdata (0.10.0-6) unstable; urgency=medium

  * Standards-Version: 4.4.0
  * Drop python2 support
  * Use debhelper-compat (=12)
  * B-D on gfortran | fortran-compiler
  * use f77 and f95 as fortran compiler aliases in d/rules
  * Use --as-needed when linking with gfortran but not flang

 -- Alastair McKinstry <mckinstry@debian.org>  Sat, 20 Jul 2019 14:09:57 +0100

libgetdata (0.10.0-5) unstable; urgency=medium

  * Rebuild for python3.7 support

 -- Alastair McKinstry <mckinstry@debian.org>  Sun, 08 Jul 2018 15:05:59 +0100

libgetdata (0.10.0-4) unstable; urgency=medium

  * Standards-Version: 4.1.4
  * Use https for homepage
  * Use Priority: optional, not extra
  * Drop calls, dep on autotools_dev with DH 10
  * Mark  packages as M-A foreign, same
  * Drop ancient x-python-version
  * Move VCS to salsa.d.o
  * Force use of gfortran-8 for mod format transition
  * Add libltdl-dev dependency 

 -- Alastair McKinstry <mckinstry@debian.org>  Mon, 07 May 2018 11:16:32 +0100

libgetdata (0.10.0-3) unstable; urgency=medium

  * libltdl-dev now needed to build. Closes: #865312
  * Standards-Version: 4.0.0. No changes required

 -- Alastair McKinstry <mckinstry@debian.org>  Wed, 21 Jun 2017 12:34:46 +0100

libgetdata (0.10.0-2) unstable; urgency=medium

  * Update copyright file. Closes: #861767

 -- Alastair McKinstry <mckinstry@debian.org>  Thu, 18 May 2017 17:24:04 +0100

libgetdata (0.10.0-1) experimental; urgency=medium

  * New upstream release
  * Soname bump:
     libgetdata7 -> libgetdata8
     libfgetdata5 -> libfgetdata6
     libf95getdata6 -> libf95getdata7
     libgetdata++6 -> libgetdata++7     

 -- Alastair McKinstry <mckinstry@debian.org>  Wed, 03 May 2017 11:40:07 +0100

libgetdata (0.9.4-1) unstable; urgency=medium

  * New upstream release
  * DH_COMPAT=10
  * Enable flac. Add dependendencies on libflac-dev, flac
  * d/rules: no longer need to rename site-packages -> dist-packages

 -- Alastair McKinstry <mckinstry@debian.org>  Mon, 19 Sep 2016 09:08:31 +0100

libgetdata (0.9.3-2) unstable; urgency=medium

  * Add python3-pygetdata package.

 -- Alastair McKinstry <mckinstry@debian.org>  Tue, 09 Aug 2016 04:59:21 +0100

libgetdata (0.9.3-1) unstable; urgency=medium

  * New upstream version
  * Standards-Version: 3.9.8

 -- Alastair McKinstry <mckinstry@debian.org>  Wed, 03 Aug 2016 12:41:46 +0100

libgetdata (0.9.1-2) unstable; urgency=medium

  * Add Breaks/Replaces, as package names in 0.9.0 were not conssitent with
    sonames.

 -- Alastair McKinstry <mckinstry@debian.org>  Sun, 21 Feb 2016 18:09:25 +0000

libgetdata (0.9.1-1) unstable; urgency=medium

  * New upstream release.
  * Use xz compression.
  * Another soname bump:
      libfgetdata2 -> libfgetdata5
      libgetdata5 -> libgetdata7
      libgetdata++3 -> libgetdata++6
      libf95getdata2 -> libf96getdata6

 -- Alastair McKinstry <mckinstry@debian.org>  Sat, 20 Feb 2016 16:10:07 +0000

libgetdata (0.9.0-2.2) unstable; urgency=medium

  * Non-maintainer upload.
  * libgetdata-doc: Reinstate the Breaks+Replaces against libgetdata-dev.
    (Closes: #799340)

 -- Andreas Beckmann <anbe@debian.org>  Sat, 09 Jan 2016 14:48:03 +0100

libgetdata (0.9.0-2.1) unstable; urgency=medium

  * Non-maintainer upload.
  * Correct Breaks/Replaces on libgetdata-doc, remove those added
    in previous uploads (Closes: #799340)

 -- Jonathan Wiltshire <jmw@debian.org>  Sat, 02 Jan 2016 22:23:48 +0000

libgetdata (0.9.0-2) unstable; urgency=medium

  * Breaks/Replace fix for libgetdata-tools. Closes: #799340.

 -- Alastair McKinstry <mckinstry@debian.org>  Sat, 21 Nov 2015 01:46:55 +0000

libgetdata (0.9.0-1) unstable; urgency=medium

  * New upstream release
  * Breaks/Replace fix. Closes: #799340.

 -- Alastair McKinstry <mckinstry@debian.org>  Thu, 29 Oct 2015 05:22:16 +0000

libgetdata (0.8.9-3) unstable; urgency=medium

  * Add Breaks to -dev, -doc packages to resolve upgrade issue.
    Closes: #799340.

 -- Alastair McKinstry <mckinstry@debian.org>  Tue, 20 Oct 2015 19:29:39 +0100

libgetdata (0.8.9-2) unstable; urgency=medium

  [ Alastair McKinstry ]
  * Add build-depends on libmodule-build-perl for perl5.22. Closes: #799118. 

 -- Alastair McKinstry <mckinstry@debian.org>  Wed, 16 Sep 2015 08:54:54 +0100

libgetdata (0.8.9-1) unstable; urgency=low

  [ Steven Benton ]
  * New upstream release.
  * Removed patches, both were fixed upstream
  * Update Standards-Version to 3.9.6
  * change versioning to reflect SONAME change
  * add libgetdata-doc package for documentation
  * add encoding (compression) libraries to Build-Depends
  * add libgetdata-perl package for perl bindings
  * enable autotools-dev to update config.{guess,sub} (Closes: #727407)
  * enable multi-arch on library packages

 -- Alastair McKinstry <mckinstry@debian.org>  Mon, 07 Sep 2015 22:37:14 +0100

libgetdata (0.7.3-6.2) unstable; urgency=medium

  * Non-maintainer upload.
  * Port from python-support to dh_python2 (Closes: #785977)
  * Call dh_numpy, to generate dependencies based on the numpy ABI.

 -- Stefano Rivera <stefanor@debian.org>  Wed, 26 Aug 2015 12:55:40 -0700

libgetdata (0.7.3-6.1) unstable; urgency=medium

  * Non-maintainer upload.
  * Build against gcc5/gfortran for transition.

 -- Alastair McKinstry <mckinstry@debian.org>  Fri, 14 Aug 2015 10:40:54 +0100

libgetdata (0.7.3-6) unstable; urgency=low

  * Fix lintian warnings about manpage NAME entries
  * Update control fields for upload to Debian

 -- Michael Milligan <mmilligan@astro.umn.edu>  Sun, 18 Sep 2011 11:02:34 -0500

libgetdata (0.7.3-5) lucid; urgency=low

  * added proper Breaks/Replaces relationship between -tools and -util

 -- Steven Benton <stevebenton@rogers.com>  Fri, 22 Jul 2011 12:08:51 -0400

libgetdata (0.7.3-4) lucid; urgency=low

  * removed bad patch persisting 0.7.1, for all files (not just Makefile.in)
  * patch to configure script, allows C++ not to be built, until fixed upstream

 -- Steven Benton <stevebenton@rogers.com>  Thu, 21 Jul 2011 13:30:19 -0400

libgetdata (0.7.3-3) lucid; urgency=low

  * libgetdata-dev now depends an all C, C++, F77, F95 runtime libraries
  * removed erroneous patch that persisted an old version of Makefile.in
  * renamed libgetdata-util to libgetdata-tools

 -- Steven Benton <stevebenton@rogers.com>  Wed, 20 Jul 2011 10:58:08 -0400

libgetdata (0.7.3-2) lucid; urgency=low

  * added packaging for the fortran bindings
  * added dependencies on libgetdata4 to all other binary packages
  * -dev package now recommends c++ and fortran libraries
  * do not install libtool .la files
  * readded watch file

 -- Steven Benton <stevebenton@rogers.com>  Mon, 18 Jul 2011 14:58:17 -0400

libgetdata (0.7.3-1) unstable; urgency=low

  * renamed and reorganized packages to conform to Debian policy
  * libgetdata split to libgetdata4 and libgetdata++2
  * libgetdata-python renamed to python-pygetdata

 -- Michael Milligan <mmilligan@astro.umn.edu>  Thu, 07 Jul 2011 04:08:59 -0500

libgetdata (0.7.3) lucid; urgency=low

  * new upstream release
  * added debian/source/format file to maybe fix native-package confusion
  * remove watch file since package name differs from sf project

 -- Steven Benton <stevebenton@rogers.com>  Thu, 23 Jun 2011 16:21:58 -0400

libgetdata (0.7.1) lucid; urgency=low

  * new upstream release
  * repackaged again as not debian-native (I must be doing something wrong)
  * packaged python bindings in libgetdata-python

 -- Steven Benton <stevebenton@rogers.com>  Thu, 23 Jun 2011 16:19:14 -0400

libgetdata (0.7.0) lucid; urgency=low

  * new upstream release
  * repackaged as not debian-native (it shouldn't be, and wasn't originally)
  * removed sonumber from library package, since nobody will run old getdata
  * added new dirfile2ascii to -util, along with manpages

 -- Steven Benton <stevebenton@rogers.com>  Wed, 24 Nov 2010 11:09:59 +1300

libgetdata (0.6.3ppa2) lucid; urgency=low

  * added utility programs in new libgetdata-util package

 -- Steven Benton <stevebenton@rogers.com>  Sat, 20 Nov 2010 10:26:09 +1300

libgetdata (0.6.3ppa1) jaunty; urgency=low

  * fix licensing terms: LGPL 2.1 is different from LGPL 2

 -- Steven Benton <stevebenton@rogers.com>  Fri, 07 May 2010 18:38:57 -0400

libgetdata (0.6.3ppa0-1) jaunty; urgency=low

  * Initial release and debianization

 -- Steven Benton <stevebenton@rogers.com>  Fri, 07 May 2010 18:38:57 -0400