File: changelog

package info (click to toggle)
libgmpada 1.0-3
  • links: PTS, VCS
  • area: main
  • in suites: stretch
  • size: 600 kB
  • ctags: 93
  • sloc: ada: 5,112; makefile: 146; ansic: 118; sh: 15
file content (232 lines) | stat: -rw-r--r-- 9,270 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
libgmpada (1.0-3) unstable; urgency=medium

  * Previous patch does not fix the FTBFS and uses obsolete -aL option.
    Copy the objects in ALI directory instead.
  * Pass build flags to tests, especially activate assertions.

 -- Nicolas Boulenguez <nicolas@debian.org>  Mon, 16 May 2016 17:36:00 +0200

libgmpada (1.0-2) unstable; urgency=medium

  * patches/gnatmake-al-not-ao-alidir.diff: changing gnatmake options to
    work around a segfault in a test with gnat-6 on kfreebsd-amd64.

 -- Nicolas Boulenguez <nicolas@debian.org>  Mon, 16 May 2016 02:17:55 +0200

libgmpada (1.0-1) unstable; urgency=medium

  * New upstream release and website.
    Update watch, control/Homepage and copyright/Upstream-Contact.
    Drop get-orig-source target.
  * Build with gnat-6 and all hardening flags. Closes: #822775.
    Rename lib and -dev packages per Ada policy.
  * fake.gpr: new for dh-ada-library, no build project anymore.
  * Remove obsolete preinst scripts.
  * Replace manual -dbg packages with automatic -dbgsym.
  * Standards-Version: 3.9.8 (no changes).

 -- Nicolas Boulenguez <nicolas@debian.org>  Wed, 27 Apr 2016 18:22:01 +0200

libgmpada (0.0.20131223-4) unstable; urgency=medium

  * Touch generated sources for deterministic ALI files and tar headers.
  * Standards-Version: 3.9.6 (no changes).

 -- Nicolas Boulenguez <nicolas@debian.org>  Mon, 04 May 2015 14:47:22 +0200

libgmpada (0.0.20131223-3) unstable; urgency=medium

  * Pass CC to make, circumventing wrong autodetection. Closes: #768706.

 -- Nicolas Boulenguez <nicolas@debian.org>  Sun, 09 Nov 2014 14:18:38 +0100

libgmpada (0.0.20131223-2) unstable; urgency=medium

  * Migrate to gnat-4.9.
    Rename library and -dev package according to Ada policy.
  * move armored upstream signature to upstream/.
  * rules: run-tests target obsoleted by sadt from devscripts.

 -- Nicolas Boulenguez <nicolas@debian.org>  Fri, 02 May 2014 04:21:56 +0200

libgmpada (0.0.20131223-1) unstable; urgency=medium

  * New upstream release.
  * Standards-Version: 3.9.4 (no changes).
  * watch, upstream-signing-key.pgp added.

 -- Nicolas Boulenguez <nicolas@debian.org>  Mon, 23 Dec 2013 05:40:19 +0100

libgmpada (0.0.20121109-3) unstable; urgency=low

  * tests: valid test names may not contain underscores.
  * rules: updated run-tests target.
  * remove any /usr/share/doc/pkg symlink, they cause maintenance problems.

 -- Nicolas Boulenguez <nicolas@debian.org>  Sat, 24 Aug 2013 00:16:17 +0200

libgmpada (0.0.20121109-2) unstable; urgency=low

  * tests/link_with_shared: avoid gnatmake printing on stderr.
    Closes: #702634, #703310.
    rules: run-tests target updated to emulate recent autopkgtest.
  * source/options: deleted, so that dpkg uses the default compression.
  * README.debian: why lintian hardening-no-fortify-functions may be ignored.
  * control: Build-Depends: gnat-4.6 >= 4.6.4, so that gnatlink handles
    --as-needed linker flag properly. Closes: #702632.
  * control: Standards-Version: 3.9.4.
  * Updated copyrights.

 -- Nicolas Boulenguez <nicolas@debian.org>  Sun, 10 Mar 2013 20:04:13 +0100

libgmpada (0.0.20121109-1) unstable; urgency=low

  * New upstream release (no patches needed anymore).
  * control: libgmpada3-dev -> libgmpada4-dev, with Breaks/Replaces,
    due to debian-ada-policy.
    XS-Testsuite: autopkgtest (Closes: #692663).
    Maintainer, DM-Upload-Allowed: I am a DD.
    Build-Depends: gprbuild is not needed anymore
  * copyright: GPL2+ -> GPL3+.
  * watch: gz -> bzip2.

 -- Nicolas Boulenguez <nicolas@debian.org>  Thu, 08 Nov 2012 16:17:00 +0100

libgmpada (0.0.20120331-2) unstable; urgency=low

  * Inherit hardening CPPFLAGS.

 -- Nicolas Boulenguez <nicolas.boulenguez@free.fr>  Sat, 07 Jul 2012 21:37:49 +0200

libgmpada (0.0.20120331-1) unstable; urgency=low

  * New upstream release (neither ALI nor SO changes).
  * watch: search for bz2 tarballs too.
  * control: -dbg does not Pre-Depends: ${misc:Pre-Depends} for multiarch.
    -dev Depends: libmpfr-dev and libgmp-dev (Closes: #667481).
  * ada_libraries, control, rules: use dh_ada_library.

 -- Nicolas Boulenguez <nicolas.boulenguez@free.fr>  Wed, 04 Apr 2012 21:36:48 +0200

libgmpada (0.0.20120318-1) unstable; urgency=low

  * New upstream release (only build system changes).
  * README.Debian: replaced with a short reference to policy.
  * control: debhelper 9, Standards-Version 3.9.3 (no changes)
  * rules: simplified flags transmission
  * tests: create obj dir to conform to new upstream.

 -- Nicolas Boulenguez <nicolas.boulenguez@free.fr>  Sun, 18 Mar 2012 06:18:31 +0100

libgmpada (0.0.20110925-3) unstable; urgency=low

  * control: remove dependencies on ada-compiler virtual package.

 -- Nicolas Boulenguez <nicolas.boulenguez@free.fr>  Thu, 09 Feb 2012 20:50:50 +0100

libgmpada (0.0.20110925-2) unstable; urgency=low

  * rules: do not strip static archive.
  * lintian-overrides: wildcard instead of an explicit architecture.
  * README.Debian: should not depend on the architecture.
  * rules: get-orig-source and run-tests targets.
  * control (Build-Depends): a gprbuild providing -R option.
  * rules: replaced ALDH subsystem by debhelper overrides for readability.

 -- Nicolas Boulenguez <nicolas.boulenguez@free.fr>  Fri, 09 Dec 2011 23:48:58 +0100

libgmpada (0.0.20110925-1) unstable; urgency=low

  * New upstream release, a patch removed.
  * Build with gcc and gnat 4.6. Closes: #642642, #633569.
  * Multi arch support for library and -dev package.
    Build-Depends: debhelper >= 8.9.8 to accept new *.ali directory.
  * Package renaming due to debian-ada-policy:
    libgmpada2-dev -> libgmpada3-dev
    libgmpada1 -> libgmpada2
    libgmpada1-dbg -> libgmpada-dbg
  * source/options: max bzip2 compression for debian.tar
  * source/local-options: abort-on-upstream-changes, unapply-patches

 -- Nicolas Boulenguez <nicolas.boulenguez@free.fr>  Sat, 01 Oct 2011 00:02:50 +0200

libgmpada (0.0.20100805-2) unstable; urgency=low

  * compat, control: updated to debhelper 8.
  * rules: made dh targets more generic
  * patches: LDLIBS instead of LDFLAGS (ubuntu bug770987)

 -- Nicolas Boulenguez <nicolas.boulenguez@free.fr>  Wed, 13 Jul 2011 14:45:18 +0200

libgmpada (0.0.20100805-1) unstable; urgency=low

  * New upstream release.
  * control: (Build-Depends) upstream now uses gprbuild.
    An unversioned libgmp-dev is now available.
    (Standards-Version) 3.9.2 without changes.
    Development package renaming, Conflicts & Replaces due to debian-ada-policy.
  * copyright: updated.
  * patches: two integrated upstream, one updated.

 -- Nicolas Boulenguez <nicolas.boulenguez@free.fr>  Mon, 09 May 2011 00:25:14 +0200

libgmpada (0.0.20091124-4) unstable; urgency=low

  * control: (Architectures) any like all ada packages. Closes: #568441.
    see http://lists.debian.org/debian-ada/2010/02/msg00002.html)
    (Standards-Version) Updated to 3.9.0.0, no changes needed.
    (Vcs-Mtn) Corrected URL.
  * rules: SOVERSION and LIBNAME must be exported to upstream Makefile.
  * Switch to dpkg-source 3.0 (quilt) format.
  * (*-dev): depend on gnat, ada-compiler.
    (*-dbg): suggest gnat, gnat-4.4, ada-compiler.

  [Ludovic Brenta]
  * debian/control (DM-Upload-Allowed): yes, in anticipation of the
    application for DM status.

 -- Nicolas Boulenguez <nicolas.boulenguez@free.fr>  Thu, 01 Jul 2010 00:37:10 +0200

libgmpada (0.0.20091124-3) unstable; urgency=low

  * control: made each package description different to please lintian.
    (Architectures) explained why alpha is temporarily disabled.
  * patches: separated and documented removal of -gstabs+ and -fstack-check.
    Corrected an upstream incoherency in library project template.
  * watch: added.
  * rules: lintian override for shlib-with-executable-stack
    Generated separated debhelper files: more readability, less overloadings.

 -- Nicolas Boulenguez <nicolas.boulenguez@free.fr>  Wed, 20 Jan 2010 20:00:17 +0100

libgmpada (0.0.20091124-2) unstable; urgency=low

  * Patched demo/Makefile,devel.gpr,build.gpr: removed gcc flag -gstabs+
    in favor of more portable -g (FTBFS on ia64)
  * Closes: 559084 patched demo/Makefile to remove gcc flag -fstack-check
    Eric Botcazou says: "-fstack-check is broken with GCC 4.4 on x86/x86-64
    Linux, it generates code that will easily segfault"
    (http://gcc.gnu.org/PR20548).
  * rules;control;patches;README.source: added quilt support
  * control: XS-VCS- becomes Vcs- to please lintian
    (VCS-Mtn) new
    (VCS-Browser) official address
    (Architectures) any -> arch supporting GNAT to avoid dependency FTBFS

 -- Nicolas Boulenguez <nicolas.boulenguez@free.fr>  Wed, 16 Dec 2009 00:04:29 +0100

libgmpada (0.0.20091124-1) unstable; urgency=low

  * New upstream version. Avoids collision with libgmp package.
  * control, rules: split -dev and -dbg packages.
  * docs, examples, rules: clarified, removed command embedding unwanted
    files, avoid compressing examples,
  * README.Debian: updated, conformed to other packages.

 -- Nicolas Boulenguez <nicolas.boulenguez@free.fr>  Tue, 24 Nov 2009 01:46:21 +0100

libgmpada (0.0.20091113-1) unstable; urgency=low

  * New package. Closes: #555682.

 -- Nicolas Boulenguez <nicolas.boulenguez@free.fr>  Fri, 13 Nov 2009 16:21:34 +0100