File: changelog

package info (click to toggle)
libgnatcoll 18-4
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 5,068 kB
  • sloc: ada: 40,393; python: 354; ansic: 310; makefile: 245; sh: 31
file content (229 lines) | stat: -rw-r--r-- 9,703 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
libgnatcoll (18-4) unstable; urgency=medium

  * Debhelper 12. No need for d/compat anymore.
  * Standards-Version: 4.3.0.

  [ Dmitry Shachnev <mitya57@debian.org> ]
  * Remove unused and obsolete pngmath sphinx extension. Closes: #918816.

 -- Nicolas Boulenguez <nicolas@debian.org>  Wed, 09 Jan 2019 19:04:22 +0100

libgnatcoll (18-3) unstable; urgency=medium

  * The binary packages were introduced by the gnat-8 transition (#908931),
    but appear as new in unstable because of the two FTBS below.
  * Prevent Makefile from messing with gprconfig. Fixes i386, hurd-i386.
  * Depend gprbuild >= 2018-3. Fixes static archive on most architectures.
  * Standards-Version: 4.2.1. Rules-Requires-Root: no.
  * More checks in link options.

 -- Nicolas Boulenguez <nicolas@debian.org>  Thu, 01 Nov 2018 18:02:17 +0100

libgnatcoll (18-2) unstable; urgency=medium

  * Rebuild in unstable for gnat-8 transition.

 -- Nicolas Boulenguez <nicolas@debian.org>  Sat, 27 Oct 2018 15:09:56 +0200

libgnatcoll (18-1) experimental; urgency=medium

  * New upstream release, splitting former libgnatcoll source package.
    Some components move to libgnatcoll-bindings or libgnatcoll-db.
  * Remove more unwanted files.
  * Add previously forgotten copyright for getRSS.c.
  * Fix path to documentation in gps xml registration.
  * Link with libdl to fix a build failure.
  * Enable parallel build of documentation, #869098 is fixed.

 -- Nicolas Boulenguez <nicolas@debian.org>  Fri, 22 Jun 2018 22:42:23 +0200

libgnatcoll (17.0.2017-5) experimental; urgency=medium

  * Rebuild with gnat-8, libgpr1-dev, libgtkada18-dev..
    Rename shared libraries and -dev packages per Debian Ada policy.
  * Remove watch file. Explain why in README.source.
  * Install documentation to libgnatcoll-doc.
    Doc is shared for all -dev packages, so the effort is wasted.
  * Remove override for lintian pedantic messages.
  * Update upstream home page.
  * Use forgotten sphinxdoc:Built-Using substitution variable.

 -- Nicolas Boulenguez <nicolas@debian.org>  Tue, 08 May 2018 08:13:15 +0200

libgnatcoll (17.0.2017-4) unstable; urgency=medium

  * Upload to unstable.
  * Break+Replace: previous gtkada-dev package per Ada policy. Closes: #896570.
  * Standards-Version: 4.1.4.

 -- Nicolas Boulenguez <nicolas@debian.org>  Tue, 24 Apr 2018 17:17:56 +0200

libgnatcoll (17.0.2017-4~pre1) experimental; urgency=medium

  * Rebuild with libgtkada-dev updating gtk-gir, fixing gnat-gps.
    Ada policy requires a renaming of the libgnatcoll-gtk-dev package,
    but the fix does not affect the gnatcoll ABI and SO version.
  * Debhelper 11 and Standards-Version: 4.1.3.
    Move docs from /u/s/doc/*-doc to /u/s/doc/*-dev.
  * Build-Depends: drop obsolete version restriction on dpkg-dev.
  * python_single_statement_set_default_console.diff: fix serious typo.
  * Build-Depend: drop dpkg-dev obsolete version restriction.

 -- Nicolas Boulenguez <nicolas@debian.org>  Sat, 03 Mar 2018 14:28:59 +0100

libgnatcoll (17.0.2017-3) unstable; urgency=medium

  * Make testsuite more verbose. Closes: #872081.
  * Build-Depend latexmk for LaTeX sphinx-doc module. Closes: #872204.
  * Build-Depend: python3 version of sphinx-doc. Patch conf.py.
  * Standards-Version: 4.1.0.
  * Rebuild with libgpr 2017-5 (because of libxmlada-unicode).
    -dev version is already new in testing.

 -- Nicolas Boulenguez <nicolas@debian.org>  Tue, 26 Sep 2017 16:54:43 +0200

libgnatcoll (17.0.2017-2) unstable; urgency=medium

  * Upload to unstable.
  * The switch to gcc-7 requires a SO version bump for each library,
    except gnatcoll, g-python, g-xref, already new in unstable.
    The Break/Replace with previous -dev becomes implicit in unstable.
  * Disable parallel doc generation to prevent #869098.
  * Standards-Version: 4.0.1. Priority: optional.
  * Vcs-Mtn: new URI format.
  * clean objects forgotten by aclocal.m4.
  * Build-Depends: renamed texlive-plain-generic.

 -- Nicolas Boulenguez <nicolas@debian.org>  Thu, 10 Aug 2017 12:42:17 +0200

libgnatcoll (17.0.2017-1) experimental; urgency=medium

  * New upstream release, two new packages for the gnatcoll-xref library.
    No ALI/SO bump in experimental.
  * Build with gnat-7, which deals with SOURCE_DATE_EPOCH directly.
  * Debhelper 10, which deals with autoconf generated stuff.
  * Standards-Version: 4.0.0. Downgrade -doc to Suggests.
    HTTPS URL for copyright format. Handle DEB_BUILD_OPTIONS=nodoc.
  * Allow -doc package to satisfy multi-arch foreign dependencies.
  * PDFLatex now handles SOURCE_DATE_EPOCH without faketime.

 -- Nicolas Boulenguez <nicolas@debian.org>  Tue, 11 Jul 2017 01:44:33 +0200

libgnatcoll (16.1.0-1) experimental; urgency=medium

  * New upstream release. Update to ligtkada16.1.0-dev.
    Replace libgnatprj/vsn, dropped by GCC with libgpr from gprbuild.
    Bump ALI versions and conflict/break previous -dev per Ada policy.
    Bump SO versions for gnatcoll and gnatcoll-python.
  * Remove many patches to upstream Makefile and invoke gprbuild directly.
    Upstream prefers a reduced set of well tested configurations.
  * remove generate-sources-timestamp.diff, but regenerate the sources after
    the build and fail if they differ with the ones from the tarball.
  * python_single_statement_set_default_console.diff was waiting an ALI bump.
  * Select all hardening flags, gprbuild will override pie when needed.
  * C sources, ignored in ALI files, do not require predictible timestamps.
  * Simplify watch file thanks to version 4 format.

 -- Nicolas Boulenguez <nicolas@debian.org>  Sun, 21 Aug 2016 17:48:30 +0200

libgnatcoll (1.7gpl2015-2) unstable; urgency=medium

  * Revert to python2 as long as most startup scripts in the gnat-gps
    reverse dependency are incompatible with python3. Reopens: #760004.
  * Build-Depend: texlive-generic-extra for iftex.sty. Closes: #830334.
  * Ensure that ./configure and gprbuild use gnatgcc instead of gcc.

 -- Nicolas Boulenguez <nicolas@debian.org>  Fri, 29 Jul 2016 08:05:19 +0200

libgnatcoll (1.7gpl2015-1) unstable; urgency=medium

  * Build with gnat-6 and gprbuild >= 2015-2. Upload to unstable.
  * Switch from manual -dbg packages to automatic -dbgsym packages.
  * Enable all hardening options, but PIE because we build a shared library.
  * Move sphinx-common to Build-Depends-Indep.
  * Standards-Version: 3.9.8 (no changes).

 -- Nicolas Boulenguez <nicolas@debian.org>  Tue, 26 Apr 2016 10:06:03 +0200

libgnatcoll (1.7gpl2015-1~exp1) experimental; urgency=medium

  * New upstream release.
  * Build-Depend gnat-5, rename library and -dev packages per Ada policy.
  * watch: use Adacore uscan redirector.
  * copyright: since Files-Excluded is mandatory for minified javascript,
    also remove generated, copied or unused sources.
  * Transmit -a/-i options to dh-ada-library. Closes: #806628.
  * Select python3 instead of 2. Closes: #760004.
  * Set build flags from ./configure instead of gprbuild.
    Let gprbuild select the right gcc version to mix with Ada.
    Configure only once during arch & indep builds.
  * generate-sources-timestamp.diff: update timestamp only if contents
    changed (for reproducible builds).
  * Standards-Version: 3.9.7.

 -- Nicolas Boulenguez <nicolas@debian.org>  Sat, 27 Feb 2016 14:34:24 +0100

libgnatcoll (1.6gpl2014-9) unstable; urgency=medium

  * patches/explicit-source-dirs-in-projects.diff closes: #802862.

 -- Nicolas Boulenguez <nicolas@debian.org>  Sun, 25 Oct 2015 19:34:08 +0100

libgnatcoll (1.6gpl2014-8) unstable; urgency=medium

  * Mix gnat-4.9 with gcc-4.9 instead of default gcc-5. Closes: #777946.
  * (XS-)Testsuite: now generated by dpkg-source.

 -- Nicolas Boulenguez <nicolas@debian.org>  Tue, 08 Sep 2015 00:45:05 +0200

libgnatcoll (1.6gpl2014-7) unstable; urgency=medium

  * Touch generated sources for deterministic ALI files and tar headers.
    Freeze the clock for deterministic PDF timestamps.

 -- Nicolas Boulenguez <nicolas@debian.org>  Sun, 03 May 2015 17:31:48 +0200

libgnatcoll (1.6gpl2014-6) unstable; urgency=medium

  * Section: move source to misc and -dev to libdevel, as do ftpmasters.
  * Priority: raise run-time libraries and -bin to optional, to allow
    optional reverse dependencies (gnat-gps, asis-programs).

 -- Nicolas Boulenguez <nicolas@debian.org>  Mon, 06 Oct 2014 23:14:53 +0200

libgnatcoll (1.6gpl2014-5) unstable; urgency=medium

  * Drop PostGreSQL support, which depends on OpenSSL and is thus
    incompatible with the GPL. Closes: #763284.
  * Standards-Version: 3.9.6 without changes.

 -- Nicolas Boulenguez <nicolas@debian.org>  Sat, 04 Oct 2014 13:51:20 +0200

libgnatcoll (1.6gpl2014-4) unstable; urgency=medium

  * Link with pthread to circumvent compiler bug #760211.

 -- Nicolas Boulenguez <nicolas@debian.org>  Tue, 02 Sep 2014 00:01:38 +0200

libgnatcoll (1.6gpl2014-3) unstable; urgency=medium

  * Break/Replace gnat-gps << 5.3-4, previous provider of gnatinspect.
  * copyright: explain why some headers contain the GPL-2+.
  * Let libgnatcoll-dev Depends: libgnatgpr-dev (via ada:Depends).
  * Drop redundant Build-Depends-Indep: sphinx-common.

 -- Nicolas Boulenguez <nicolas@debian.org>  Sat, 30 Aug 2014 20:42:35 +0200

libgnatcoll (1.6gpl2014-2) unstable; urgency=medium

  * Build-Depend: sphinx-common. dh_sphinxdoc is needed during -arch rebuilds.

 -- Nicolas Boulenguez <nicolas@debian.org>  Thu, 14 Aug 2014 06:29:11 +0200

libgnatcoll (1.6gpl2014-1) unstable; urgency=medium

  * Initial packaging. Closes: #757309.
    GPL 2014 is between 1.6 and 1.7 commercial releases.
    Upstream archive is repackaged without minified javascript.

 -- Nicolas Boulenguez <nicolas@debian.org>  Sun, 10 Aug 2014 03:35:11 +0200