File: extconf.rb

package info (click to toggle)
libgpgme-ruby 1.0.1-2
  • links: PTS
  • area: main
  • in suites: lenny
  • size: 212 kB
  • ctags: 268
  • sloc: ansic: 1,800; ruby: 1,203; makefile: 3
file content (11 lines) | stat: -rw-r--r-- 232 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
require 'mkmf'

unless find_executable('gpgme-config')
  $stderr.puts("gpgme-config not found")
  exit(1)
end

$CFLAGS += ' ' << `gpgme-config --cflags`.chomp
$libs += ' ' << `gpgme-config --libs`.chomp

create_makefile ('gpgme_n')