File: changelog

package info (click to toggle)
libhibernate-validator-java 4.3.4-1
  • links: PTS, VCS
  • area: main
  • in suites: buster, sid
  • size: 6,692 kB
  • sloc: java: 34,120; xml: 6,060; sh: 90; makefile: 6
file content (231 lines) | stat: -rw-r--r-- 8,396 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
libhibernate-validator-java (4.3.4-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
    - Removed the CVE-2017-7536 patch (fixed upstream)
  * Fixed the build failure with Java 11 (Closes: #911138)

 -- Emmanuel Bourg <ebourg@apache.org>  Wed, 17 Oct 2018 17:16:01 +0200

libhibernate-validator-java (4.3.3-5) unstable; urgency=medium

  * Team upload.
  * Use the maven-jaxb2-plugin instead of invoking xjc directly to fix the build
    failure with Java 11 (Closes: #905359)
  * Added the missing build dependency on libeasymock-java
  * Standards-Version updated to 4.2.1
  * Switch to debhelper level 11
  * Use salsa.debian.org Vcs-* URLs

 -- Emmanuel Bourg <ebourg@apache.org>  Wed, 19 Sep 2018 10:39:24 +0200

libhibernate-validator-java (4.3.3-4) unstable; urgency=high

  * Team upload.
  * Fix CVE-2017-7536.
    Thanks to Salvatore Bonaccorso for the report. (Closes: #885577)
  * Switch to compat level 11.
  * Declare compliance with Debian Policy 4.1.3.
  * Rename README.Debian-source to README.source.
  * Remove unused maven.cleanIgnoreRules and maven.publishedRules.

 -- Markus Koschany <apo@debian.org>  Thu, 11 Jan 2018 14:43:58 +0100

libhibernate-validator-java (4.3.3-3) unstable; urgency=medium

  * Team upload.
  * Added the missing build dependency on libjsoup-java (Closes: #882317)
  * Removed the dependency on glassfish-javaee and libgeronimo-jpa-2.0-spec-java
  * Standards-Version updated to 4.1.1

 -- Emmanuel Bourg <ebourg@apache.org>  Thu, 30 Nov 2017 02:18:10 +0100

libhibernate-validator-java (4.3.3-2) unstable; urgency=medium

  * Team upload.
  * Add jboss-logging-tools.patch and provide the missing source files
    manually.
    The packaging was incomplete because generated classes were not created at
    build time. Apparently this is caused by a wrong or outdated invocation of
    the jboss-logging-processor in pom.xml. This package still requires an
    older version of jboss-logging-tools which behaves differently. This patch
    works around the issue by applying the sources manually. They were created
    with version 1.0.1.Final of jboss-logging-tools and then Log_$logger.java
    was patched to fix missing methods. For more information see #874579.
    (Closes: #874579)
  * Declare compliance with Debian Policy 4.1.0.

 -- Markus Koschany <apo@debian.org>  Tue, 19 Sep 2017 09:12:55 +0200

libhibernate-validator-java (4.3.3-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
  * Switch to debhelper level 10

 -- Emmanuel Bourg <ebourg@apache.org>  Mon, 19 Dec 2016 09:50:16 +0100

libhibernate-validator-java (4.3.2-3) unstable; urgency=medium

  * Team upload.
  * Depend on groovy instead of groovy2
  * Standards-Version updated to 3.9.8 (no changes)

 -- Emmanuel Bourg <ebourg@apache.org>  Fri, 13 May 2016 15:20:52 +0200

libhibernate-validator-java (4.3.2-2) unstable; urgency=medium

  * Team upload.
  * Use the dependencies generated by maven-debian-helper
  * debian/watch: Track only the final releases

 -- Emmanuel Bourg <ebourg@apache.org>  Fri, 01 Apr 2016 15:38:10 +0200

libhibernate-validator-java (4.3.2-1) unstable; urgency=medium

  * Team upload.
  * New upstream release (Closes: #737436)
    - New build dependencies on libmaven-processor-plugin-java and groovy2
    - New dependency on libjboss-logging-tools-java
    - Removed jaxb-binding-fixes.patch (fixed upstream)
    - Updated the build for the new project layout
    - Worked around a maven-repo-helper bug with plugin dependencies
  * Build with the DH sequencer instead of CDBS
  * Added the missing Maven rule for log4j
  * Standards-Version updated to 3.9.7 (no changes)
  * Use a secure Vcs-Git URL
  * Converted debian/copyright to the Copyright Format 1.0

 -- Emmanuel Bourg <ebourg@apache.org>  Fri, 01 Apr 2016 00:15:58 +0200

libhibernate-validator-java (4.2.1-2) unstable; urgency=medium

  * Team upload.
  * Upload to unstable

 -- Emmanuel Bourg <ebourg@apache.org>  Mon, 27 Apr 2015 21:28:53 +0200

libhibernate-validator-java (4.2.1-1) experimental; urgency=medium

  * Team upload.
  * New upstream release
    - Fixes CVE-2014-3558 (Closes: #762690)
    - Refreshed the patches
    - Added libjaxb-java, libgeronimo-jpa-2.0-spec-java, libjoda-time-java,
      libjavassist-java and libmaven-bundle-plugin-java to the build deps
  * debian/control:
    - Use canonical URLs for the Vcs-* fields
    - Standards-Version updated to 3.9.6 (no changes)
  * debian/watch: Updated to watch the release tags on Github
  * Removed debian/orig-tar.* and use the Github archive as is
  * Switch to debhelper level 9

 -- Emmanuel Bourg <ebourg@apache.org>  Wed, 19 Nov 2014 12:37:40 +0100

libhibernate-validator-java (4.0.2.GA-8) unstable; urgency=low

  * Team upload.
  * add patch to remove jdk15 classifier from testng dependency from pom.xml
  * fix testng version handling in d/maven.rules

  [ Sylvestre Ledru ]
  * Standards-Version updated to 3.9.4

 -- Eugene Zhukov <jevgeni.zh@gmail.com>  Fri, 04 Oct 2013 05:58:30 +0000

libhibernate-validator-java (4.0.2.GA-7) unstable; urgency=low

  * Team upload.
  * JAXB is now included in OpenJDK, so enabled previously disabled sources
  * Calling xjc in rules rather than using maven jaxb plugin as it is not
    packaged
  * Modified JPATraversableResolver.java to always return null as the
    method it uses to check its state does not exist in the version of the api
    provided in Debian. (It was previously disabled completely)

 -- Brian Thomason <brian.thomason@eucalyptus.com>  Fri, 25 May 2012 17:37:00 +0000

libhibernate-validator-java (4.0.2.GA-6ubuntu1) precise; urgency=low

  * Fix missing jar file from /usr/share/java.

 -- Onkar Shinde <onkarshinde@ubuntu.com>  Wed, 18 Apr 2012 22:56:21 +0530

libhibernate-validator-java (4.0.2.GA-6) unstable; urgency=low

  * Team upload.
  * Add missing Build-Depends on testng. (Closes: #655774).

 -- Miguel Landaeta <miguel@miguel.cc>  Sat, 14 Jan 2012 17:26:03 -0430

libhibernate-validator-java (4.0.2.GA-5) unstable; urgency=low

  * Team upload.
  * Add Build-Depends on libmaven-reporting-impl-java. (Closes: #644341).
  * Disable maven-surefire-report-plugin usage during build time.
  * Fix clean target to allow two builds in a row.

 -- Miguel Landaeta <miguel@miguel.cc>  Wed, 12 Oct 2011 13:49:57 -0430

libhibernate-validator-java (4.0.2.GA-4) unstable; urgency=low

  * Team upload.
  * d/patches/pom_modules.diff: Disable some modules from pom.xml
    since --ignore doesn't seems to work (Closes: #615155).
  * Bump Standards-Version to 3.9.2 (no changes needed).

 -- Damien Raude-Morvan <drazzib@debian.org>  Mon, 02 May 2011 00:18:52 +0200

libhibernate-validator-java (4.0.2.GA-3) unstable; urgency=low

  * Upload to unstable.
  * Add maven-assembly-plugin to maven.ignoreRules.

 -- Torsten Werner <twerner@debian.org>  Tue, 03 Aug 2010 21:50:25 +0200

libhibernate-validator-java (4.0.2.GA-2) experimental; urgency=low

  * Use --ignore to ignore modules that cannot be built yet.

 -- Torsten Werner <twerner@debian.org>  Tue, 22 Jun 2010 20:32:31 +0200

libhibernate-validator-java (4.0.2.GA-1) experimental; urgency=low

  * New upstream release
  * Create orig tarball from SVN tag.
  * Switch to git for maintaining the package.
  * Build package with Maven instead of Ant.
  * Change Section: java.
  * Add missing Depends: ${misc:Depends}.
  * Update Standards-Version: 3.8.4.
  * Update (Build-)Depends.
  * Update licenses in debian/copyright (now Apache-2.0).

 -- Torsten Werner <twerner@debian.org>  Mon, 14 Jun 2010 22:37:27 +0200

libhibernate-validator-java (3.1.0.GA+dak1-1) unstable; urgency=low

  * Move package to main.

 -- Torsten Werner <twerner@debian.org>  Tue, 18 Nov 2008 20:05:17 +0100

libhibernate-validator-java (3.1.0.GA-1) unstable; urgency=low

  * New upstream release
  * Bump up Standards-Version: 3.8.0 (no changes).

 -- Torsten Werner <twerner@debian.org>  Sat, 08 Nov 2008 21:58:40 +0100

libhibernate-validator-java (3.1.0.CR1-1) unstable; urgency=low

  * New upstream release
  * Add libslf4j-java to Build-Depends-Indep
  * Bump Standards-Version to 3.7.3

 -- Varun Hiremath <varun@debian.org>  Mon, 02 Jun 2008 01:24:04 +0530

libhibernate-validator-java (3.0.0.GA-1) unstable; urgency=low

  * Initial Release (closes: #451489).

 -- Torsten Werner <twerner@debian.org>  Sun, 11 Nov 2007 21:12:33 +0100