File: changelog

package info (click to toggle)
libhtml-html5-writer-perl 0.201-2
  • links: PTS, VCS
  • area: main
  • in suites: buster
  • size: 356 kB
  • ctags: 268
  • sloc: perl: 3,777; makefile: 8; sh: 4
file content (58 lines) | stat: -rw-r--r-- 2,114 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
libhtml-html5-writer-perl (0.201-2) unstable; urgency=medium

  [ Salvatore Bonaccorso ]
  * Modernize Vcs-* fields:
    + Use anonscm hostname for Vcs-Git field.

  [ Jonas Smedegaard ]
  * Modernize Vcs-* fields:
    + Use anonscm hostname for Vcs-Browser field.
    + Use https protocol.
    + Use git (not gitweb) in path.
  * Declare compliance with Debian Policy 4.1.0.
  * Update git-buildpackage config: Filter any .git* files.
  * Update watch file:
    + Use format version 4.
    + Watch MetaCPAN URL.
    + Mention gbp --uscan in usage comment.
    + Stop handle prereleases.
    + Tighten version regex.
  * Modernize cdbs:
    + Drop upstream-tarball hints: Use gbp import-orig --uscan.
    + Do copyright-check in maintainer script (not during build).
      Relax to build-depend unversioned on cdbs.
      Stop build-depend on devscripts.
  * Use debhelper compatibility level 9 (not 7).
  * Update copyright info:
    + Use https protocol in file format URL.
    + Use License-Grant and License-Reference fields.
      Thanks to Ben Finney.
    + Extend coverage for myself. Relicense packaging as GPL-3+.
  * Add lintian overrides regarding License-Reference.
  * Remove debian/source/local-options: abort-on-upstream-changes and
    unapply-patches are default in dpkg-source since 1.16.1.
  * Advertise DEP-3 format in patch headers.
  * Fix stop recommend libhtml-html5-parser-perl.

 -- Jonas Smedegaard <dr@jones.dk>  Fri, 01 Sep 2017 01:45:19 +0200

libhtml-html5-writer-perl (0.201-1) unstable; urgency=low

  * New upstream release.

  * Update copyright file:
    + Bump format to 1.0.
    + Improve Files sections for convenience copies of external Perl
      modules.
    + Extend coverage of main licensing.
  * Add patch 1001 to avoid auto-installing dependencies during build.
  * Stop (Build-)depending on libcommon-sense-perl.

 -- Jonas Smedegaard <dr@jones.dk>  Thu, 14 Jun 2012 19:26:48 +0200

libhtml-html5-writer-perl (0.104-1) unstable; urgency=low

  * Initial packaging release.
    Closes: bug#663972.

 -- Jonas Smedegaard <dr@jones.dk>  Wed, 09 May 2012 02:15:10 +0200