File: changelog

package info (click to toggle)
libime 1.0.4-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye
  • size: 189,696 kB
  • sloc: cpp: 25,967; python: 58; makefile: 7
file content (154 lines) | stat: -rw-r--r-- 4,578 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
libime (1.0.4-1) unstable; urgency=medium

  * Team upload.
  * New upstream release

 -- Shengjing Zhu <zhsj@debian.org>  Fri, 19 Feb 2021 15:14:03 +0800

libime (1.0.3-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
  * Update Standards-Version to 4.5.1 (no changes)
  * Add libboost-filesystem-dev to Build-Depends

 -- Shengjing Zhu <zhsj@debian.org>  Sat, 16 Jan 2021 01:25:54 +0800

libime (1.0.2-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
  * Fix uscan watch file syntax
  * Refresh patches

 -- Shengjing Zhu <zhsj@debian.org>  Sat, 05 Dec 2020 18:21:19 +0800

libime (1.0.1-3) unstable; urgency=medium

  * Team upload.
  * libime-data-language-model should Breaks+Replaces libimecore0
    Closes: #974044

 -- Shengjing Zhu <zhsj@debian.org>  Mon, 09 Nov 2020 22:36:57 +0800

libime (1.0.1-2) unstable; urgency=medium

  * Team upload.
  * Add libime-data-language-model package

 -- Shengjing Zhu <zhsj@debian.org>  Sat, 07 Nov 2020 22:26:34 +0800

libime (1.0.1-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
  * Bump libfcitx5utils-dev to 5.0.1
  * Fix library install patch for new version

 -- Shengjing Zhu <zhsj@debian.org>  Sat, 07 Nov 2020 00:48:37 +0800

libime (0.0~git20201029.22106dc-3) unstable; urgency=medium

  * Team upload.
  * Disable testtrie on mipsx again, still failing in new version.

 -- Shengjing Zhu <zhsj@debian.org>  Sun, 01 Nov 2020 12:57:04 +0800

libime (0.0~git20201029.22106dc-1) unstable; urgency=medium

  * Team upload.
  * New upstream snapshot.
  * Use MUT for data and kenlm source.
  * Do not disable testtrie on mips* and hppa. The problem
    should be fixed with refreshed kenlm code.
  * Bump libfcitx5utils-dev to 0.0~git20201030

 -- Shengjing Zhu <zhsj@debian.org>  Sat, 31 Oct 2020 22:51:05 +0800

libime (0.0~git20200823.dff3ea6-2) unstable; urgency=medium

  * Team upload.
  * Disable testtrie on mipsx and hppa

 -- Shengjing Zhu <zhsj@debian.org>  Thu, 27 Aug 2020 02:38:52 +0800

libime (0.0~git20200823.dff3ea6-1) unstable; urgency=medium

  * Team upload.
  * New upstream snapshot.
  * as-needed LDFLAGS is not needed since bullseye
  * Changes architecture from linux-any to any
  * Refresh patches
  * Update bundled dict.utf8
  * Tests on i386 are fixed

 -- Shengjing Zhu <zhsj@debian.org>  Wed, 26 Aug 2020 11:56:39 +0800

libime (0.0~git20200626.2c85668-1) unstable; urgency=medium

  * Team upload.
  * New upstream snapshot.
  * Bump debhelper-compat to 13 and clean up d/rules
  * Update dict.utf8 to 20200613
  * Refresh patches
  * Add libboost-iostreams-dev to Build-Depends
  * Bump libfcitx5utils-dev to 0.0~git20200626

 -- Shengjing Zhu <zhsj@debian.org>  Thu, 02 Jul 2020 11:44:03 +0800

libime (0.0~git20200318.a78efdf-1) unstable; urgency=medium

  * Team upload.
  * New upstream snapshot.
  * Ignore failing test on i386 for now
  * Bump fcitx version to 0.0~git20200323

 -- Shengjing Zhu <zhsj@debian.org>  Tue, 24 Mar 2020 03:38:39 +0800

libime (0.0~git20200310.fdce632-1) unstable; urgency=medium

  * Team upload.
  * New upstream snapshot.
  * Stop repacking upstream tarball.
    Move extra sources to debian directory.
  * Use cmake config from system libdouble-conversion-dev.
  * Bump libfcitx5utils-dev to 0.0~git20200311.

 -- Shengjing Zhu <zhsj@debian.org>  Fri, 13 Mar 2020 00:19:32 +0800

libime (0.0~git20191230.5b6e890+ds2-1) unstable; urgency=medium

  * ds: Let src:libime to provide required dictionaries.
  * debian/control:
    - Drop build-dependency on fcitx5-data.
    + Bump Standards-Version to 4.5.0.
    + Mark architecture-dependent packages as linux-any.

 -- Boyuan Yang <byang@debian.org>  Wed, 05 Feb 2020 16:37:00 -0500

libime (0.0~git20191230.5b6e890+ds1-2) unstable; urgency=high

  * debian/control: Let the core library depends on libime-data
    data package. This is needed by fcitx5-chinese-addons.

 -- Boyuan Yang <byang@debian.org>  Sun, 19 Jan 2020 17:33:53 -0500

libime (0.0~git20191230.5b6e890+ds1-1) unstable; urgency=medium

  * New upstream snapshot.

 -- Boyuan Yang <byang@debian.org>  Thu, 02 Jan 2020 20:14:32 -0800

libime (0.0~git20191129.48c56a4+ds1-1) unstable; urgency=high

  * New upstream snapshot.
  * Source-only upload to allow testing migration.
  * debian/control: Mark dev packages as M-A: same.

 -- Boyuan Yang <byang@debian.org>  Fri, 27 Dec 2019 20:50:22 -0800

libime (0.0~git20191103.442e091+ds2-1) unstable; urgency=medium

  * Initial release. (Closes: #945850)

 -- Boyuan Yang <byang@debian.org>  Fri, 29 Nov 2019 15:58:21 -0500