File: changelog

package info (click to toggle)
libircclient 1.9-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid, stretch
  • size: 1,752 kB
  • ctags: 1,078
  • sloc: ansic: 3,132; objc: 790; cpp: 349; makefile: 164; sh: 47; python: 36
file content (95 lines) | stat: -rw-r--r-- 3,352 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
libircclient (1.9-1) unstable; urgency=medium

  * New upstream version 1.9
  * Added libircclient.triggers with ldconfig
  * Refreshed patches for the new codebase
  * d/control:
   - Changed maintainer's email to d.o
   - Bump standards to 3.9.8, no changes needed
   - Changed vcs to secure, git browser to cgit
  * d/copyright:
    - redefined BSD-3-clause
    - added year 2016
    - changed maintainer's email to d.o
  * Added bindnow hardening

 -- Dariusz Dwornikowski <darek@debian.org>  Tue, 20 Sep 2016 18:25:56 +0200

libircclient (1.8-2) unstable; urgency=medium

  * patch/fix-ipv6-socaddr.patch added (Closes: #762027)
    - fixes segfault when connecting to an IPv6 address

 -- Dariusz Dwornikowski <dariusz.dwornikowski@cs.put.poznan.pl>  Thu, 18 Sep 2014 15:29:18 +0200

libircclient (1.8-1) unstable; urgency=medium

  * New maintainer (Closes: #674882)
  * Imported Upstream version 1.8
  * Removed -dfsg, rfc file violating DFSG no longer in source
  * Bump standards to 3.9.5, no changes needed
  * Build-Dep in d/control changed to debhelper>=9
  * Added myself to d/copyright
  * d/copyright updated for Authors of cocoa/
  * d/compat changed to 9
  * Deleted 00_fix_missing_headers patch, not needed
  * Added dh-autoreconf to Build-Deps
  * Switched to multiarch (Thanks Andreas Rönnquist)
  * patch/proper-lib-building.patch added
    - removed old build system
    - uses autoreconf and libtool
    - still allows using upstream's --enable system
    - builds libircclient with IPv6 support
  * removed README.source file, not needed
  * README.Debian added with URL pointing to upstream's doc

 -- Dariusz Dwornikowski <dariusz.dwornikowski@cs.put.poznan.pl>  Fri, 15 Aug 2014 18:48:38 +0200

libircclient (1.6+dfsg1-1) UNRELEASED; urgency=medium

  [ Andreas Rönnquist ]
  * Imported Upstream version 1.6+dfsg1
  * Update Standards Version to 3.9.3 (No changes)
  * Update Vcs-* fields
  * Reset executable flag of bootstrap after running it
  * Convert package to quilt format
  * Fix debian-rules-missing-recommended-target
  * Add hardening flags to build system
  * Fix Multiarch support
  * Fix binary-control-field-duplicates-source field 'Section'
  * Fix duplicate short description lintian warning
  * Fix quilt-patch-missing-description lintian warning
  * Add symbols file for libircclient1
  * Update homepage field
  * Drop installing unneeded .la file
  * Update Copyright file
  * Fix closing bug lacking hash sign

 -- Dariusz Dwornikowski <dariusz.dwornikowski@cs.put.poznan.pl>  Fri, 15 Aug 2014 18:47:45 +0200

libircclient (1.3+dfsg1-3) unstable; urgency=low

  * Add quilt patch system.
  * debian/patches:
    - 00_fix_missing_headers.diff - Add missing includes. Closes: #534898.

 -- Bradley Smith <bradsmith@debian.org>  Sun, 28 Jun 2009 13:58:40 +0100

libircclient (1.3+dfsg1-2) unstable; urgency=low

  * Add missing header file. Closes: #534798.
  * Update Standards-Version to 3.8.2. (No changes).

 -- Bradley Smith <bradsmith@debian.org>  Sat, 27 Jun 2009 12:22:50 +0100

libircclient (1.3+dfsg1-1) unstable; urgency=low

  * New upstream release.

 -- Bradley Smith <bradsmith@debian.org>  Mon, 05 Jan 2009 22:46:15 +0000

libircclient (1.2+dfsg1-1) unstable; urgency=low

  * Initial release. Closes: #498179.

 -- Bradley Smith <bradsmith@debian.org>  Sun, 26 Oct 2008 12:34:32 +0000