File: changelog

package info (click to toggle)
libjs-qunit 1.23.1~dfsg-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 708 kB
  • sloc: javascript: 7,096; makefile: 31; sh: 13
file content (95 lines) | stat: -rw-r--r-- 3,083 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
libjs-qunit (1.23.1~dfsg-1) unstable; urgency=medium

  [ upstream ]
  * new release(s)

  [ Jonas Smedegaard ]
  * simplify rules;
    stop build-depend on dh-buildinfo cdbs
  * add source script copyright-check;
    stop build-depend on devscripts
  * generate html and plaintext documentation;
    build-depend on pandoc
  * declare compliance with Debian Policy 3.5.1
  * set Rules-Requires-Root: no
  * use debhelper compatibility level 13 (not 9);
    build-depend on debhelper-compat (not debhelper)
  * copyright:
    + use https protocol in format identifier
    + use License-Grant and License-Reference fields;
      add lintian override (see bug#786450)
    + update coverage
    + list only canonical Github URL as Source URL
    + repackage upstream source, removing pre-generated code
  * override lintian
    for more License is in License-Reference field warnings
    (see bug#786450)
  * update watch file:
    + use file format 4 (not 3)
    + simplify regular expressions
    + use substitution strings
    + set dversionmangle=auto
    + add usage comment
    + track NPM registry
      (newest 1.x tags don't appear in regular Github matching)
    + limit to 1.x releases
      (node module name got renamed since 2.4.1)
  * fix generate code during build
    (not use upstream pre-generated code),
    and check minimal testsuite;
    build-depend on
    grunt node-grunt-contrib-concat node-load-grunt-tasks
  * update git-buildpackage settings:
    + use DEP-14 git branch names
    + avoid deprecated section name
  * add patch 2001 to avoid prviacy leaks in documentation
  * update Vcs-* fields: maintenance moved to salsa
  * compress for browser use;
    build-depend on brotli pigz uglifyjs

 -- Jonas Smedegaard <dr@jones.dk>  Tue, 01 Dec 2020 16:56:07 +0100

libjs-qunit (1.22.0-1) unstable; urgency=low

  * New upstream release.
  * Install CSS file as well (closes: #748886).
  * Generalize watch file.
  * Update Standards-Version to 3.9.7 and debhelper level to 9 .

 -- Laszlo Boszormenyi (GCS) <gcs@debian.org>  Fri, 04 Mar 2016 12:42:42 +0000

libjs-qunit (1.14.0-1) unstable; urgency=low

  * New upstream release with addons removed for now.

 -- Laszlo Boszormenyi (GCS) <gcs@debian.org>  Fri, 14 Feb 2014 12:35:11 +0000

libjs-qunit (1.13.0-1) unstable; urgency=low

  * New upstream release.
  * Update Standards-Version to 3.9.5 .
  * Update watch file.
  * Add mysqlf to Uploaders.

 -- Laszlo Boszormenyi (GCS) <gcs@debian.org>  Wed, 08 Jan 2014 09:23:07 +0000

libjs-qunit (1.12.0-1) unstable; urgency=low

  [ upstream ]
  * New release.

  [ Jonas Smedegaard ]
  * Update README.source to emphasize control.in file as *not* a
    show-stopper for contributions.
  * Add git URL as alternate source.
  * Stop tracking md5sum of upstream tarball.
  * Extend copyright coverage for main upstream author.

 -- Jonas Smedegaard <dr@jones.dk>  Tue, 23 Jul 2013 02:49:24 +0200

libjs-qunit (1.11.0-1) unstable; urgency=low

  * Initial release.
    Closes: Bug#695662.

 -- Jonas Smedegaard <dr@jones.dk>  Thu, 14 Mar 2013 20:05:31 +0100