1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217
|
Source: libjson-rpc-cpp
Priority: extra
Maintainer: Peter Spiess-Knafl <dev@spiessknafl.at>
Build-Depends: catch,
cmake,
debhelper (>= 9),
libargtable2-dev,
libcurl4-openssl-dev | libcurl4-nss-dev,
libjsoncpp-dev,
libmicrohttpd-dev (>= 0.9.71)
Standards-Version: 3.9.8.0
Section: libs
Homepage: https://github.com/cinemast/libjson-rpc-cpp
Vcs-Git: https://anonscm.debian.org/git/collab-maint/libjson-rpc-cpp.git
Vcs-Browser: https://anonscm.debian.org/cgit/collab-maint/libjson-rpc-cpp.git
Package: libjsonrpccpp-common0
Architecture: any
Pre-Depends: ${misc:Pre-Depends}
Depends: ${misc:Depends}, ${shlibs:Depends}
Suggests: libjsonrpccpp-client0 (= ${binary:Version}),
libjsonrpccpp-server0 (= ${binary:Version}),
libjsonrpccpp-tools (= ${binary:Version})
Description: common functionality for server and client library
This library provides common classes for the libjson-rpc-cpp framework like
.
* Exceptions
* Error-Codes
* Specification Parsers and Writers
* Procedure parameter validation
.
This package usually only makes sense with libjsonrpccpp-client0 and/or
libjsonrpccpp-server0.
Package: libjsonrpccpp-common0-dbg
Architecture: any
Depends: libjsonrpccpp-common0 (= ${binary:Version}),
${misc:Depends},
${shlibs:Depends}
Section: debug
Description: debugging symbols for libjsonrpccpp-common0
This library provides common classes for the libjson-rpc-cpp framework like
.
* Exceptions
* Error-Codes
* Specification Parsers and Writers
* Procedure parameter validation
.
This package usually only makes sense with libjsonrpccpp-client0 and/or
libjsonrpccpp-server0.
.
This package contains the debugging symbols for libjsonrpccpp-common0.
Package: libjsonrpccpp-client0
Architecture: any
Pre-Depends: ${misc:Pre-Depends}
Depends: ${misc:Depends}, ${shlibs:Depends}
Suggests: libjsonrpccpp-tools
Description: library implementing json-rpc C++ clients
This library provides classes to easily implement JSON-RPC C++ clients.
It comes with a built in HTTP-Client connector (based on libcurl)
for easy data exchange. It is fully JSON-RPC 2.0 and JSON-RPC
1.0 compatible, including:
.
* Type checking
* Error response handling
* Batch procedure calls
* JSON-RPC Method invocation
* JSON-RPC Notification invocation
* Interface for additional Client-Connectors beside HTTP
* Positional and named parameters
Package: libjsonrpccpp-client0-dbg
Architecture: any
Depends: libjsonrpccpp-client0 (= ${binary:Version}),
libjsonrpccpp-common0-dbg (= ${binary:Version}),
${misc:Depends},
${shlibs:Depends}
Section: debug
Description: debugging symbols for libjsonrpccpp-client0
This library provides classes to easily implement JSON-RPC C++ clients.
It comes with a built in HTTP-Client connector (based on libcurl)
for easy data exchange. It is fully JSON-RPC 2.0 and JSON-RPC 1.0 compatible,
including:
.
* Type checking
* Error response handling
* Batch procedure calls
* JSON-RPC Method invocation
* JSON-RPC Notification invocation
* Simple Interface for implementing additional Client-Connectors beside HTTP
* Positional and named parameters
.
This package contains the debugging symbols for libjsonrpccpp-client0.
Package: libjsonrpccpp-server0
Architecture: any
Pre-Depends: ${misc:Pre-Depends}
Depends: ${misc:Depends}, ${shlibs:Depends}
Suggests: libjsonrpccpp-tools
Description: library implementing json-rpc C++ servers
This library provides classes to easily implement JSON-RPC C++ Server
applications. It comes with a built in HTTP-Server connector
(based on libmicrohttpd) for easy data exchange. It is fully JSON-RPC 2.0 and
JSON-RPC 1.0 compatible, including:
.
* Type checking
* Malformed request handling
* Handling batch procedure calls
* JSON-RPC Method invocation
* JSON-RPC Notification invocation
* Simple Interface for implementing additional Server-Connectors beside HTTP
* Positional and named parameters
Package: libjsonrpccpp-server0-dbg
Architecture: any
Depends: libjsonrpccpp-common0-dbg (= ${binary:Version}),
libjsonrpccpp-server0 (= ${binary:Version}),
${misc:Depends},
${shlibs:Depends}
Section: debug
Description: debugging symbols for libjsonrpccpp-server0
This library provides classes to easily implement JSON-RPC C++ Server
applications. It comes with a built in HTTP-Server connector
(based on libmicrohttpd) for easy data exchange. It is fully JSON-RPC 2.0 and
JSON-RPC 1.0 compatible, including:
.
* Type checking
* Malformed request handling
* Handling batch procedure calls
* JSON-RPC Method invocation
* JSON-RPC Notification invocation
* Simple Interface for implementing additional Server-Connectors beside HTTP
* Positional and named parameters
.
This package contains the debugging symbols for libjsonrpccpp-server0.
Package: libjsonrpccpp-stub0
Architecture: any
Section: libdevel
Pre-Depends: ${misc:Pre-Depends}
Depends: libjsonrpccpp-common0, ${misc:Depends}, ${shlibs:Depends}
Suggests: libjsonrpccpp-tools
Description: library for stub generation of libjsonrpccpp based applications
This package provides the stub generator library for the libjson-rpc-cpp
framework. It can automatically generate full functioning C++ and JavaScript
JSON-RPC Client classes, which are ready to use.
.
For JSON-RPC Server applications, this library can generate an abstract C++
class which just has to be sub classed and implement all pure virtual methods.
To make this possible, a interface description file (in the JSON format)
is required, which lists all available methods with corresponding parameters
and types.
Package: libjsonrpccpp-stub0-dbg
Architecture: any
Section: debug
Depends: libjsonrpccpp-common0-dbg (= ${binary:Version}),
libjsonrpccpp-stub0 (= ${binary:Version}),
${misc:Depends},
${shlibs:Depends}
Suggests: libjsonrpccpp-tools
Description: debugging symbols for libjsonrpccpp-stub0
This package provides the stub generator library for the libjson-rpc-cpp
framework. It can automatically generate full functioning C++ and JavaScript
JSON-RPC Client classes, which are ready to use.
.
For JSON-RPC Server applications, this library can generate an abstract C++
class which just has to be sub classed and implement all pure virtual methods.
To make this possible, a interface description file (in the JSON format)
is required, which lists all available methods with corresponding parameters
and types.
.
This package contains the debugging symbols for libjsonrpccpp-common0.
Package: libjsonrpccpp-tools
Architecture: any
Section: libdevel
Depends: libjsonrpccpp-stub0 (= ${binary:Version}),
${misc:Depends},
${shlibs:Depends}
Suggests: libjsonrpccpp-dev
Description: stub generator for libjsonrpccpp based applications
This package provides the stub generator for the libjson-rpc-cpp framework.
It can automatically generate full functioning C++ and JavaScript JSON-RPC
Client classes, which are ready to use.
.
For JSON-RPC Server applications, this tool can generate an abstract C++ class
which just has to be sub classed and implement all pure virtual methods. To
make this possible, a simple interface description file (in the JSON format)
is required, which lists all available methods with corresponding parameters
and types.
Package: libjsonrpccpp-dev
Section: libdevel
Architecture: any
Depends: libcurl4-openssl-dev | libcurl4-nss-dev,
libjsoncpp-dev,
libjsonrpccpp-client0 (= ${binary:Version}),
libjsonrpccpp-common0 (= ${binary:Version}),
libjsonrpccpp-server0 (= ${binary:Version}),
libjsonrpccpp-stub0 (= ${binary:Version}),
libmicrohttpd-dev (>= 0.9.71),
${misc:Depends}
Description: development files for JSON-RPC C++ framework
This package provides all required developer resources like header-files
and statically linked libraries of the libjson-rpc-cpp framework.
.
Features of this framework include:
.
* Type checking
* Malformed request handling
* Handling batch procedure calls
* JSON-RPC Method invocation
* JSON-RPC Notification invocation
* Simple Interface for implementing additional Server-Connectors beside HTTP
* Positional and named parameters
|