File: control

package info (click to toggle)
liblist-moreutils-perl 0.416-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid, stretch
  • size: 724 kB
  • ctags: 1,079
  • sloc: perl: 4,726; ansic: 227; makefile: 11
file content (36 lines) | stat: -rw-r--r-- 1,689 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
Source: liblist-moreutils-perl
Maintainer: Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Uploaders: Krzysztof Krzyzaniak (eloy) <eloy@debian.org>,
           Damyan Ivanov <dmn@debian.org>,
           Ansgar Burchardt <ansgar@debian.org>,
           gregor herrmann <gregoa@debian.org>,
           Alessandro Ghedini <ghedo@debian.org>
Section: perl
Testsuite: autopkgtest-pkg-perl
Priority: optional
Build-Depends: debhelper (>= 9.20120312~),
               libexporter-tiny-perl,
# Dependency on perl 5.22.2-2~ which contains the fix for CVE-2016-6185
               perl (>= 5.22.2-2~)
Standards-Version: 3.9.8
Vcs-Browser: https://anonscm.debian.org/cgit/pkg-perl/packages/liblist-moreutils-perl.git
Vcs-Git: https://anonscm.debian.org/git/pkg-perl/packages/liblist-moreutils-perl.git
Homepage: https://metacpan.org/release/List-MoreUtils

Package: liblist-moreutils-perl
Architecture: any
Depends: ${misc:Depends},
         ${perl:Depends},
         ${shlibs:Depends},
         libexporter-tiny-perl,
# Dependency on perl 5.22.2-2~ which contains the fix for CVE-2016-6185
         perl (>= 5.22.2-2~)
Description: Perl module with additional list functions not found in List::Util
 List::MoreUtils provides some trivial but commonly needed functionality on
 lists which is not going to go into List::Util.
 .
 All of the functions are implementable in only a couple of lines of Perl
 code. Using the functions from this module however should give slightly better
 performance as everything is implemented in C. The pure-Perl implementation of
 these functions only serves as a fallback in case the C portions of this module
 could not be compiled on this machine.