1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37
|
DHFLAGS=--parallel
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
%:
dh $@ $(DHFLAGS) --with gir --without autoreconf
override_dh_missing:
dh_missing --fail-missing
override_dh_install:
rm -f debian/tmp/usr/lib/*/*.la
dh_install
override_dh_auto_configure:
NOCONFIGURE=1 ./autogen.sh
dh_auto_configure $(DHFLAGS) -- \
--disable-silent-rules \
--disable-static \
--enable-introspection
override_dh_makeshlibs:
dh_makeshlibs -V 'libmatekbd4 (>= 1.8.0)'
override_dh_strip:
dh_strip -plibmatekbd4 --dbgsym-migration='libmatekbd4-dbg (<< 1.14.1-1~)'
override_dh_auto_clean:
dh_auto_clean
get-orig-source:
uscan --noconf --force-download --rename --download-current-version --destdir=..
|