File: changelog

package info (click to toggle)
libmath-gmp-perl 2.19-1
  • links: PTS, VCS
  • area: main
  • in suites: buster
  • size: 248 kB
  • sloc: perl: 700; makefile: 3
file content (203 lines) | stat: -rw-r--r-- 7,000 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
libmath-gmp-perl (2.19-1) unstable; urgency=medium

  * Import upstream version 2.18 and 2.19
  * Drop Build-Depends on libdevel-checklib-perl
  * Add no-alien.patch to not use Alien::Base::Wrapper

 -- Salvatore Bonaccorso <carnil@debian.org>  Mon, 09 Apr 2018 16:06:09 +0200

libmath-gmp-perl (2.17-1) unstable; urgency=medium

  * Update Vcs-* headers for switch to salsa.debian.org
  * Import upstream version 2.17
  * Declare compliance with Debian policy 4.1.4
  * Update copyright years for debian/* packaging files

 -- Salvatore Bonaccorso <carnil@debian.org>  Thu, 05 Apr 2018 23:41:49 +0200

libmath-gmp-perl (2.16-1) unstable; urgency=medium

  * Team upload.

  [ Alex Muntada ]
  * Remove inactive pkg-perl members from Uploaders.

  [ gregor herrmann ]
  * Import upstream version 2.16.
  * Update years of packaging copyright.
  * Declare compliance with Debian Policy 4.1.3.
  * Bump debhelper compatibility level to 10.

 -- gregor herrmann <gregoa@debian.org>  Tue, 02 Jan 2018 23:48:35 +0100

libmath-gmp-perl (2.15-1) unstable; urgency=medium

  * Team upload.
  * Import upstream version 2.15.
  * Update years of packaging copyright.
  * Declare compliance with Debian Policy 4.0.0.

 -- gregor herrmann <gregoa@debian.org>  Fri, 04 Aug 2017 17:32:19 -0400

libmath-gmp-perl (2.13-1) unstable; urgency=medium

  * Import upstream version 2.13

 -- Salvatore Bonaccorso <carnil@debian.org>  Fri, 18 Nov 2016 15:09:44 +0100

libmath-gmp-perl (2.12-1) unstable; urgency=medium

  [ Axel Beckert ]
  * debian/upstream/metadata: Re-add upstream git repo with correct URL.

  [ Salvatore Bonaccorso ]
  * debian/control: Use HTTPS transport protocol for Vcs-Git URI

  [ gregor herrmann ]
  * debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
  * debian/upstream/metadata: use HTTPS for GitHub URLs.

  [ Salvatore Bonaccorso ]
  * Import upstream version 2.12
  * Update copyright years for debian/* packaging files
  * Declare compliance with Debian policy 3.9.8
  * debian/rules: Build enabling all hardening flags

 -- Salvatore Bonaccorso <carnil@debian.org>  Wed, 09 Nov 2016 13:06:09 +0100

libmath-gmp-perl (2.11-1) unstable; urgency=medium

  * Remove reference to upstream repo.
    Currently there is no github repository available for Math::GMP.
  * Imported Upstream version 2.11

 -- Salvatore Bonaccorso <carnil@debian.org>  Mon, 17 Aug 2015 08:08:31 +0200

libmath-gmp-perl (2.10-1) unstable; urgency=medium

  * Add debian/upstream/metadata
  * Import upstream version 2.10

 -- Salvatore Bonaccorso <carnil@debian.org>  Wed, 12 Aug 2015 22:50:03 +0200

libmath-gmp-perl (2.09-1) unstable; urgency=medium

  * Update Vcs-Browser URL to cgit web frontend
  * Imported Upstream version 2.09
  * Wrap and sort fields in debian/control file
  * Update copyright years for debian/* packaging files
  * Declare compliance with Debian policy 3.9.6
  * Add libdevel-checklib-perl to Build-Depends
  * Declare package as autopkgtestable
  * Reformat copyright file and add Comment field for debian/* files

 -- Salvatore Bonaccorso <carnil@debian.org>  Fri, 31 Jul 2015 07:50:40 +0200

libmath-gmp-perl (2.07-1) unstable; urgency=low

  [ Ansgar Burchardt ]
  * [7cbff8f6] debian/control: Convert Vcs-* fields to Git.

  [ Salvatore Bonaccorso ]
  * [357e5ef7] Change Vcs-Git to canonical URI (git://anonscm.debian.org)
  * [7db0fda8] Change search.cpan.org based URIs to metacpan.org based URIs

  [ Axel Beckert ]
  * [c889442b] debian/copyright: migrate pre-1.0 format to 1.0
                                 using "cme fix dpkg-copyright"

  [ Daniel Lintott ]
  * [7f573356] Imported Upstream version 2.07
  * [7e6f51d0] Drop trailing slash from metacpan URL's
  * [3a7be292] Add myself to Uploaders
  * [e707ee2c] Bump debhelper version, to get all hardening flags
  * [290320a8] Declare compliance with standards version 3.9.5

 -- Daniel Lintott <daniel@serverb.co.uk>  Mon, 24 Feb 2014 19:58:56 +0000

libmath-gmp-perl (2.06-1) unstable; urgency=low

  [ gregor herrmann ]
  * debian/control: Changed: Switched Vcs-Browser field to ViewSVN
    (source stanza).
  * debian/control: Added: ${misc:Depends} to Depends: field.

  [ Ryan Niebur ]
  * Remove Florian Ragwitz from Uploaders (Closes: #523212)

  [ Nathan Handler ]
  * debian/watch: Update to ignore development releases.

  [ Ansgar Burchardt ]
  * New upstream release.
    + debian/copyright: Update years of copyright.
  * Use minimal debian/rules.
  * debian/control: Make build-dep on perl unversioned.
  * Bump Standards-Version to 3.8.3.
  * Update my email address.

  [ Salvatore Bonaccorso ]
  * debian/control:
    - Change Build-Depends on libgmp3-dev to libgmp-dev.
    - Bump Build-Depends on debhelper to (>= 8).
    - Drop Build-Depends on libtest-yaml-meta-perl.
  * Bump Debhelper compat level to 8.
  * debian/copyright:
    - Refresh Format-Specification to revision 135 of DEP5 propolsal for
      machine-readable copyright information.
    - Explicitly point to version 2 of the LGPL in common-licenses
  * Add myself to Uploaders.
  * Bump Standards-Version to 3.9.1.
  * Convert to '3.0 (quilt)' source package format.

 -- Salvatore Bonaccorso <carnil@debian.org>  Fri, 18 Mar 2011 08:25:39 +0100

libmath-gmp-perl (2.05-1.1) unstable; urgency=low

  * NMU.  Change dependency libgmp3-dev --> libgmp-dev.

 -- Steve M. Robbins <smr@debian.org>  Thu, 17 Mar 2011 22:15:20 -0500

libmath-gmp-perl (2.05-1) unstable; urgency=low

  [ gregor herrmann ]
  * Take over for the Debian Perl Group with maintainer's permission
    (http://lists.debian.org/debian-perl/2008/06/msg00039.html)
  * debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser
    field (source stanza); Homepage field (source stanza). Changed:
    Maintainer set to Debian Perl Group <pkg-perl-
    maintainers@lists.alioth.debian.org> (was: Florian Ragwitz
    <rafl@debian.org>); Florian Ragwitz <rafl@debian.org> moved to
    Uploaders.
  * Add debian/watch.

  [ Ansgar Burchardt ]
  * New upstream release.
  * Remove patch framework (patch was applied upstream)
  * Refresh debian/rules for debhelper 7.
  * Bump Standards Version to 3.8.0
  * Convert debian/copyright to proposed machine-readable format

 -- Ansgar Burchardt <ansgar@43-1.org>  Sun, 02 Nov 2008 02:23:12 +0100

libmath-gmp-perl (2.04-2.1) unstable; urgency=low

  * Non-maintainer upload for the Perl 5.10 transition.
  * Don't try to remove /usr/share/perl5 if it doesn't exist. (Closes: #463542)

 -- Niko Tyni <ntyni@debian.org>  Wed, 02 Apr 2008 16:11:46 +0300

libmath-gmp-perl (2.04-2) unstable; urgency=low

  * Added debian/patches/64bit_ftbfs.dpatch that makes the test suite pass on
    64 bit platforms (Closes: #338945).
  * debian/{control,rules} adjustments for dpatch.
  * Use DH_COMPAT 5.

 -- Florian Ragwitz <rafl@debian.org>  Sun, 26 Mar 2006 20:19:35 +0200

libmath-gmp-perl (2.04-1) unstable; urgency=low

  * Initial Release.

 -- Florian Ragwitz <rafl@debian.org>  Wed,  2 Nov 2005 18:51:14 +0100