File: control

package info (click to toggle)
libmodule-extract-use-perl 1.047-1
  • links: PTS, VCS
  • area: main
  • in suites: bookworm, bullseye, sid
  • size: 184 kB
  • sloc: perl: 572; makefile: 2
file content (31 lines) | stat: -rw-r--r-- 1,322 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
Source: libmodule-extract-use-perl
Maintainer: Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Uploaders: gregor herrmann <gregoa@debian.org>
Section: perl
Testsuite: autopkgtest-pkg-perl
Priority: optional
Build-Depends: debhelper-compat (= 12)
Build-Depends-Indep: libppi-perl <!nocheck>,
                     libtest-manifest-perl <!nocheck>,
                     libtest-output-perl <!nocheck>,
                     libtest-pod-coverage-perl <!nocheck>,
                     libtest-pod-perl <!nocheck>,
                     perl
Standards-Version: 4.5.0
Vcs-Browser: https://salsa.debian.org/perl-team/modules/packages/libmodule-extract-use-perl
Vcs-Git: https://salsa.debian.org/perl-team/modules/packages/libmodule-extract-use-perl.git
Homepage: https://metacpan.org/release/Module-Extract-Use
Rules-Requires-Root: no

Package: libmodule-extract-use-perl
Architecture: all
Depends: ${misc:Depends},
         ${perl:Depends},
         libppi-perl
Description: Perl module to extract which modules some code uses
 Module::Extract::Use extracts the names of the modules used in a file using a
 static analysis. It uses PPI (Perl Parsing Interface) to tokenize and extract
 the file data.
 .
 Since this module does not run code, it cannot find dynamic uses of modules,
 such as eval "require $class".