File: dist.ini

package info (click to toggle)
libmoosex-declare-perl 0.43-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid, stretch
  • size: 564 kB
  • ctags: 82
  • sloc: perl: 1,240; makefile: 9
file content (34 lines) | stat: -rw-r--r-- 1,004 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
name = MooseX-Declare
author  = Florian Ragwitz <rafl@debian.org>
license = Perl_5
copyright_holder = Florian Ragwitz
copyright_year = 2008

[@Author::ETHER]
:version = 0.097
surgical_podweaver = 1
-remove = PodCoverageTests  ; temporary
-remove = Test::PodSpelling ; temporary
-remove = Test::Pod::No404s ; URI::Find botches the geany link
Test::MinimumVersion.max_target_perl = 5.008008
AutoPrereqs.skip = ^::|^Role|DefClass|^ProvidesFooAttribute
Authority.authority = cpan:FLORA
Test::ReportPrereqs.include = Dist::CheckConflicts
StaticInstall.dry_run = 0   ; we can safely set this here

[MetaResources]
x_IRC = irc://irc.perl.org/#moose
x_MailingList = http://lists.perl.org/list/moose.html

[Prereqs]
Devel::Declare = 0.005011 ; we actually use Devel::Declare::Context::Simple, but
                          ; it has no version in historical releases
namespace::autoclean = 0.16

[Prereqs / DevelopRequires]
Test::Warnings = 0

[Test::CheckBreaks]
conflicts_module = Moose::Conflicts

[Deprecated]