1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62
|
include /usr/share/quilt/quilt.make
export PERL_MM_USE_DEFAULT=1
PACKAGE=$(shell dh_listpackages)
ifndef PERL
PERL = /usr/bin/perl
endif
TMP = $(CURDIR)/debian/$(PACKAGE)
build: build-arch build-indep
build-arch: build-stamp
build-indep: build-stamp
build-stamp: $(QUILT_STAMPFN)
dh_testdir
LDAPPKGNAME=openldap $(PERL) Makefile.PL.rpm INSTALLDIRS=vendor
$(MAKE) OPTIMIZE="-Wall -O2 -g"
touch build-stamp
clean: clean-patched unpatch
clean-patched:
dh_testdir
dh_testroot
rm -rf build-stamp install-stamp temp
[ ! -f Makefile ] || $(MAKE) distclean
rm -rf $(TMP)
dh_clean
install: build install-stamp
install-stamp:
dh_testdir
dh_testroot
dh_clean -k
$(MAKE) test
$(MAKE) install DESTDIR=$(TMP) PREFIX=/usr
touch install-stamp
binary-indep:
binary-arch: build install
dh_testdir
dh_testroot
dh_installexamples examples/*
dh_installdocs CREDITS README
dh_installchangelogs ChangeLog
dh_strip -a
dh_makeshlibs -a
dh_installdeb -a
dh_perl -a
dh_shlibdeps -a
dh_compress
dh_fixperms
dh_gencontrol
dh_md5sums
dh_builddeb
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary
|