1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40
|
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
export DEB_BUILD_OPTIONS=nocheck
confflags := --disable-silent-rules \
--prefix=/usr \
--libdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH) \
$(NULL)
confflags += $(shell dpkg-buildflags --export=configure)
override_dh_installchangelogs:
dh_installchangelogs ChangeLog
override_dh_auto_configure:
dh_auto_configure -- $(confflags)
override_dh_auto_install:
dh_auto_install
install -d debian/tmp/etc/nfc
install -m 644 libnfc.conf.sample debian/tmp/etc/nfc/libnfc.conf
%:
dh $@ --with autoreconf
override_dh_strip:
dh_strip -plibnfc5 --dbg-package=libnfc5-dbg
dh_strip --remaining-packages
|