1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52
|
DEB_SOURCE := $(shell dpkg-parsechangelog | grep Source: | sed -e 's/Source: //')
DEB_VERSION := $(shell dpkg-parsechangelog | grep Version: | sed -e 's/Version: //')
DEB_UPSTREAM_VERSION := $(shell echo $(DEB_VERSION) | sed -e 's/-[^-]*$$//')
GIT_URL = git://omxil.git.sourceforge.net/gitroot/omxil/omxil
%:
dh $@ --with autoreconf,linktree
override_dh_auto_configure:
dh_auto_configure -- --enable-videosrc --disable-jpeg
override_dh_auto_install:
set -e; for script in triggers; do \
sed -e"s/#MULTIARCH#/$(DEB_HOST_MULTIARCH)/g" \
-e"s/#ARCH#/$(DEB_HOST_ARCH)/g" \
debian/libomxil-bellagio-bin.$$script.in \
> debian/libomxil-bellagio-bin.$$script ; \
done
dh_auto_install
find $(CURDIR)/debian/tmp -name "*.la" -delete
rm -f $(CURDIR)/doc/libomxil-bellagio/html/jquery.js
override_dh_makeshlibs:
dh_makeshlibs -Xusr/lib/libomxil-bellagio0/
override_dh_installdocs:
dh_installdocs -plibomxil-bellagio-doc --doc-main-package=libomxil-bellagio-doc
dh_installdocs --remaining-packages
update-patch-series:
mkdir -p $(CURDIR)/debian/patches
rm -f $(CURDIR)/debian/patches/*.patch
git-format-patch -o $(CURDIR)/debian/patches patches ^upstream | \
xargs -n 1 basename > $(CURDIR)/debian/patches/series
get-orig-source::
set -e; if echo $(DEB_VERSION) | grep -c "git"; \
then \
git_version=`echo $(DEB_VERSION) | sed -e 's/^.*git\([0-9]*\)*\.\(.*\)-.*$$/\2/g'`; \
else \
git_version=$(DEB_UPSTREAM_VERSION); \
fi; \
tmpdir=`mktemp -d -t`; \
cd $$tmpdir; \
echo "checkout upstream repository ..."; \
git clone $(GIT_URL); echo "getting specific upstream revision/tag: $$git_version"; \
cd `ls | head -n 1`; git checkout -b orig $$git_version; cd ..; \
tar --exclude=.git -czvf $(CURDIR)/$(DEB_SOURCE)_$(DEB_UPSTREAM_VERSION).orig.tar.gz `ls | head -n 1`; \
cd $(CURDIR); \
rm -rf $$tmpdir
|