1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64
|
include /usr/share/dpkg/architecture.mk
ENABLE_SPREADSHEET_MODEL=y
ifneq "$(ENABLE_SPREADSHEET_MODEL)" "y"
export DH_OPTIONS += -Nliborcus-spreadsheet-model-0.13-0
endif
%:
dh $@ --parallel --with python3 --with sphinxdoc
override_dh_auto_clean:
rm -rf src/python/orcus/__pycache__/
rm -rf test/python/__pycache__
dh_auto_clean
dh_autoreconf_clean
rm -rf doc/_doxygen doc/tmp
override_dh_auto_build-arch:
dh_autoreconf
ifeq "$(ENABLE_SPREADSHEET_MODEL)" "y"
dh_auto_configure -- --disable-silent-rules --disable-werror --with-boost-libdir=/usr/lib/$(DEB_HOST_MULTIARCH)
else
dh_auto_configure -- --disable-silent-rules --disable-werror --disable-spreadsheet-model --with-boost-libdir=/usr/lib/$(DEB_HOST_MULTIARCH)
endif
dh_auto_build
override_dh_auto_build-indep:
cd doc && \
doxygen doxygen.conf && \
mkdir tmp && sphinx-build -v -a . tmp
override_dh_auto_configure:
ifeq "$(DEB_HOST_ARCH)" "s390"
override_dh_auto_test:
else
override_dh_auto_test:
if [ -d $(CURDIR)/src/python/.libs ]; then \
PYTHONPATH="$(CURDIR)/src/python/.libs:$(CURDIR)/src/python/orcus" dh_auto_test; \
fi
endif
override_dh_auto_install:
mkdir -p debian/tmp
if [ -d src/.libs ]; then dh_auto_install; \
find debian/tmp/usr/lib/python* -name "*.*a" -exec rm {} \; ; \
chrpath -d debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/liborcus-0.14.so.0.0.0; \
else dh_auto_install -- -pliborcus-doc; fi
|