File: dist.ini

package info (click to toggle)
libpackage-stash-perl 0.38-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 520 kB
  • sloc: perl: 3,423; makefile: 12
file content (50 lines) | stat: -rw-r--r-- 1,337 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
name = Package-Stash
author = Jesse Luehrs <doy@tozt.net>
license = Perl_5
copyright_holder = Jesse Luehrs

[FileFinder::Filter / WeaverFinder]
finder = :InstallModules
finder = :ExecFiles
skip = Conflicts.pm$

[@Author::ETHER]
:version = 0.119
authority = cpan:DOY
installer = none
ExecDir.dir = bin
PodWeaver.finder = WeaverFinder
PodWeaver.replacer = replace_with_nothing
PodWeaver.post_code_replacer = replace_with_nothing
AutoPrereqs.skip = Variable::Magic
Test::Compile.xt_mode = 0
Test::Compile.bail_out_on_fail = 0
; there's some bug with PodCoverageTests and Conflicts on travis that i can't
; seem to track down, so just disable that for now
-remove = PodCoverageTests
-remove = Test::CleanNamespaces
-remove = Test::PodSpelling
-remove = Test::MinimumVersion
[=inc::MMPackageStash]
[Metadata]
dynamic_config = 1

[Prereqs / TestRequires]
Test::More = 0.88

[Prereqs / RuntimeRecommends]
; XXX keep this in sync with inc/MMPackageStash.pm
Package::Stash::XS = 0.26

[Prereqs / DevelopRequires]
Test::LeakTrace = 0
; XXX can't just have a dep here because it won't install on 5.12 and below
; see .travis.yml
; Package::Anon = 0

[Conflicts]
-script = bin/package-stash-conflicts
Class::MOP                    = 1.08
MooseX::Role::WithOverloading = 0.08
namespace::clean              = 0.18
MooseX::Method::Signatures    = 0.36