File: changelog

package info (click to toggle)
libpeas 1.22.0-4
  • links: PTS, VCS
  • area: main
  • in suites: buster, sid
  • size: 5,788 kB
  • sloc: ansic: 14,494; sh: 11,443; makefile: 1,078; python: 187; xml: 44
file content (558 lines) | stat: -rw-r--r-- 18,419 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
370
371
372
373
374
375
376
377
378
379
380
381
382
383
384
385
386
387
388
389
390
391
392
393
394
395
396
397
398
399
400
401
402
403
404
405
406
407
408
409
410
411
412
413
414
415
416
417
418
419
420
421
422
423
424
425
426
427
428
429
430
431
432
433
434
435
436
437
438
439
440
441
442
443
444
445
446
447
448
449
450
451
452
453
454
455
456
457
458
459
460
461
462
463
464
465
466
467
468
469
470
471
472
473
474
475
476
477
478
479
480
481
482
483
484
485
486
487
488
489
490
491
492
493
494
495
496
497
498
499
500
501
502
503
504
505
506
507
508
509
510
511
512
513
514
515
516
517
518
519
520
521
522
523
524
525
526
527
528
529
530
531
532
533
534
535
536
537
538
539
540
541
542
543
544
545
546
547
548
549
550
551
552
553
554
555
556
557
558
libpeas (1.22.0-4) unstable; urgency=medium

  * Add -Wl,-O1 to our LDFLAGS
  * Bump Standards-Version to 4.3.0

 -- Jeremy Bicha <jbicha@debian.org>  Fri, 28 Dec 2018 08:31:54 -0500

libpeas (1.22.0-3) unstable; urgency=medium

  * Update Vcs fields for migration to https://salsa.debian.org/
  * Bump Standards-Version to 4.2.1
  * Drop Conflicts/Replaces/Provides for Ubuntu's previous loader split
    not needed after Ubuntu 18.04 LTS

 -- Jeremy Bicha <jbicha@debian.org>  Sun, 02 Dec 2018 08:19:21 -0500

libpeas (1.22.0-2) unstable; urgency=medium

  [ Simon McVittie ]
  * gir1.2-peas-1.0 Provides gir1.2-peasgtk-1.0, reflecting the fact
    that it contains both Peas-1.0.typelib and PeasGtk-1.0.typelib
  * Bump priorities from extra to optional. Priority: extra is now
    deprecated.

  [ Jeremy Bicha ]
  * Update Vcs fields for conversion to git
  * Add debian/gbp.conf
  * Bump Standards-Version to 4.1.2
  * Bump debhelper compat to 11
  * Build with all hardening flags

 -- Jeremy Bicha <jbicha@debian.org>  Tue, 19 Dec 2017 16:49:57 -0500

libpeas (1.22.0-1) unstable; urgency=medium

  * New upstream translations release

 -- Jeremy Bicha <jbicha@debian.org>  Sun, 10 Sep 2017 11:01:40 -0400

libpeas (1.21.0-1) unstable; urgency=medium

  * New upstream release.
  * Bump Standards-Version to 4.1.0

 -- Jeremy Bicha <jbicha@ubuntu.com>  Tue, 29 Aug 2017 13:50:55 -0400

libpeas (1.20.0-1) unstable; urgency=medium

  * Convert from cdbs to dh.
  * Bump to dh compat 10 (automatic dh-autoreconf)
  * Add explicit gnome-common build-dependency (Closes: #837844)
  * New upstream release.

 -- Andreas Henriksson <andreas@fatal.se>  Mon, 19 Sep 2016 19:15:48 +0200

libpeas (1.18.0-3) unstable; urgency=medium

  * Convert to multiarch. (Closes: #815727)
  * Add some Conflicts/Replaces/Provides for the benefit of users
    transitioning from Ubuntu's different loader split.

 -- Iain Lane <laney@debian.org>  Tue, 05 Jul 2016 10:21:20 +0100

libpeas (1.18.0-2) unstable; urgency=medium

  * Add Build-Depends-Package meta-tags to symbols file.
  * Split out python2 loader in a separate package (Closes: #806824)
  * Use --fail-missing when installing package files.
  * Bump Standards-Version to 3.9.8

 -- Andreas Henriksson <andreas@fatal.se>  Fri, 15 Apr 2016 10:17:52 +0200

libpeas (1.18.0-1) experimental; urgency=medium

  [ Hideki Yamane ]
  * debian/watch
    - adjust to new upstream URL

  [ Andreas Henriksson ]
  * New upstream release.
  * Drop debian/patches/0001-Fix-Python-plugin-loader-module-paths.patch
    - merged upstream.
  * Bump Standards-Version to 3.9.7
  * Append '-V -- -c4' to dh makeshlib args.
    - prevents package being built with auto-generated symbols file.
  * Update debian/libpeas-1.0-0.symbols with three additions.

 -- Andreas Henriksson <andreas@fatal.se>  Sat, 02 Apr 2016 15:47:48 +0200

libpeas (1.16.0-1) unstable; urgency=medium

  * New upstream release.
  * Update debian/patches/0001-Fix-Python-plugin-loader-module-paths.patch
    - replace patch from gnome bugzilla with commit from upstream git.

 -- Andreas Henriksson <andreas@fatal.se>  Tue, 22 Sep 2015 13:44:28 +0200

libpeas (1.14.0-1) unstable; urgency=medium

  [ Iain Lane ]
  * Depend on adwaita-icon-theme for the test. This is GNOME's new default
    icon theme.

  [ Jackson Doak ]
  * New upstream release

  [ Andreas Henriksson ]
  * Fix Homepage url (breakage spotted by DUCK by skanz@d.o)

  [ Michael Biebl ]
  * Bump Build-Depends as per configure.ac.
  * Drop obsolete --disable-seed configure flag.
  * Update symbols file. Mark private symbols as optional.
  * Bump debhelper compatibility level to 9.
  * Drop obsolete Conflicts and Replaces from pre-wheezy.
  * Fix Python plugin loader module paths. Patch taken from bgo#753401.

 -- Michael Biebl <biebl@debian.org>  Fri, 04 Sep 2015 00:33:39 +0200

libpeas (1.12.1-2) unstable; urgency=medium

  * Disable seed support everywhere.

 -- Emilio Pozuelo Monfort <pochu@debian.org>  Thu, 06 Nov 2014 13:13:34 +0100

libpeas (1.12.1-1) unstable; urgency=medium

  * New upstream release.
  * Bump libglib2.0-dev build-dependency to >= 2.32.0 according to configure.ac

 -- Andreas Henriksson <andreas@fatal.se>  Mon, 22 Sep 2014 21:10:34 +0200

libpeas (1.10.1-4) unstable; urgency=medium

  * Also exclude arm64 hppa and arm from the seed build-dependency.
  * Add ppc64el and ia64 to archs where we don't enable seed
    and exclude them from the seed build-dependency.

 -- Andreas Henriksson <andreas@fatal.se>  Sun, 07 Sep 2014 22:01:32 +0200

libpeas (1.10.1-3) unstable; urgency=medium

  * Also add arm64 to platforms where we don't enable seed.

 -- Andreas Henriksson <andreas@fatal.se>  Sun, 07 Sep 2014 21:48:58 +0200

libpeas (1.10.1-2) unstable; urgency=medium

  * Add hppa and alpha to the list of architectures where we don't enable
    seed (Closes: #757241)

 -- Andreas Henriksson <andreas@fatal.se>  Fri, 05 Sep 2014 00:01:41 +0200

libpeas (1.10.1-1) unstable; urgency=medium

  [ Emilio Pozuelo Monfort ]
  * debian/rules:
    + Don't run the test suite when DEB_BUILD_OPTIONS contains nocheck.
      Thanks to Pino Toscano. Closes: #755251.
  * debian/rules,
    debian/control.in:
    + Disable seed support on hurd-i386. Thanks to Pino Toscano.
      Closes: #755259.

  [ Andreas Henriksson ]
  * New upstream release.

 -- Andreas Henriksson <andreas@fatal.se>  Thu, 28 Aug 2014 16:43:26 -0700

libpeas (1.10.0-2) unstable; urgency=medium

  * debian/rules, debian/control.in:
    Disable seed support on big-endian architectures (Closes: #727127)
    - add powerpc s390x sparc since mips was already excluded.
    - seed (because of webkit?) is broken on big endian.

 -- Andreas Henriksson <andreas@fatal.se>  Sat, 26 Apr 2014 20:06:47 +0200

libpeas (1.10.0-1) experimental; urgency=medium

  * export NOCONFIGURE in debian/rules to avoid double-configure.
  * Add --disable-gjs configure flag for now.
    - the gjs support has been dropped upstream
    - it causes test failures (see 1.9.0-1 changelog entry)
    - doesn't build with gjs >= 1.39 (mozjs24)
  * Make test-suite fatal again.
  * Bump Standards-Version to 3.9.5
  * New upstream release.
  * Update build-dependencies according to configure.ac changes:
    - Bump gobject-introspection to >= 1.39.0
    - Drop libgjs-dev
  * Remove --disable-gjs configure flag (gjs no longer exists)
  * Drop debian/patches/Fix-autogen-with-latest-gnome-common.patch
    - from upstream, now part of released version.

 -- Andreas Henriksson <andreas@fatal.se>  Tue, 01 Apr 2014 21:13:05 +0200

libpeas (1.9.0-1) experimental; urgency=low

  * New upstream release
  * debian/patches/0001-Fix-tests-after-glib-string-change.patch
   + Dropped, fixed upstream
  * debian/patches/0002-Fix-autogen-with-latest-gnome-common.patch
   + Dropped, fixed upstream
  * debian/patches/Fix-autogen-with-latest-gnome-common.patch
    + Added, fix autogen (from upstream git)
  * make the test-suite non-fatal, issues filed upstream as bgo#711356

 -- Sjoerd Simons <sjoerd@debian.org>  Sun, 03 Nov 2013 20:52:13 +0100

libpeas (1.8.1-2) unstable; urgency=low

  * debian/patches/0002-Fix-autogen-with-latest-gnome-common.patch:
    Cherry-pick patch from upstream to drop usage of AM_GNU_GETTEXT as this is
    not working in combination with IT_PROG_INTLTOOL. This fixes a FTBFS with
    latest gnome-common which uses autoreconf now. (Closes: #724555)
  * Delete __pycache__ directory in addition to compiled .pyc and .pyo files.

 -- Michael Biebl <biebl@debian.org>  Mon, 14 Oct 2013 11:53:01 +0200

libpeas (1.8.1-1) unstable; urgency=low

  [ Michael Biebl ]
  * Upload to unstable.

  [ Iain Lane ]
  * debian/patches/0001-Fix-tests-after-glib-string-change.patch: Cherry-pick
    from upstream to work with `old' and 'new' GLib strings. Fixes FTBFS in
    test suite.

  [ Jeremy Bicha ]
  * Update homepage

  [ Michael Biebl ]
  * New upstream release.
  * debian/watch: Track stable releases.

 -- Michael Biebl <biebl@debian.org>  Thu, 01 Aug 2013 17:29:30 +0200

libpeas (1.8.0-1) experimental; urgency=low

  * New upstream release.
    + debian/patches/30_fix_python2-config.patch:
      - Removed, included upstream.

 -- Emilio Pozuelo Monfort <pochu@debian.org>  Thu, 28 Mar 2013 02:19:29 +0100

libpeas (1.7.0-2) experimental; urgency=low

  * debian/control.in:
    + Bump libgjs-dev build dependency to build against libgjs0c.
  * debian/rules:
    + Set $HOME when running the test suite, fixes the build on some
      buildds where $HOME is not writable.

 -- Emilio Pozuelo Monfort <pochu@debian.org>  Sun, 24 Mar 2013 21:58:10 +0100

libpeas (1.7.0-1) experimental; urgency=low

  * New upstream release.
  * debian/control:
    - Bump Standards-Version to 3.9.4.
    - Build-Depends on python3-dev to build python3 loader.
    - Build-Depends on dh_autoreconf.
    - Build-Depends on python-gi-dev (>= 3.7.2) to pass testsuite.
    - Build-Depends on xvfb and xauth to run testsuite.
    - Build-Depends on libgjs-dev to build gjs loader.
    - Build-Depends on libseed-gtk3-dev also on ia64.
  * debian/rules:
    - Enable python3 loader (Closes: #678354).
    - Enable gjs loader.
    - Enable seed loader on ia64.
    - Include autoreconf.mk to run dh_autoreconf.
    - Enable testsuite.
    - Run gnome-autogen.sh
  * debian/patches:
    - Added 30_fix_python2-config.patch: Check for python-config binary.

 -- Thomas Bechtold <thomasbechtold@jpberlin.de>  Sat, 16 Mar 2013 07:27:26 +0100

libpeas (1.6.2-1) experimental; urgency=low

  * New upstream release
  * Drop vala build-dep and configure flag,
    vala demo plugin dropped upstream. (Closes: #675656)
  * Update for new libpeas-1.0-0 symbols (2 additions)

 -- Andreas Henriksson <andreas@fatal.se>  Sun, 09 Dec 2012 22:54:16 +0100

libpeas (1.4.0-2) unstable; urgency=low

  * Don't enable the seed plugin on ia64 and mips since seed is not available
    on those architectures.

 -- Michael Biebl <biebl@debian.org>  Sat, 31 Mar 2012 23:37:26 +0200

libpeas (1.4.0-1) unstable; urgency=low

  * New upstream release.
  * debian/watch: Track .xz tarballs.
  * Bump (Build-)Depends on libglib2.0-dev to (>= 2.31.2).
  * debian/libpeas-1.0-0.symbols: Add new symbols and remove 2 internal
    symbols which were dropped upstream.
  * Explicitly enable the plugins (vala, python, seed) for more reliable build
    results.
  * Use find to remove the compiled python and libtool .la files.
  * Bump Standards-Version to 3.9.3.

 -- Michael Biebl <biebl@debian.org>  Sat, 31 Mar 2012 08:26:42 +0200

libpeas (1.2.0-2) unstable; urgency=low

  [ Josselin Mouette ]
  * Replace python-gobject by python-gi.

  [ Michael Biebl ]
  * Change section of gir1.2-peas-1.0 to introspection.

  [ Josselin Mouette ]
  * Update repository URL.

 -- Michael Biebl <biebl@debian.org>  Thu, 15 Mar 2012 20:17:11 +0100

libpeas (1.2.0-1) unstable; urgency=low

  [ Oliver Sauder ]
  * Renamed peas vapi file to libpeas-1.0.vapi (Closes: #639625)

  [ Laurent Bigonville ]
  * debian/control.in:
    - Bump Priority to optional
    - Drop duplicate Section to please lintian
  * debian/libpeas-doc.lintian-overrides:
    Override documentation-package-not-architecture-independent

  [ Sjoerd Simons ]
  * New upstream release
  * Binds plugin module symbols globally, fixes python plugins (Closes: 647292)
  * Sync with ubuntu:
    * Don't ship vapi files, rely on valac-0.14 shipping them
    * debian/libpeas-1.0-0.symbols: Updates
    * Put libpeas-1.0-0, libpeas-common and gir1.2-peas-1.0 in section libs
    * Don't run the GTK test as they require an X server
    * Set priority to extra

 -- Sjoerd Simons <sjoerd@debian.org>  Sun, 20 Nov 2011 23:21:10 +0000

libpeas (1.1.1-1) unstable; urgency=low

  * New upstream release.
  * debian/libpeas-1.0-0.symbols: Update for new API additions.

 -- Michael Biebl <biebl@debian.org>  Wed, 03 Aug 2011 19:11:54 +0200

libpeas (1.1.0-1) unstable; urgency=low

  * New upstream release.
  * Update debian/libpeas-1.0-0.symbols.
  * debian/rules: Build gtk-doc documentation.
  * Install the complete /usr/lib/peas-demo directory and remove compiled
    python and libtool .la files afterwards. This way we don't fail on
    architectures where seed is disabled and no .js files are installed.

 -- Michael Biebl <biebl@debian.org>  Fri, 22 Jul 2011 00:16:40 +0200

libpeas (1.0.0-5) unstable; urgency=low

  * debian/libpeas-doc.install:
    - Install .js and .py plugin files for peas-demo.
  * Disable seed support on mips. Should be re-enabled when #633730 is fixed.

 -- Michael Biebl <biebl@debian.org>  Thu, 21 Jul 2011 18:41:59 +0200

libpeas (1.0.0-4) unstable; urgency=low

  [ Sebastien Bacher ]
  * debian/control.in: build-depends on libgladeui-dev
  * Install the glade catalogue

  [ Michael Biebl ]
  * Rely on cdbs to call dh_girepository:
    - Bump Build-Depends on cdbs to (>= 0.4.90).
    - Remove custom dh_girepository rules from debian/rules.
  * Disable seed support on ia64 until #582774 is fixed.
  * Upload to unstable.
    - Update Vcs-* fields.
    - Remove check-dist.mk from debian/rules.

 -- Michael Biebl <biebl@debian.org>  Wed, 13 Jul 2011 10:49:51 +0200

libpeas (1.0.0-3) experimental; urgency=low

  * Exclude plugin directory when calling dh_makeshlibs for libpeas-1.0-0 and
    remove those symbols from debian/libpeas-1.0-0.symbols.
  * debian/watch: Don't run uupdate.
  * debian/control.in:
    - Bump dependency on libgirepository1.0-dev to (>= 0.10.1) for
      libpeas-dev according to the .pc file.
    - Bump Build-Depends on libgirepository1.0-dev to (>= 0.10.1).
  * Don't install libtool .la files for loader plugins and peas-demo.

 -- Michael Biebl <biebl@debian.org>  Sun, 19 Jun 2011 01:19:40 +0200

libpeas (1.0.0-2) experimental; urgency=low

  [ Michael Terry ]
  * debian/libpeas-1.0-0.symbols: add symbols file

  [ Martin Pitt ]
  * Enable Vala support:
    - debian/control.in: Add valac-0.12 build dependency. configure picks that
      up and enables Vala support.
    - debian/rules: Call vapigen to build a vapi from generated gir.
    - debian/libpeas-dev.install: Ship libpeas-1.0.vapi.
  * debian/rules: Run tests during build, but make sure that we don't build
    the tests with -Bsymbolic-functions, which confuses them. Thanks to
    Michael Terry for the patch! (Closes: #627115)
  * debian/control.in: Add gnome-icon-theme build dependency. One of the self
    tests checks the "gtk-about" stock icon, so ensure that it can actually
    find it.
  * debian/control.in: Bump Standards-Version to 3.9.2, no changes necessary.
  * debian/copyright: Update FSF address, thanks lintian.

 -- Martin Pitt <mpitt@debian.org>  Tue, 31 May 2011 15:29:55 +0200

libpeas (1.0.0-1) experimental; urgency=low

  [ Josselin Mouette ]
  * Make the -dev package depend on the gir package.

  [ Andreas Henriksson ]
  * New upstream release.
    - Bump gobject-introspection and seed build dependencies according
      to configure.ac

  [ Frederic Peters ]
  * debian/rules: don't install compiled python files for the demo plugin.

 -- Frederic Peters <fpeters@debian.org>  Wed, 13 Apr 2011 16:59:57 +0200

libpeas (0.9.0-1) experimental; urgency=low

  * New upstream release.

 -- Frederic Peters <fpeters@debian.org>  Mon, 28 Mar 2011 12:05:11 +0530

libpeas (0.7.3-2) experimental; urgency=low

  * Fix typo in the libpeas-dev dependencies

 -- Sjoerd Simons <sjoerd@debian.org>  Sat, 26 Feb 2011 16:45:50 +0000

libpeas (0.7.3-1) experimental; urgency=low

  [ Sebastien Bacher ]
  * debian/control.in:
    - conflicts, replaces with old ubuntu naming to avoid upgrade issues.
      (Closes: #612478)

  [ Sjoerd Simons ]
  * New upstream release (0.7.3)
  * Transition to libgtk-3-* package nameing

 -- Sjoerd Simons <sjoerd@debian.org>  Sat, 26 Feb 2011 16:17:43 +0000

libpeas (0.7.1-1) experimental; urgency=low

  * New upstream release.

 -- Emilio Pozuelo Monfort <pochu@debian.org>  Mon, 31 Jan 2011 23:29:06 +0000

libpeas (0.7.0-1) experimental; urgency=low

  [ Sjoerd Simons ]
  * Initial debian revision

  [ Emilio Pozuelo Monfort ]
  * debian/control.in,
    debian/rules:
    - Switch to CDBS.
  * debian/rules:
    - Call dh_girepository.
  * debian/control.in:
    - Update the Homepage.
    - Fix the libpeas-dev dependencies.
  * debian/copyright:
    - Remove version from the download location.
  * debian/control.in,
    debian/libpeas-{examples,doc}.install:
    - Rename libpeas-examples to libpeas-doc and ship the documentation
      on it.
  * debian/control.in,
    debian/libpeas-common.install:
    - Add a common package.
  * debian/libpeas-dev:
    - Don't install libtool .la files.
  * debian/control.in,
    debian/compat:
    - Bump debhelper compatibility to 8.

 -- Emilio Pozuelo Monfort <pochu@debian.org>  Mon, 20 Dec 2010 00:55:33 +0000

libpeas (0.7.0-0ubuntu2) natty; urgency=low

  * Rebuild with python 2.7 as the python default.

 -- Matthias Klose <doko@ubuntu.com>  Thu, 09 Dec 2010 16:52:36 +0000

libpeas (0.7.0-0ubuntu1) natty; urgency=low

  * New upstream release
  * debian/control:
    - Update dependencies
  * debian/patches/older_gobject_introspection:
    - Dropped, not needed now
  * debian/rules:
    - Don't call autoreconf
    - Don't build against gtk2
    - Call dh_girepository to set gir:Depends
  * debian/watch:
    - Use bz2 tarballs

 -- Michael Terry <mterry@ubuntu.com>  Mon, 15 Nov 2010 16:38:37 -0500

libpeas (0.5.3-0ubuntu5) maverick; urgency=low

  * debian/control:
  * debian/gir1.0-libpeas-1.0.install:
  * debian/gir1.0-peas-1.0.install:
    - Fix name of GIR package

 -- Robert Ancell <robert.ancell@canonical.com>  Fri, 20 Aug 2010 15:36:33 +1000

libpeas (0.5.3-0ubuntu4) maverick; urgency=low

  * Rebuild against latest gobject-introspection

 -- Robert Ancell <robert.ancell@canonical.com>  Wed, 11 Aug 2010 09:19:37 +1000

libpeas (0.5.3-0ubuntu3) maverick; urgency=low

  * debian/control:
    - Build-depend on intltool, gtk-doc-tools

 -- Robert Ancell <robert.ancell@canonical.com>  Mon, 09 Aug 2010 16:44:03 +1000

libpeas (0.5.3-0ubuntu2) maverick; urgency=low

  * debian/control:
    - Build-depend on gobject-introspection

 -- Robert Ancell <robert.ancell@canonical.com>  Mon, 09 Aug 2010 12:14:50 +1000

libpeas (0.5.3-0ubuntu1) maverick; urgency=low

  * Initial release

 -- Robert Ancell <robert.ancell@canonical.com>  Tue, 03 Aug 2010 17:45:27 +1000