File: control

package info (click to toggle)
libperl-minimumversion-perl 1.38-2
  • links: PTS, VCS
  • area: main
  • in suites: buster
  • size: 276 kB
  • sloc: perl: 2,252; makefile: 2
file content (44 lines) | stat: -rw-r--r-- 1,913 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
Source: libperl-minimumversion-perl
Maintainer: Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Uploaders: Vincent Danjean <vdanjean@debian.org>,
           Ansgar Burchardt <ansgar@debian.org>,
           Damyan Ivanov <dmn@debian.org>,
           Salvatore Bonaccorso <carnil@debian.org>,
           gregor herrmann <gregoa@debian.org>
Section: perl
Rules-Requires-Root: no
Testsuite: autopkgtest-pkg-perl
Priority: optional
Build-Depends: debhelper (>= 10)
Build-Depends-Indep: libfile-find-rule-perl,
                     libfile-find-rule-perl-perl,
                     libparams-util-perl,
                     libperl-critic-perl,
                     libppi-perl (>= 1.215),
                     libppix-regexp-perl (>= 0.033),
                     libtest-script-perl,
                     perl
Standards-Version: 4.1.4
Vcs-Browser: https://salsa.debian.org/perl-team/modules/packages/libperl-minimumversion-perl
Vcs-Git: https://salsa.debian.org/perl-team/modules/packages/libperl-minimumversion-perl.git
Homepage: https://metacpan.org/release/Perl-MinimumVersion

Package: libperl-minimumversion-perl
Architecture: all
Depends: ${misc:Depends},
         ${perl:Depends},
         libfile-find-rule-perl,
         libfile-find-rule-perl-perl,
         libparams-util-perl,
         libperl-critic-perl,
         libppi-perl (>= 1.215),
         libppix-regexp-perl (>= 0.033)
Description: module to determine minimum required version of perl required
 Perl::MinimumVersion is a module that inspects arbitrary Perl source code and
 determines the minimum version of perl required to be able to run it. Because
 it is based on PPI, it can do this without having to actually load the code.
 .
 Currently it tests both the syntax of your code, and the use of explicit
 version dependencies such as "require 5.005".
 .
 Future plans are to also add support for tracing module dependencies.