1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177
|
Description: fix spelling typo
Origin: vendor
Author: mason james <mtj@kohaaloha.com>
Forwarded: https://rt.cpan.org/Public/Bug/Display.html?id=146205
Last-Update: 2023-02-02
diff --git a/lib/Perlude.pod b/lib/Perlude.pod
index 027d4e6..19b7b05 100644
@@ -7,7 +7,7 @@
=head1 SYNOPSIS
-If you're used to a unix shell, Windows Powershell or any langage comming with
+If you're used to a unix shell, Windows Powershell or any language coming with
the notion of streams, perl could be frustrating as functions like map and grep
only works with arrays.
@@ -37,7 +37,7 @@ array, maybe to act on each lastly generated element with the keyword C<now>
my @five = fold take 5, range 1, 1000;
map {say} take 5, range 1, 1000;
-a classical, memory agressive, Perl code would be
+a classical, memory aggressive, Perl code would be
map {say} (1..1000)[0..4]
@@ -103,7 +103,7 @@ the perlude counterpart is
=head2 a generator
-is a function that retuns an iterator.
+is a function that returns an iterator.
sub counter ($) {
my $x = $_[0];
@@ -139,7 +139,7 @@ from a functional language).
(2,4,6,8,10,())
A an iterator is a function that can return the elements of an iterator one by
-one. A generator is a function that retuns the iterator
+one. A generator is a function that returns the iterator
sub from_to { # the generator
my ( $from, $to ) = @_;
@@ -478,7 +478,7 @@ expose them as a single stream.
=head1 Perlude companions
some modules comes with generators so they are perfect Perlude companions
-(send me an exemple if yours does too).
+(send me an example if yours does too).
=head1 C<Path::Iterator::Rule>
@@ -515,7 +515,7 @@ you can use C<filter> instead of C<and>:
=head1 C<curry>
-a very friendly way to write iterators. i rewrote the exemple from the
+a very friendly way to write iterators. i rewrote the example from the
C<TAP::Parser> doc:
use TAP::Parser;
@@ -564,7 +564,7 @@ Explore test suite to know what isn't well tested. find bugs :)
* see range implementation # what if step 0 ?
* pairs must support streams and array
* provide an alternative to takeWhile to return the combo breaker
- * explore AST manipulations for futher optimizations
+ * explore AST manipulations for further optimizations
=item *
@@ -578,7 +578,7 @@ remove the hardcoded C<f> namespace and use C<use aliased> instead.
=item *
-ask for BooK and Dolmen if they mind to remove C<Perlude::Lazy> as noone seems
+ask for BooK and Dolmen if they mind to remove C<Perlude::Lazy> as no one seems
to use it anymore.
=item *
@@ -630,7 +630,7 @@ Burak Gürsoy (cpanization)
=item *
Thanks to Nicolas Pouillard and Valentin (#haskell-fr), i leanrt a lot about
-streams, lazyness, lists and so on. Lazyness.pm was my first attempt.
+streams, laziness, lists and so on. Lazyness.pm was my first attempt.
=item *
@@ -646,11 +646,11 @@ perfect semantic to end a stream. So Book, Dolmen and myself rewrote the
entire module from scratch in the hall of the hotel with a bottle of chartreuse
and Cognominal.
-We also tried some experiments about real lazyness, memoization and so on. it
+We also tried some experiments about real laziness, memoization and so on. it
becomes clear now that this is hell to implement correctly: use perl6 instead
:)
-I was drunk and and mispelled Perlude as "Perl dude" so Cognominal collected
+I was drunk and and misspelled Perlude as "Perl dude" so Cognominal collected
some quotes of "The Big Lebowski" and we called ourselves "the Perl Dudes".
This is way my best remember of peer programming and one of the best moment i
shared with my friends mongueurs.
diff --git a/lib/Perlude/Lazy.pm b/lib/Perlude/Lazy.pm
index 14cb091..37fc357 100644
@@ -241,7 +241,7 @@ in perlude, the same code will be:
=head1 FUNCTIONS
-all the Perlude documentation is relevent. just replace sub by enlist
+all the Perlude documentation is relevant. just replace sub by enlist
=cut
diff --git a/lib/Perlude/Tutorial.pod b/lib/Perlude/Tutorial.pod
index 3e384b4..35c35f4 100644
@@ -29,7 +29,7 @@ of potential results. Those can be written as
( 1, 2, 3, 4, () )
so C<()> is used as a list terminator. your iterator must return one scalar by
-call and last it work sending a terminator. As exemple:
+call and last it work sending a terminator. As example:
sub read_file {
open my $fh, shift;
@@ -64,12 +64,12 @@ release 3 records only.
=back
Writing unix filters is really easy. Also note that filters/generators
-compositions rules are simple and powerfull
+compositions rules are simple and powerful
G | F => G
F | F => F
-If you wrote shell, powershell, perl6 or any other functionnal langage, you
+If you wrote shell, powershell, perl6 or any other functionnal language, you
probably miss it coming back to perl5.
Basically, on demand lists are just iterators. Perlude is just a pleasant way
@@ -129,7 +129,7 @@ No perl builtin provide this power.
Perlude is a set of functions that takes closures as arguments, and returns
others
-nat is the basic closure exemple:
+nat is the basic closure example:
my $nat = sub { state $x=0; $x++ }
@@ -147,7 +147,7 @@ now you can use Perlude keywords on this functions
sub evens_in { filter { not( $_ % 2 ) } shift }
sub top5 { take 5, shift }
-=head1 Other dynamic langages stuff
+=head1 Other dynamic languages stuff
Ruby : Rubylude was written by Nono after RMLL'11 https://github.com/nono/Rubylude
Javascript :
diff --git a/t/stream/12_buffer.t b/t/stream/12_buffer.t
index 9b10a53..094989e 100644
@@ -4,7 +4,7 @@ use warnings;
use Perlude;
ok 1
-,"done testing, please check if those tests are still relevent";
+,"done testing, please check if those tests are still relevant";
done_testing;
|