File: Todo

package info (click to toggle)
libphp-jpgraph 1.5.2-11+u1
  • links: PTS
  • area: main
  • in suites: lenny
  • size: 888 kB
  • ctags: 2,689
  • sloc: php: 8,992; makefile: 24
file content (86 lines) | stat: -rw-r--r-- 3,423 bytes parent folder | download | duplicates (6)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
Version: $Id: Todo,v 1.3 2002/01/24 23:27:32 aditus Exp $

Before 1.6 release
====================

Documentation update
--------------------
* Rewrite preferred way to handle client side image maps
* Add documentation for Stroke($aFileName)
* Document the addition of SetCenter() for line plots
* Revise documentation of classes. Class diagram update
* Add documentation on how to use background image
* Review of theme management for pie

Additions
---------
* Add possibility to set the default start value for text labels
* More examples of how to plot images and extended tutorial
* Add date/time scale/axis type

Verifications/Investigations:
-----------------------------
* Possible bug when mixing grouped bar and lineplots
* Have really all 0-value bugs been squashed?
* Implement multi line text for legends
* Check legends for grouped bar plots. Can we make that easier to use?
* Check labels for 3d pies.
* Check autoscaling with several scatterplots in a graph
* Check if Setting manual scale in spider plot is a problem
* Check potential problem with linlin and supplying both X and Y 
  coordinates for a line plot
* Check what happens with negative values for impuls plots when
  adding a line y=0. Possible scale bug?
* Check the GroupBar and AccBar plot still work after the changes in
  BarPlot? Verification
* Add testcase for negative/positive accumulated bar graphs
* Fix error in documentation SetColor() is not a method of Class Legend
* Fix problem whereby the first label on the x-axis is hidden when
  Y-axis has negative values and x-axis is positioned at 0 and 
  setcenter() is used for the lineplot. Add a check to see if Setcenter
  is used and if that is the case the first label should not be hidden
  even if position is 0.
* Merge the patch to make it possible to do CSIM without running the script off-line.
* CSIM for Plot marks
* CSIM for legends. Does this make sense?
* Investigate the following report
	Also,  I  have  discovered that in a graph with bars and lines, if the
	values  are  low  (<50),  the  graph goes wrong (oversized bars, wrong
	scale, very big parse-time...). I have solved this.

	But  if the values are lower (<10), the scale gets crazy. For example,
	for   0  to  3, the Y-Scale say : "blank-0-0-1-2-2-3" or similar. Also
	the graph takes VERY more time to generate.

	Also, I did notice that in sections 6.3.25 and 6.3.26 in the manual, the
	headings on the charts say "SpiderGraph" rather than "PieGraph."  The
	General Description paragraph in both of those sections needs to be changed,
	too.
* Possibility to just plot ticks/labels where the label is != "". Does
  this make sense? How should it work?
* Linear scale investigation: Many datapoints and only show a grouped 
  name for all values, for example sampling every hour but label each day 
  (which is centered)
* Filled line plots with negative values. What is the way to handle this?
* Possibility to add text-labels directly in the new xxPlot() creation?

Sometimes:
==========
* Scientific plots. Investigate some use cases and see what changes needs to be done
* Difference between minor/major tick marks for text-scale, i.e. 
  ticks with and without text labels
* Add pole-zero plots
* Re factoring of the way Y and X axis are implemented. Redo the OOD so that
  we separate the notion of horizontal and vertical axis. This will get
  rid of the horrible non-oo tests axis=="x"