1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23
|
include /usr/share/dpkg/architecture.mk
include /usr/share/dpkg/pkg-info.mk
%:
dh $@ --builddirectory=debian/build
export DEB_BUILD_MAINT_OPTIONS := hardening=+bindnow,+pie
override_dh_auto_test:
VERBOSE=1 dh_auto_test
execute_after_dh_auto_install:
rm -f debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/libpipeline.la
override_dh_installdocs:
dh_installdocs --link-doc=libpipeline1
VERSION_MINOR = $(shell echo "$(DEB_VERSION_UPSTREAM)" | cut -d. -f1,2).0
override_dh_makeshlibs:
dh_makeshlibs -V'libpipeline1 (>= $(VERSION_MINOR))' -- -c4
|