File: Makefile.PL

package info (click to toggle)
libponapi-client-perl 0.002012-1
  • links: PTS, VCS
  • area: main
  • in suites: bookworm, bullseye, sid
  • size: 292 kB
  • sloc: perl: 941; makefile: 2
file content (65 lines) | stat: -rw-r--r-- 1,503 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
# This file was automatically generated by Dist::Zilla::Plugin::MakeMaker v6.012.
use strict;
use warnings;

use 5.008;

use ExtUtils::MakeMaker;

my %WriteMakefileArgs = (
  "ABSTRACT" => "Client to a {JSON:API} service (http://jsonapi.org/) v1.0",
  "AUTHOR" => "Mickey Nasriachi <mickey\@cpan.org>, Stevan Little <stevan\@cpan.org>, Brian Fraser <hugmeir\@cpan.org>",
  "CONFIGURE_REQUIRES" => {
    "ExtUtils::MakeMaker" => 0
  },
  "DISTNAME" => "PONAPI-Client",
  "LICENSE" => "perl",
  "MIN_PERL_VERSION" => "5.008",
  "NAME" => "PONAPI::Client",
  "PREREQ_PM" => {
    "Hijk" => 0,
    "JSON::MaybeXS" => 0,
    "Moose" => 0,
    "URI" => 0,
    "YAHC" => 0,
    "parent" => 0,
    "strict" => 0,
    "warnings" => 0
  },
  "TEST_REQUIRES" => {
    "Test::Moose" => 0,
    "Test::More" => 0,
    "Test::Simple" => "0.98"
  },
  "VERSION" => "0.002012",
  "test" => {
    "TESTS" => "t/010-Client-Request/*.t"
  }
);


my %FallbackPrereqs = (
  "Hijk" => 0,
  "JSON::MaybeXS" => 0,
  "Moose" => 0,
  "Test::Moose" => 0,
  "Test::More" => 0,
  "Test::Simple" => "0.98",
  "URI" => 0,
  "YAHC" => 0,
  "parent" => 0,
  "strict" => 0,
  "warnings" => 0
);


unless ( eval { ExtUtils::MakeMaker->VERSION(6.63_03) } ) {
  delete $WriteMakefileArgs{TEST_REQUIRES};
  delete $WriteMakefileArgs{BUILD_REQUIRES};
  $WriteMakefileArgs{PREREQ_PM} = \%FallbackPrereqs;
}

delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
  unless eval { ExtUtils::MakeMaker->VERSION(6.52) };

WriteMakefile(%WriteMakefileArgs);