File: README-UPGRADE

package info (click to toggle)
libpqxx 6.4.5-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 3,992 kB
  • sloc: cpp: 12,634; sh: 4,426; xml: 1,104; makefile: 309; python: 294; ansic: 3
file content (11 lines) | stat: -rw-r--r-- 578 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
NOTICES FOR USERS UPGRADING FROM EARLIER VERSIONS TO 6.x

As of 6.0, libpqxx requires C++11 or better.  Make sure that your libpqxx is
built against the same version of the C++ standard as your own application, or
there may be build problems.

It may be possible to paper over some mismatches.  If your application build
fails with errors about `std::experimental::optional`, try defining a macro
`PQXX_HIDE_EXP_OPTIONAL` in your application's build.  This will suppress
support for `std::experimental::optional` even if libpqxx was built to assume
that the feature is present.